(SOLVED)can't delete files using delete button on ntfs patition

Forum rules
Before you post please read this
Post Reply
Laurentius
Level 2
Level 2
Posts: 92
Joined: Sat Oct 25, 2014 4:31 pm

(SOLVED)can't delete files using delete button on ntfs patition

Post by Laurentius » Sun Apr 15, 2018 3:03 pm

Hello.
I have just installed linumint 18.3 xfce 64 bit on a netbook with dual boot with windows 7
I set up an ntfs partition where i copied the files that i would like to share between linuxmint and W7 and labelled it DATOS (with gparted)
I want it to automount it at start up.

Here is the problem:
On Thunar, when i try to delete a folder on that ntfs patition whith de keyboard "Delete" button i get this message:
"Unable to find or create trash directory"

i have just realized that i can delete it using the mouse right click context menu "Delete", (a massage advices me that it will be permanently deleted)

So, how can i do to be able to delete files with the keyboard "Delete" button.

I first used gnome-disks to set the automount. Then i read an interlting altair4 post about how to do that on fstab
viewtopic.php?f=50&t=267427#p1455937
I thought my problem could be related to that
So, i edited fstab as altair4 suggested. But the problem remains.

Here is my fstab now:

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=0b75c8ae-04df-4535-81ab-c367f691fe10 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda7 during installation
UUID=fc7fa5f6-62d7-4ca3-9f8c-1158c02f3658 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=e929ceaf-a012-4e52-8441-8e18c7a0d9cd none            swap    sw              0       0
#
#Así monta la particion gnome-disks
#/dev/disk/by-uuid/3FDA508E2E4CD457 /mnt/DATOS auto nosuid,nodev,nofail,x-gvfs-show 0 0
#
# Montado manual de DATOS
UUID=3FDA508E2E4CD457 /media/DATOS ntfs defaults, uid=lm,windows_names 0 0
Is that right?
I notice that although i wrote "uid=lm" on the fstab line (lm is my user account) all in DATOS is owned by root. Even if i create a folder on it it is owned by root. (just to comment)

EDIT: To the forum admin: Please move this post to the forum you consider it should be. I'm not sure if this is the right place
Last edited by Laurentius on Sun Apr 15, 2018 3:43 pm, edited 4 times in total.

Mute Ant
Level 13
Level 13
Posts: 4793
Joined: Tue Sep 03, 2013 7:45 pm

Re: can't delete files using de delete button on ntfs patition

Post by Mute Ant » Sun Apr 15, 2018 3:24 pm

Your /etc/fstab line is broken, it should not have spaces after commas in the options list. Maybe the uid is not being set?
Like this...
defaults,uid=lm,windows_names
...not this...
defaults, uid=lm,windows_names
In Chapter One, Boron slays the entire Marketing Department by explaining Asynchronous Protocols.

Laurentius
Level 2
Level 2
Posts: 92
Joined: Sat Oct 25, 2014 4:31 pm

Re: can't delete files using de delete button on ntfs patition

Post by Laurentius » Sun Apr 15, 2018 3:37 pm

Thank you Mute Ant!
That solved the problem.
Delete button works now.

And files are owned by lm.
But the group of the files is root. Is that right?

Mute Ant
Level 13
Level 13
Posts: 4793
Joined: Tue Sep 03, 2013 7:45 pm

Re: (SOLVED)can't delete files using delete button on ntfs patition

Post by Mute Ant » Sun Apr 15, 2018 8:52 pm

Let's guess it defaults to uid:gid == 0:0 and you only changed the uid of the mount?
In Chapter One, Boron slays the entire Marketing Department by explaining Asynchronous Protocols.

Laurentius
Level 2
Level 2
Posts: 92
Joined: Sat Oct 25, 2014 4:31 pm

Re: (SOLVED)can't delete files using delete button on ntfs patition

Post by Laurentius » Mon Apr 16, 2018 8:15 pm

MuteAnt said:
Let's guess it defaults to uid:gid == 0:0 and you only changed the uid of the mount?
Sorry, MuteAnt. I'm afraid I don't get what you're saying.
Should I change "the uid of the mount"?

Post Reply

Return to “Mounting Partitions”