Page 1 of 1

Unmounting problem

Posted: Thu May 10, 2018 12:52 am
by outhud
Everytime I try to unmount a USB drive using the eject button in Nemo, or using the stop button under Volumes in Disks, I get this error:

Error unmounting /dev/sdb1: Command-line `umount "/media/me/A52A-1451"' exited with non-zero exit status 32: umount: /media/me/A52A-1451: not mounted

The problem is that "A52A-1451" is not the mount point of the drive I want to unmount. No matter what drive I try to unmount, it appears it always tries to unmount A52A-1451 (which is a USB I last used a few weeks ago).

To be clear, if I go to the terminal and umount using the correct mount point of the USB drive, it works.

The problem is that using other methods, for some reason it wants to unmount this A52A-1451 drive, I don't where there is a reference to this on my computer.

This is also affecting Tails installer, when I go to use it, I get:
tails-amd64-3.7.iso selected
Unmounting mounted filesystems on '/dev/sdb'
udisks-error-quark: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error unmounting /dev/sdb1: Command-line `umount "/media/me/A52A-1451"' exited with non-zero exit status 32: umount: /media/me/A52A-1451: not mounted
(0)
Tails installation failed!
udisks-error-quark: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error unmounting /dev/sdb1: Command-line `umount "/media/me/A52A-1451"' exited with non-zero exit status 32: umount: /media/me/A52A-1451: not mounted

Re: Unmounting problem

Posted: Thu May 10, 2018 1:39 am
by catweazel
outhud wrote:
Thu May 10, 2018 12:52 am
...
viewtopic.php?t=129169
https://askubuntu.com/questions/839247/ ... ad-message
https://askubuntu.com/questions/767647/ ... -usb-drive

If they don't help, please post the output of this terminal command:

Code: Select all

cat /etc/fstab
Enclose the results in-between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.