Mounting DVD/CD drive [Solved!!]

Forum rules
Before you post please read this
Post Reply
bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Mounting DVD/CD drive [Solved!!]

Post by bobstead » Sat May 19, 2018 11:56 am

Hi
Have installed Mint 18.3 on an old Acer laptop & it's running fine, except that the optical drive is only recognised/mounted if there is a disk present on boot up. I've read various posts & tried various tweaks so may have made matters worse!!

Currently working & fstab reads as follows:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda5 during installation
UUID=b193c588-1a52-4def-9488-01570123090c / ext4 errors=remount-ro 0 1
# swap was on /dev/sda6 during installation
UUID=b5864a17-8ce0-4991-97a4-d44d9b403c6d none swap sw 0 0
/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-U633A /dev/sr0 auto nosuid,nodev,nofail,x-gvfs-show 0 0


If I insert a disk after booting the drive winds up & then stops, but the disc is not mounted / shown (although I did get a message about a bad or non-existent path at one point.

Any advice appreciated.
Bob
Last edited by bobstead on Tue May 29, 2018 12:19 pm, edited 1 time in total.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5142
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mounting DVD/CD drive

Post by administrollaattori » Sat May 19, 2018 12:19 pm

Make a mount point sudo mkdir /media/cdrom and In the /etc/fstab file a line

Code: Select all

/dev/cdrom /media/cdrom auto rw,noauto,user,exec 0 0

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Mon May 21, 2018 5:05 pm

Hi Thanks for yr advice. Tried that but sadly no joy!

Should I have removed the line:

/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-U633A /dev/sr0 auto nosuid,nodev,nofail,x-gvfs-show 0 0 ??

BobS

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Mon May 21, 2018 5:17 pm

Hi Thanks for yr advice. Tried that but sadly no joy!

Should I have removed the line:

/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-U633A /dev/sr0 auto nosuid,nodev,nofail,x-gvfs-show 0 0 ??

BobS

User avatar
administrollaattori
Level 14
Level 14
Posts: 5142
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mounting DVD/CD drive

Post by administrollaattori » Tue May 22, 2018 3:47 am

bobstead wrote:
Mon May 21, 2018 5:17 pm
Hi Thanks for yr advice. Tried that but sadly no joy!

Should I have removed the line:

/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-U633A /dev/sr0 auto nosuid,nodev,nofail,x-gvfs-show 0 0 ??

BobS
Yes. An another option for /etc/fstab is

Code: Select all

/dev/cdrom      /media/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Tue May 22, 2018 6:57 pm

Thanks again but still no joy! I deleted previous lines & added your suggested new line. Drive winds up but then light just goes out again. If there is a disc in the drive on boot up it now reads fine with no error messages & plays the music.
THis is progress but it would be great to be able to change discs with a reboot.
Bob

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Tue May 22, 2018 7:06 pm

Just got a new error message trying to swap discs:

Error mounting system-managed device /dev/sr0: Command-line `mount "/media/cdrom"' exited with non-zero exit status 32: mount: no medium found on /dev/sr0

Does that explain anything?

Bob

User avatar
administrollaattori
Level 14
Level 14
Posts: 5142
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mounting DVD/CD drive

Post by administrollaattori » Wed May 23, 2018 3:54 am

bobstead wrote:
Tue May 22, 2018 6:57 pm
Thanks again but still no joy! I deleted previous lines & added your suggested new line. Drive winds up but then light just goes out again. If there is a disc in the drive on boot up it now reads fine with no error messages & plays the music.
THis is progress but it would be great to be able to change discs with a reboot.
Bob
Have you tried with data CD or DVD? Are packages libdvdread4 and libdvdnav4 installed?

Code: Select all

apt-cache policy libdvdread4
apt-cache policy libdvdnav4

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Wed May 23, 2018 4:31 am

Hi
Those seem to be installed.

linda@linda-Aspire-5810T ~ $ apt-cache policy libdvdread4
libdvdread4:
Installed: 5.0.3-1
Candidate: 5.0.3-1
Version table:
*** 5.0.3-1 500
500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
100 /var/lib/dpkg/status
linda@linda-Aspire-5810T ~ $ apt-cache policy libdvdnav4
libdvdnav4:
Installed: 5.0.3-1
Candidate: 5.0.3-1
Version table:
*** 5.0.3-1 500
500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
100 /var/lib/dpkg/status
linda@linda-Aspire-5810T ~ $ ^C
linda@linda-Aspire-5810T ~ $

THanks for all of this
Bob

User avatar
administrollaattori
Level 14
Level 14
Posts: 5142
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mounting DVD/CD drive

Post by administrollaattori » Wed May 23, 2018 3:39 pm

What tells inxi -d ?

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Thu May 24, 2018 4:59 am

linda@linda-Aspire-5810T ~ $ inxi -d
Drives: HDD Total Size: 500.1GB (4.0% used)
ID-1: /dev/sda model: WDC_WD5000BEVT size: 500.1GB
Optical: No optical drives detected.
linda@linda-Aspire-5810T ~ $ ^C
linda@linda-Aspire-5810T ~ $

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Thu May 24, 2018 5:00 am

PS: THat was with a disc in the drive.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5142
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mounting DVD/CD drive

Post by administrollaattori » Thu May 24, 2018 1:06 pm

bobstead wrote:
Thu May 24, 2018 4:59 am
linda@linda-Aspire-5810T ~ $ inxi -d
Drives: HDD Total Size: 500.1GB (4.0% used)
ID-1: /dev/sda model: WDC_WD5000BEVT size: 500.1GB
Optical: No optical drives detected.
linda@linda-Aspire-5810T ~ $ ^C
linda@linda-Aspire-5810T ~ $

Code: Select all

dmesg | grep DVD
dmesg | grep CD

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Thu May 24, 2018 1:11 pm

linda@linda-Aspire-5810T ~ $ dmesg | grep DVD
[ 8.185363] ata5.00: ATAPI: TSSTcorp CDDVDW TS-U633A, AC01, max UDMA/100
[ 8.202543] scsi 4:0:0:0: CD-ROM TSSTcorp CDDVDW TS-U633A AC01 PQ: 0 ANSI: 5
linda@linda-Aspire-5810T ~ $ dmesg | grep CD
[ 8.185363] ata5.00: ATAPI: TSSTcorp CDDVDW TS-U633A, AC01, max UDMA/100
[ 8.202543] scsi 4:0:0:0: CD-ROM TSSTcorp CDDVDW TS-U633A AC01 PQ: 0 ANSI: 5
[ 8.216727] cdrom: Uniform CD-ROM driver Revision: 3.20
[ 8.217217] sr 4:0:0:0: Attached scsi CD-ROM sr0
linda@linda-Aspire-5810T ~ $

User avatar
administrollaattori
Level 14
Level 14
Posts: 5142
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mounting DVD/CD drive

Post by administrollaattori » Thu May 24, 2018 2:43 pm

bobstead wrote:
Thu May 24, 2018 1:11 pm
linda@linda-Aspire-5810T ~ $ dmesg | grep DVD
[ 8.185363] ata5.00: ATAPI: TSSTcorp CDDVDW TS-U633A, AC01, max UDMA/100
[ 8.202543] scsi 4:0:0:0: CD-ROM TSSTcorp CDDVDW TS-U633A AC01 PQ: 0 ANSI: 5
linda@linda-Aspire-5810T ~ $ dmesg | grep CD
[ 8.185363] ata5.00: ATAPI: TSSTcorp CDDVDW TS-U633A, AC01, max UDMA/100
[ 8.202543] scsi 4:0:0:0: CD-ROM TSSTcorp CDDVDW TS-U633A AC01 PQ: 0 ANSI: 5
[ 8.216727] cdrom: Uniform CD-ROM driver Revision: 3.20
[ 8.217217] sr 4:0:0:0: Attached scsi CD-ROM sr0
linda@linda-Aspire-5810T ~ $
Eject CDROM first via Terminal and then see if it mounts.

Code: Select all

eject
https://ubuntuforums.org/archive/index. ... 35151.html

https://bugs.launchpad.net/ubuntu/+sour ... bug/412527

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive

Post by bobstead » Fri May 25, 2018 4:46 am

Sadly still no joy - typed eject cdrom with disc in drive.

eject cdrom
eject: tried to use `/dev/cdrom' as device name but it is no block device
eject: unable to find or open device for: `cdrom'

rebooted machine with disc in drive (icon now on screen), and got different error message:

$ eject cdrom
umount: /media/cdrom: umount failed: Operation not permitted
eject: unmount of `/media/cdrom' failed

I see from a brief look at you included links that this is not a one-off problem & using the eject button may be partly to blame?

Bob

bobstead
Level 1
Level 1
Posts: 27
Joined: Thu Jul 04, 2013 1:53 pm

Re: Mounting DVD/CD drive [Solved!]

Post by bobstead » Tue May 29, 2018 12:16 pm

Read through post at https://ubuntuforums.org/archive/index. ... 35151.html and changed fstab to include the line:

/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0 as this is stated to be the default.

Rebooted & so far - It Works!!! :D

Thanks for all the help.

Post Reply

Return to “Mounting Partitions”