Page 1 of 1

Cannot mount external hard drive

Posted: Sun Aug 05, 2018 2:19 am
by Spacecadet
I get the following when trying to use my hard drive:
Error mounting /dev/sdb1 at /media/mama/TOURO: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sdb1" "/media/mama/TOURO"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdb1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.
I was using it to back up my files getting ready to install a new version of Mint. It was working fine and I got a few files over but then accidentally pulled the power cord out in the middle of the process. When I plug it in it makes the 'beep' sound but there is nothing seen and I get the above message which I don't understand because I am new to all this. Would appreciate any help getting it mounted again so I can get the rest of the files off and do a new install.

Re: Cannot mount external hard drive

Posted: Sun Aug 05, 2018 10:23 am
by Flemur
Spacecadet wrote:
Sun Aug 05, 2018 2:19 am
In the first case run chkdsk /f on Windows then reboot into Windows twice.

The usage of the /f parameter is very important!

Re: Cannot mount external hard drive

Posted: Sun Aug 05, 2018 10:51 am
by Spacecadet
I know it says that but I do not understand what it means or how to do it.

Re: Cannot mount external hard drive

Posted: Sun Aug 05, 2018 11:11 am
by Laurent85
You can alternatively from Windows right click the drive, select properties, and in one of the available tabs there is a Check button. From the check button window also perform a Scan drive if command option available.

Re: Cannot mount external hard drive

Posted: Sun Aug 05, 2018 5:56 pm
by Spacecadet
Laurent85 wrote:
Sun Aug 05, 2018 11:11 am
You can alternatively from Windows right click the drive, select properties, and in one of the available tabs there is a Check button. From the check button window also perform a Scan drive if command option available.
So I need to find a Windows computer and run this?

Re: Cannot mount external hard drive

Posted: Sun Aug 05, 2018 6:20 pm
by BG405
If you're not using Windows then there's no need to have NTFS partitions. Presumably the disk came already formatted this way?

Assuming the files you copied still exist in their original locations, your best bet is to reformat it as ext4 using GParted (which you will need to install, via Software Manager, Synaptic or command-line) or, if using KDE, then KDE Partition Manager is already present.

Then you'll be able to copy your files over again. An added benefit is that ext4 is a bit more robust with respect to accidents like this than NTFS is.

Re: Cannot mount external hard drive

Posted: Mon Aug 06, 2018 12:29 am
by Spacecadet
Yes. It came this way. I have never given ay thought to this. Should I format all my future external drives to this?

I installed GParted and changed the file system to ext4. There is a file on there called 'Lost + found' which I cannot read. It has about 25GB in it. No idea what though. There were plenty of files there apart from the ones I moved over. I am happy to lose all of them every thing is backed up elsewhere.

Re: Cannot mount external hard drive

Posted: Mon Aug 06, 2018 2:50 pm
by BG405
Spacecadet wrote:
Mon Aug 06, 2018 12:29 am
Should I format all my future external drives to this?
External hard disks and SSDs, yes I'd recommend that. For flash drives, ext2 is better as it avoids the extra writes you get with ext4 (journalling), which is an issue with the limited number of write cycles flash memory is generally capable of.
Spacecadet wrote:
Mon Aug 06, 2018 12:29 am
There is a file on there called 'Lost + found' which I cannot read.
Looks like it's attempted to save the data it found while preparing the drive. You need to be root to read this I think. Have a look just to check, but you might as well get rid of it as it's just taking up space; you'll need to be root to do that too.

Re: Cannot mount external hard drive

Posted: Mon Aug 06, 2018 11:43 pm
by Spacecadet
BG405 wrote:
Mon Aug 06, 2018 2:50 pm
Spacecadet wrote:
Mon Aug 06, 2018 12:29 am
Should I format all my future external drives to this?
External hard disks and SSDs, yes I'd recommend that. For flash drives, ext2 is better as it avoids the extra writes you get with ext4 (journalling), which is an issue with the limited number of write cycles flash memory is generally capable of.
Spacecadet wrote:
Mon Aug 06, 2018 12:29 am
There is a file on there called 'Lost + found' which I cannot read.
Looks like it's attempted to save the data it found while preparing the drive. You need to be root to read this I think. Have a look just to check, but you might as well get rid of it as it's just taking up space; you'll need to be root to do that too.
How can I do a format as root? I cannot remove the the 'lost & found' folder as I do not have root privileges. When I open the folder as root there doesn't look like there is any thing to remove. Also I cannot copy and paste any files onto the disk. There is no paste option. And drag and drop doesn't work. So I suspect it has all got root privileges now. Not sure if it is the case nor how to fix it. Would like to make the external hard drive usable again.

Re: Cannot mount external hard drive

Posted: Tue Aug 07, 2018 2:43 am
by Sir Charles
Spacecadet wrote:
Mon Aug 06, 2018 11:43 pm
Also I cannot copy and paste any files onto the disk. There is no paste option. And drag and drop doesn't work. So I suspect it has all got root privileges now. Not sure if it is the case nor how to fix it. Would like to make the external hard drive usable again.
In a terminal, runlsblkto find out the path to the mount point for your disk. Next change the ownership from root to your user:

Code: Select all

sudo chown USERNAME:USERNAME /path/to/mountpoint
Replace USERNAME with your actual username and /path/to/mountpoint with the actual path.