Mounts not accessible until clicked in Computer

Forum rules
Before you post please read this
Post Reply
swangle
Level 1
Level 1
Posts: 5
Joined: Thu Jul 26, 2018 3:28 pm

Mounts not accessible until clicked in Computer

Post by swangle » Fri Aug 10, 2018 2:06 pm

I have a peculiar situation. I have some additional internal drives. All mounted since OS install with "Auto mount at startup" enabled.
Any links or applications using the partitions (e.g. steam) fails to see the mounts until I have clicked or accessed it in "Computer" ui or navigating to it directly in a terminal.

So for e.g. steam I have to exit, then go access the mount and re-open steam for it to detect the mount and my installed games.

Image

Image

Code: Select all

System:    Kernel: 4.17.13-041713-generic x86_64 bits: 64 gcc: 8.2.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: desktop Mobo: ASUSTeK model: PRIME Z370-A v: Rev X.0x serial: N/A
           UEFI: American Megatrends v: 0615 date: 04/11/2018
Drives:    HDD Total Size: 3506.7GB (10.0% used)
           ID-1: /dev/nvme1n1 model: Samsung_SSD_960_EVO_250GB size: 250.1GB
           ID-2: /dev/nvme0n1 model: Samsung_SSD_960_EVO_500GB size: 500.1GB
           ID-3: USB /dev/sda model: 015 size: 2000.4GB
           ID-4: /dev/sdb model: Crucial_CT256MX1 size: 256.1GB
           ID-5: /dev/sdc model: Samsung_SSD_850 size: 1000.2GB
Partition: ID-1: / size: 196G used: 31G (17%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 705M used: 502M (77%) fs: ext4 dev: /dev/nvme1n1p2
           ID-3: swap-1 size: 34.29GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
edit: it has been like this since install.

swangle
Level 1
Level 1
Posts: 5
Joined: Thu Jul 26, 2018 3:28 pm

Re: Mounts not accessible until clicked in Computer

Post by swangle » Fri Aug 10, 2018 3:33 pm

Oh snap - I have just learnt about /etc/fstab
Adding the partitions in there fixed the issue.

However, I find it misleading that there is an option in the "Disks" utility that has an option to "Auto mount at startup".

Happy days :mrgreen:

p.s. How do you mark the topic as "Solved"?

User avatar
phd21
Level 17
Level 17
Posts: 7264
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Mounts not accessible until clicked in Computer

Post by phd21 » Fri Aug 10, 2018 4:09 pm

Hi swangle,

You can use the "Disks" option by selecting the drive's partition, clicking the "Gear" (Additional Partition Options), Edit Mount options, turning off the automount (I know it is counter-intuitive), then selecting "Mount at Startup", click "ok", which changes the "fstab" file for you without having to manually edit the "fstab" file. FYI: You can also change the mount locations or add mount parameter options.

Hope this helps ...
.
Drives1.jpg
"Drives" application
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

swangle
Level 1
Level 1
Posts: 5
Joined: Thu Jul 26, 2018 3:28 pm

Re: Mounts not accessible until clicked in Computer

Post by swangle » Fri Aug 10, 2018 4:36 pm

Ah I get it now. However, with Cinnamon it does not say "Automatic mount options", it says: "User session defaults", but I saw how the GUI changed after I manually added it to fstab so I realized how it works now.

Many thanks!

User avatar
phd21
Level 17
Level 17
Posts: 7264
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Mounts not accessible until clicked in Computer

Post by phd21 » Fri Aug 10, 2018 4:44 pm

Hi swangle,

You are welcome...

FYI: Just edit your original post and add <Solved> to its subject line, click submit...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Mounting Partitions”