Sometimes it mounts, sometimes it doesn't!

Forum rules
Before you post please read this
Post Reply
williebthe3rd
Level 1
Level 1
Posts: 20
Joined: Sun Oct 21, 2018 11:07 am

Sometimes it mounts, sometimes it doesn't!

Post by williebthe3rd » Mon Oct 22, 2018 10:27 pm

Greetings, Forum! I'm a well-versed "Windows Geek" that is falling in love with LINUX, and I know that I still have a WHOLE LOT TO LEARN!! :)

I've been running Mint 18 for about a year now in a dual-boot configuration, with Linux being the primary/default in GRUB.

I set it up to auto-mount the Windows XP partition at boot up, and about 75% of the time, it does. :)

It is that other 25% that is annoying. :( When it fails to mount, there is a delay of 10 ~ 20 seconds before the MATE desktop appears. When it does, the Windows drive icon is not there. I cannot "see" that drive in the "Computer" file manager, either. It is simply "invisible" to Linux. Restart, and there it is! (Or not, then a 2'nd restart brings it up, and it's fine.)

I still have to use Windows XP now and then, because my Lexmark S415 All-in-One scanner absolutely refuses to work in Linux. :? (It's screwed-up driver would sometimes flood my kernel.log and syslog files, making them literally fill the HD until it crashed!)

In another post, on another topic, one of the Gurus here said to post the following from the Terminal, so I share it here for your analysis. Note that this is with the Windows partition visible and working:

Code: Select all

 ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=7a46b807-77ed-4f3c-9fa8-fe65f79c9fce /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=72f15a76-a1db-414e-98d0-6a679583a764 none            swap    sw              0       0
/dev/disk/by-uuid/8618238118236EFD /mnt/8618238118236EFD auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=WindowsXP 0 0
And also this one:

Code: Select all

 ~ $ lsblk -f
NAME   FSTYPE LABEL UUID                                 MOUNTPOINT
sr0                                                      
sda                                                      
├─sda2                                                   
├─sda5 ext4         7a46b807-77ed-4f3c-9fa8-fe65f79c9fce /
├─sda1 ntfs         8618238118236EFD                     /mnt/8618238118236EFD
└─sda6 swap         72f15a76-a1db-414e-98d0-6a679583a764 [SWAP]
Thanks in advance for any suggestions to bring this thing up to 100% reliability! 8)

Willie...

User avatar
WharfRat
Level 20
Level 20
Posts: 11826
Joined: Thu Apr 07, 2011 8:15 pm

Re: Sometimes it mounts, sometimes it doesn't!

Post by WharfRat » Mon Oct 22, 2018 11:50 pm

I never liked the gnome virtual filesystem mounts so I use ntfs-3g.

Comment your current fstab line and try

UUID=8618238118236EFD /mnt/8618238118236EFD ntfs-3g noatime,nls=utf8,windows_names,dmask=002,fmask=111,uid=1000,gid=1000 0 0

Make sure that mount point exists when you change the line as I'm not sure if gvfs removes the mount point on shutdown.

Also you might want to use something like /media/windows. The /media folder should be used for locally attached devices.

Just make sure the fstab entry matches the mount point.

Good luck :wink:
ImageImage

williebthe3rd
Level 1
Level 1
Posts: 20
Joined: Sun Oct 21, 2018 11:07 am

Re: Sometimes it mounts, sometimes it doesn't!

Post by williebthe3rd » Wed Oct 24, 2018 10:54 pm

Hey, WharfRat! Thanks for the suggestion. Going to give it a try, and let you know.

I'm getting it, slowly. :) Have to "Open as Administrator" to edit this file, etc... "baby steps".

It will take a few shut down/re-start sequences to see if this made any difference. I'll let you know. :)

Thanks again! :)

Willie...

williebthe3rd
Level 1
Level 1
Posts: 20
Joined: Sun Oct 21, 2018 11:07 am

Re: Sometimes it mounts, sometimes it doesn't!

Post by williebthe3rd » Wed Oct 24, 2018 10:59 pm

Hmmm... OK, no dice. Two-for-two reboots, no Windows drive. I must have missed something.

Here's the fstab file, as edited.

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=7a46b807-77ed-4f3c-9fa8-fe65f79c9fce /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=72f15a76-a1db-414e-98d0-6a679583a764 none            swap    sw              0       0
# /dev/disk/by-uuid/8618238118236EFD /mnt/8618238118236EFD auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=WindowsXP 0 0
UUID=8618238118236EFD /mnt/8618238118236EFD ntfs-3g noatime,nls=utf8,windows_names,dmask=002,fmask=111,uid=1000,gid=1000 0 0
For now, I'll comment out your line, and uncomment mine, to get back to where I was.

Thanks again! :)

Willie...

User avatar
WharfRat
Level 20
Level 20
Posts: 11826
Joined: Thu Apr 07, 2011 8:15 pm

Re: Sometimes it mounts, sometimes it doesn't!

Post by WharfRat » Wed Oct 24, 2018 11:12 pm

It looks OK, did you check the mount point :?:

Try this, create sudo mkdir /media/windows

Then change fstab to

UUID=8618238118236EFD /media/windows ntfs-3g noatime,nls=utf8,windows_names,dmask=002,fmask=111,uid=1000,gid=1000 0 0

To test it there's no need to reboot. Just make sure it's not mounted to /mnt/8618238118236EFD.

If it is unmount it with sudo umount /mnt/8618238118236EFD

Then sudo mount /media/windows
ImageImage

Post Reply

Return to “Mounting Partitions”