Page 1 of 1

fstab mount admin:/// [SOLVED]

Posted: Thu Apr 11, 2019 5:07 pm
by bigjohnv12
I have searched but have been unable to find a solution to the problem I am having.

I have been using Ubuntu for some time and just come from 18.10, however I installed Linuxmint 19.1 as Ubuntu kept having issues with Nautilus.

I have added a line to the fstab to auto mount some samba shares on my network on boot which worked under ubuntu but just doesn't seem to work under LinuxMint

Code: Select all

//IP/4tb /mnt/4TB cifs username=fileshare,password=**,uid=1000,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
when i issue sudo mount -a i get no errors but when i got to /mnt/ using nemo i get the following prompt and have to put in my sudo password.

Is this a Nemo quirk or am i doing something wrong?

thank you for your help

Re: fstab mount admin:///

Posted: Thu Apr 11, 2019 5:17 pm
by catweazel
bigjohnv12 wrote:
Thu Apr 11, 2019 5:07 pm

Code: Select all

//IP/3tb /mnt/3TB cifs username=fileshare,password=**,uid=1000,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
when i issue sudo mount -a i get no errors but when i got to /mnt/ using nemo i get the following prompt and have to put in my sudo password.
I may have missed something in the translation, but your image appears to show that you are selecting a drive with a label of "4TB", while your command up there refers to "3TB".

Re: fstab mount admin:///

Posted: Thu Apr 11, 2019 6:12 pm
by bigjohnv12
sorry the line is the same for 4TB i just happened to take the screenshot of 4Tb, ive edited it so it now makes sense

Re: fstab mount admin:///

Posted: Thu Apr 11, 2019 6:56 pm
by rene
bigjohnv12 wrote:
Thu Apr 11, 2019 5:07 pm
when i issue sudo mount -a i get no errors but when i got to /mnt/ using nemo i get the following prompt and have to put in my sudo password.
mount -a does not in fact report a failing mount. The x's on /mnt/{3,4}TB in your Nemo screenshot mean that your user does not have access to those directories, that ls -l /mnt would supposedly show them to be 0700 or alike (rwx------) which in turn means that the mount did not in fact succeed, since it would be 0777 if it did. Or would here in any case. The permission stuff is is as such likely a red herring, with the issue being just a run of the mill failing CIFS mount. I need to since a few versions explicitly add "vers=1.0" to the mount options for my one and only CIFS mount of a USB stick plugged into my older router. That may be the issue also for you? (the defaults were changed a while ago kernel-sides due to CIFS vulnerabilities).

Re: fstab mount admin:///

Posted: Fri Apr 12, 2019 6:37 pm
by bigjohnv12
Hello

Thanks for your reply, the vers=1.0 seems to have solved it, the shares are now mounting at boot

Thanks again

Re: fstab mount admin:///

Posted: Sat Apr 13, 2019 8:49 am
by altair4
Curious.

The Linux kernels in both Ubuntu 18.10 and Mint 19 instruct mount.cifs to negotiate with the server the correct smb dialect ( vers ) to use starting from smbv2.1 all the way up to smbv3. If the server were set to only accept smbv1 or less when you ran sudo mount -a it would have responded with a somewhat incoherent error message:
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
I wonder why vers=1.0 is required in Mint yet it's not required in Ubuntu 18.10. There's a bit of a performance hit in going all the way back to smbv1.

Re: fstab mount admin:/// [SOLVED]

Posted: Sat Apr 13, 2019 9:02 am
by bigjohnv12
Its quite odd, to be honest its just a laptop for home so not to worried about the performance drop, ive had a look with some speed tests and they all seem ok, bit slower than when i was on Ubuntu 18.10 but still perfectly usable.

Thank you for your help

Re: fstab mount admin:/// [SOLVED]

Posted: Sat Apr 13, 2019 4:18 pm
by rene
Confirmation that mount -a does in fact complain; must've fouled earlier test. Otherwise, yes, curious.