Using a Rapiddisk Ramdisk

Forum rules
Before you post please read this
Post Reply
Menard
Level 2
Level 2
Posts: 63
Joined: Wed May 08, 2019 5:14 am
Location: Angers (France)

Using a Rapiddisk Ramdisk

Post by Menard »

Hi

I have just created a bootable ramdisk with Rapiddisk.
The problem is that I find scripts to use it as physical drive cache but not for simply redirect various caches on it.
I find sripts also for Tmpfs but not for Rapiddisk

- I have no swap and I have 8 Go DDR3
- I create this ramdisk by a bash script in usr/bin and a systemd service
- The ramdisk is mounted in /media/ $ mkdir /media/ramdrive and $ mount /dev/rd0 /media/ramdrive

- The ramdisk is in format Ext 4 and appears in Gnome-disks but not in Nemo

The problem begins when I see that I get no name to use it , or is it rd0 ? for me it is rd0 for what ? only for Rapiddisk ?
So i'm new on Linux ... i am able to create a ramdisk on boot with a complex script BUT I don't know what is /media/ramdrive folder or /dev/rd0 file : ????

So on another thread I read "The easyiest way to use a ramdisk is to create a link in your home directory that points to /run/shm directory" :|
> I feel that it is probably very interesting for me BUT It's chinese !!

On other threads others advice to use fstab editing, but others got problems doing this
So I know how to recover from my mistakes or from crashes because 1- I have a Mint 18.2 64 bootable USB Stick and also Clonezilla Live USB stick with system' partition back ups
Linux Mint 19.3 64bits Cinnamon (Kernel 5.3.0-23)
AMD APU A8 7600 (3100 MHz to 3800 MHz) with DDR3 1833 MHz 4 GB x2
(CPU limited to 4x 3100 Mhz default by no support of the Turbo-core, then after editing grub, supports up to only 3600 MHz)
Menard
Level 2
Level 2
Posts: 63
Joined: Wed May 08, 2019 5:14 am
Location: Angers (France)

Re: Using a Rapiddisk Ramdisk

Post by Menard »

Hi,
Today I add this because I made a mistake, the ramdisk is in fact visible in Nemo, it is called "Volume de 1.1 Go" with path: "/media/ramdrive"
I can copy on it using : $ sudo cp ~/myfile /media/ramdrive

but when I try this

$ ~/media/ramdrive $ sudo ln -s ~/.config/google-chrome config
$ ~/media/ramdrive $ sudo ln -s ~/.cache/google-chrome cache

it works but not on reboot ...

:?
Linux Mint 19.3 64bits Cinnamon (Kernel 5.3.0-23)
AMD APU A8 7600 (3100 MHz to 3800 MHz) with DDR3 1833 MHz 4 GB x2
(CPU limited to 4x 3100 Mhz default by no support of the Turbo-core, then after editing grub, supports up to only 3600 MHz)
Post Reply

Return to “Mounting Partitions”