[SOLVED] Weird NTFS Message

Forum rules
Before you post please read this
Post Reply
ajgringo619
Level 6
Level 6
Posts: 1391
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

[SOLVED] Weird NTFS Message

Post by ajgringo619 » Fri May 31, 2019 4:30 pm

I run a daily backup script (as root) for my dual-boot Win10/Mint19.1 system. The part that handles the Windows side mounts the C: drive, rsyncs the files, then unmounts. This all seems to be working fine.

Now today I noticed some messages that I've never seen before, and a DuckDuckGo search gave me nothing:

Code: Select all

May 31 13:00:01 ntfs-3g[12672]: Version 2017.3.23 integrated FUSE 28
May 31 13:00:01 ntfs-3g[12672]: Mounted /dev/sda4 (Read-Write, label "Windows-C", NTFS 3.1)
May 31 13:00:01 ntfs-3g[12672]: Cmdline options: rw
May 31 13:00:01 ntfs-3g[12672]: Mount options: rw,allow_other,nonempty,relatime,fsname=/dev/sda4,blkdev,blksize=4096
May 31 13:00:01 ntfs-3g[12672]: Ownership and permissions disabled, configuration type 7
May 31 13:00:20 ntfs-3g[12672]: Could not load plugin /usr/lib/x86_64-linux-gnu/ntfs-3g/ntfs-plugin-80000017.so: No such file or directory
May 31 13:00:20 ntfs-3g[12672]: Hint /usr/lib/x86_64-linux-gnu/ntfs-3g/ntfs-plugin-80000017.so: cannot open shared object file: No such file or directory
May 31 13:00:24 ntfs-3g[12672]: Unmounting /dev/sda4 (Windows-C)
Any idea what that ntfs-plugin-80000017.so file is? The directory /usr/lib/x86_64-linux-gnu/ntfs-3g doesn't exist. I also tried searching using apt-file; again nothing.
Last edited by ajgringo619 on Fri May 31, 2019 5:31 pm, edited 1 time in total.
Mint 19.2 XFCE
kernel 4.15.0-64-generic
AMD FX-8350 Eight-Core w/16 GB RAM
Nvidia GeForce 960 w/2GB RAM (435.21)
Image

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Weird NTFS Message

Post by Lord Boltar » Fri May 31, 2019 4:48 pm

looks like it is looking for NTFS-3G check the synaptic package manager and make sure it is installed - in the search block just type in ntfs-3g

Hope this helps
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

ajgringo619
Level 6
Level 6
Posts: 1391
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Weird NTFS Message

Post by ajgringo619 » Fri May 31, 2019 4:51 pm

It's installed:

Code: Select all

$ apt search ntfs-3g | grep ^i
i   libntfs-3g88                                                                         - read/write NTFS driver for FUSE (runtime library)                                             
i   ntfs-3g                                                                              - read/write NTFS driver for FUSE
I never get any errors, whether I mount the partition via the CLI or Thunar.
Mint 19.2 XFCE
kernel 4.15.0-64-generic
AMD FX-8350 Eight-Core w/16 GB RAM
Nvidia GeForce 960 w/2GB RAM (435.21)
Image

User avatar
Flemur
Level 17
Level 17
Posts: 7086
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Weird NTFS Message

Post by Flemur » Fri May 31, 2019 5:26 pm

Could not load plugin /usr/lib/x86_64-linux-gnu/ntfs-3g/ntfs-plugin-80000017.so
I don't have that file either, but...

https://github.com/ebiggers/ntfs-3g-system-compression :
ebiggers/ntfs-3g-system-compression: NTFS-3G plugin for ... - GitHub
https://github.com/ebiggers/ntfs-3g-system-compression

An example full path to the installed plugin is
/usr/lib/ntfs-3g/ntfs-plugin-80000017.so .

It may differ slightly on different platforms. make install will create the ...
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

ajgringo619
Level 6
Level 6
Posts: 1391
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Weird NTFS Message

Post by ajgringo619 » Fri May 31, 2019 5:31 pm

Hmmm...thanks for that, Flemur. Maybe it's just a shameless plug(-in); haven't used NTFS compression since the Win2000 days.
Mint 19.2 XFCE
kernel 4.15.0-64-generic
AMD FX-8350 Eight-Core w/16 GB RAM
Nvidia GeForce 960 w/2GB RAM (435.21)
Image

User avatar
Flemur
Level 17
Level 17
Posts: 7086
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Weird NTFS Message

Post by Flemur » Fri May 31, 2019 6:15 pm

ajgringo619 wrote:
Fri May 31, 2019 5:31 pm
Hmmm...thanks for that, Flemur. Maybe it's just a shameless plug(-in); haven't used NTFS compression since the Win2000 days.
Oh well.
I gather your backup setup is unmounting the partition without doing the backup?
Try a search on (w/quotes)
"Ownership and permissions disabled, configuration type 7"
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

ajgringo619
Level 6
Level 6
Posts: 1391
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: [SOLVED] Weird NTFS Message

Post by ajgringo619 » Fri May 31, 2019 6:19 pm

No, it backs it up fine. Here's the code I'm using:

Code: Select all

mount /dev/sda4 /media/Windows-C
rsync -auvb --exclude Cache /media/Windows-C/Users/ /media/Backup-Data/rsync/windows/daily
umount /media/Windows-C
Maybe it's complaining because I'm not using any mount parameters, but the backup itself works as promised.
Mint 19.2 XFCE
kernel 4.15.0-64-generic
AMD FX-8350 Eight-Core w/16 GB RAM
Nvidia GeForce 960 w/2GB RAM (435.21)
Image

Post Reply

Return to “Mounting Partitions”