[SOLVED] Nemo can't open ext4 partition

Forum rules
Before you post please read this
Post Reply
Rehdon
Level 3
Level 3
Posts: 161
Joined: Tue Nov 29, 2011 9:18 am

[SOLVED] Nemo can't open ext4 partition

Post by Rehdon »

Hi all,
since I had some unused space on my HDD I merged free space and unused partitions into a new one, formatted it and copied stuff on it. Everything seems to work fine, except that Nemo refuses to open one of the already existing partitions! I can see its content via terminal, I can open it with SpaceFM, I can open the folders I linked on desktop, but when clicking on it with Nemo nothing happens.

Using LM 18.3, no problem with partitions before doing this change, checked the UUID and it is correct, I deleted and created a new swap partition now in fstab with correct UUID.

I noticed that I am getting this error message at boot but perhaps it was there already (also the unruly partition is /dev/sda7):

Code: Select all

[    0.000000] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload-210)
[    0.000000] ACPI Error: 1 table load failures, 7 successful (20170831/tbxfload-246)
[    0.098357] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    0.802022] RAS: Correctable Errors collector initialized.
[    9.972439] EXT4-fs (sdb2): re-mounted. Opts: errors=remount-ro
Any ideas?

R
Last edited by Rehdon on Sat Nov 09, 2019 2:40 pm, edited 1 time in total.

gittiest personITW
Level 6
Level 6
Posts: 1181
Joined: Tue May 28, 2019 4:27 pm

Re: Nemo can't open ext4 partition

Post by gittiest personITW »

Hi,
Just to see if it is a permission problem.....
Can you right click an empty space in nemo and select 'open as root'.
A little dangerous red window will open. BE VERY CAREFUL as anything you do in this won't give you an 'are you sure about this?' prompt, it will just go and do it.
See if you can access the partition in question.
If you can, it is a permission problem. Post back.
If you can't, its not likely a permission problem. Post back.

Rehdon
Level 3
Level 3
Posts: 161
Joined: Tue Nov 29, 2011 9:18 am

Re: Nemo can't open ext4 partition

Post by Rehdon »

Hello gittiest personITW (???),
I tried your tip and it worked: root can open that partition, so it is definitely accessible.

Actually, I also tried to open it as normal user and it worked! So it must have been a glitch in Nemo, which was somehow resolved after n reboots :)

Thanks for your help anyway, going to mark this a (misteriously) solved :D

R

Post Reply

Return to “Mounting Partitions”