Page 1 of 1

[SOLVED] Nemo can't open ext4 partition

Posted: Sun Nov 03, 2019 3:40 am
by Rehdon
Hi all,
since I had some unused space on my HDD I merged free space and unused partitions into a new one, formatted it and copied stuff on it. Everything seems to work fine, except that Nemo refuses to open one of the already existing partitions! I can see its content via terminal, I can open it with SpaceFM, I can open the folders I linked on desktop, but when clicking on it with Nemo nothing happens.

Using LM 18.3, no problem with partitions before doing this change, checked the UUID and it is correct, I deleted and created a new swap partition now in fstab with correct UUID.

I noticed that I am getting this error message at boot but perhaps it was there already (also the unruly partition is /dev/sda7):

Code: Select all

[    0.000000] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload-210)
[    0.000000] ACPI Error: 1 table load failures, 7 successful (20170831/tbxfload-246)
[    0.098357] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    0.802022] RAS: Correctable Errors collector initialized.
[    9.972439] EXT4-fs (sdb2): re-mounted. Opts: errors=remount-ro
Any ideas?

R

Re: Nemo can't open ext4 partition

Posted: Tue Nov 05, 2019 3:21 pm
by gittiest personITW
Hi,
Just to see if it is a permission problem.....
Can you right click an empty space in nemo and select 'open as root'.
A little dangerous red window will open. BE VERY CAREFUL as anything you do in this won't give you an 'are you sure about this?' prompt, it will just go and do it.
See if you can access the partition in question.
If you can, it is a permission problem. Post back.
If you can't, its not likely a permission problem. Post back.

Re: Nemo can't open ext4 partition

Posted: Sat Nov 09, 2019 2:39 pm
by Rehdon
Hello gittiest personITW (???),
I tried your tip and it worked: root can open that partition, so it is definitely accessible.

Actually, I also tried to open it as normal user and it worked! So it must have been a glitch in Nemo, which was somehow resolved after n reboots :)

Thanks for your help anyway, going to mark this a (misteriously) solved :D

R