Page 1 of 1

[work around] mount: wrong fs type, bad option - superblock

Posted: Sun Apr 12, 2020 8:25 am
by kuifje09
After installing linux mint 19.2 on an ext4 formatted disk, linux mint 14.4 will not mount ext4 from 19.2
The filesystems ar perfectly clean! I can use and crossmount them, but only not from 14.4.

The ( almost ) complete message is :

Error mounting /dev/sdc1 at
Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdc1" ....
exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error

I tried already a lot of things including compiling/installing the 1.45 e2fstools... but no luck.

The new e2fsfsck says disk is ok| but mount still does not want to mount.
I think I need also a bunch of mout... commands but no idea which.

Anyone has an idea how to ix this. There is already a lot on the web about this but non helped me so far...

I thought of installing the e2fs... and mount... stuff from another distribution like ubuntu 16.4 because that one has no problems...
Mayby from 19.2 ? but how can I do it.


p.s. The problem is because EXT4 is no longer EXT4 , the new ext4 ( in fact ext5 ) has now an extra checksum thing

Re: mount: wrong fs type, bad option - superblock

Posted: Mon Apr 13, 2020 12:26 pm
by kuifje09
Well, there seems no other solution then rewite the whole bunch to some other filesesysten.

Because of everything is growing and the goal of having some dedicated devellop system, copied all to a new disk with more space,
Took some time and reconfiguring.. but its up and running and all cross-mounts to and from several other systems are working.

I am happy again.