mounting usb drives in mint8

Forum rules
Before you post please read this
Post Reply
ajan
Level 1
Level 1
Posts: 19
Joined: Sun Jan 31, 2010 11:44 am

mounting usb drives in mint8

Post by ajan » Sun Jan 31, 2010 11:49 am

i've just installed linux mint 8 over mint 7 which was working fine.but now i cannot mount my usb drive in mint 8.pls help

User avatar
Midnighter
Level 6
Level 6
Posts: 1300
Joined: Tue May 22, 2007 1:52 pm
Location: Western Australia

Re: mounting usb drives in mint8

Post by Midnighter » Tue Feb 02, 2010 4:07 am

By "installed Mint 8 over Mint 7", do you mena you upgraded, or tht you installed with disc, and formatted root partition?

ajan
Level 1
Level 1
Posts: 19
Joined: Sun Jan 31, 2010 11:44 am

Re: mounting usb drives in mint8

Post by ajan » Wed Feb 03, 2010 7:05 am

i installed it using cd.any suggetions

User avatar
Midnighter
Level 6
Level 6
Posts: 1300
Joined: Tue May 22, 2007 1:52 pm
Location: Western Australia

Re: mounting usb drives in mint8

Post by Midnighter » Wed Feb 03, 2010 8:15 am

Are you trying to mount a thumb-drive or an external hard-drive? Either way, both should just auto-mount, it should not require manual intervention. What hardware are you running please? How new is it?

funkytomatoes
Level 1
Level 1
Posts: 2
Joined: Mon Mar 17, 2008 12:31 pm

Re: mounting usb drives in mint8

Post by funkytomatoes » Wed Feb 03, 2010 6:54 pm

Hi, I can confirm the same problem in Helena (I performed a fresh install over Gloria from a live CD). Neither my USB external hard drive nor my USB pen drive will automount, looks like it might be a general problem with auto-mounting USB devices.

lsusb gives:
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 011: ID 0d7d:1900 Phison Electronics Corp. USB Thumb Drive
Bus 002 Device 010: ID 058f:6391 Alcor Micro Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The devices are both seen by gparted but are not mounted.

funkytomatoes
Level 1
Level 1
Posts: 2
Joined: Mon Mar 17, 2008 12:31 pm

Re: mounting usb drives in mint8

Post by funkytomatoes » Wed Feb 03, 2010 7:22 pm

Installing gnome-volume-manager from synaptic and rebooting worked for me (on my Dell Inspiron 1525) - the devices are not recognised if they are plugged in when the machine is booted but if they are plugged in any time afterwards they are picked up.

ajan
Level 1
Level 1
Posts: 19
Joined: Sun Jan 31, 2010 11:44 am

Re: mounting usb drives in mint8

Post by ajan » Fri Feb 05, 2010 4:18 am

i'm using lenovo G430 laptop.my pen drive .gparted shows it as unallocated.but its actually fat32 formatted and is working fine in other computers and vista installed in my laptop,in mint 7 b4 i installed helena.even when my nokia phone was connected to it in data storage mode it shows the same.

User avatar
Leppie
Level 4
Level 4
Posts: 444
Joined: Sun Feb 07, 2010 8:54 pm

Re: mounting usb drives in mint8

Post by Leppie » Thu Feb 11, 2010 4:50 pm

have you checked dmesg?

Code: Select all

dmesg | tail
also /var/log/messages could shed some light on this:

Code: Select all

tail -f /var/log/messages
hit enter a couple of times to mark the insertion of the usb stick, then insert the usb stick and see what appears.
Last edited by Leppie on Sun Feb 14, 2010 7:17 pm, edited 1 time in total.
Cleanflash: resolve your flash issues the easy way

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: mounting usb drives in mint8

Post by Husse » Sat Feb 13, 2010 12:57 pm

ajan
you have asked the same in another topic already
What about writing some explanation to your question - I don't understand your post
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
T J Tulley
Level 5
Level 5
Posts: 559
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: mounting usb drives in mint8

Post by T J Tulley » Tue Mar 09, 2010 12:41 pm

Using LinuxMint-8 (Helena) on a Dell Inspiron 1750 Laptop
[2.2GHz Intel Premium Dual core cpu, 4 GB RAM, 500 GB hdd]
Dual booting with Windows-7/64 Home Premium

My problem is slightly different: my external SATA 500-GB drive with 8 various partitions has up to now always (for 2 months) auto-mounted all the partitions on /media when connected via USB-2. They were all open in the same workspace. I could read and write to the first (NTFS) partition which is labelled SATABkps and I used this partition as an external backup repository. I closed the others and they remained mounted and showing on the Desktop screen, with icons showing either their labels (if present) or their sizes.

Suddenly this automount behaviour has stopped happening - I tried booting with it connected - no show; connecting after boot, I see in "Computer" 4 items named: Generic STORAGE DEVICE. The R-click menu offers only Open (which fails), Copy, Rename, Safely Remove Drive and Properties. Properties reveals only that they open with File Browser. If I select Safely Remove Drive, I get a box saying:
"Unable to stop drive
Error detaching: helper exited with exit code 1: sense buffer empty
Error SYNCHRONIZE CACHE for /dev/sdf: Success
sense buffer empty
Error STOP UNIT for /dev/sdf: No such file or directory"

In the last line, the device varies from sdc to sdf for the 4 items.

Now: can I use a command to mount this partition? Here is a record of my attempt so far:

theo@TJTLAP3 ~ $ sudo mount /media/SATABkps /dev/sdc
[sudo] password for theo:
mount: special device /media/SATABkps does not exist
theo@TJTLAP3 ~ $ sudo mkdir /media/SATABkps
theo@TJTLAP3 ~ $ sudo mount /media/SATABkps /dev/sdc
mount: /media/SATABkps is not a block device

[Edit 5:00 pm - forum clock's an hour fast!]:
I did a $ CD /dev and then ls -a shows all those devices are present.
I wish I could change the default typescript colours in that screen - the yellow is almost unreadable.
[End of edit]
[Edit 2 - 12:09 pm 10/3/2010]
I've just inserted my Corsair 4 GB Flash stick which mounted at once. The external hd still won't mount.
[End of Edit 2]

As ever, grateful for any help!

With many thanks,

Yours hopefully, -

Theo Tulley.

futureyes
Level 1
Level 1
Posts: 1
Joined: Tue Mar 16, 2010 5:38 am

Re: mounting usb drives in mint8

Post by futureyes » Tue Mar 16, 2010 5:45 am

I can also verify the same problem. USB-2.0 flash drive and external HDD's are not auto-initializing after boot. This system is a AMD62 3200+, ASUS 6150 Mortherboard, 2GB 2-3-2-5 DDR1-400MHz, NV-7800gt, 250GBWD-HDD. System worked perfectly with Mint7 & Win7. But no USB drives mounting on Mint 8. :-(

User avatar
T J Tulley
Level 5
Level 5
Posts: 559
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: mounting usb drives in mint8

Post by T J Tulley » Fri Mar 26, 2010 2:51 pm

The above was a fortnight ago. I tried again 2 days ago - inserted USB connection for SATA drive under Linux-8: no show. Not even showing in My Computer (Desktop icon).

Then I opened a directory and navigated to root, then /dev, and sdc7 was there with its 8 partitions! I unplugged it and they disappeared! Then re-inserted, and they automounted as they had previously done. I closed the ones I didn't want, and successfully performed a backup to the remaining 40 GB ntfs partition.

Today, inserting the connection again gives automount as before.
Very odd!

Hoping that this helps -



Theo Tulley.

tj.tulley@physics.org

User avatar
omkar.nisal
Level 1
Level 1
Posts: 3
Joined: Mon Apr 20, 2009 7:42 pm
Contact:

Re: mounting usb drives in mint8

Post by omkar.nisal » Sun Mar 28, 2010 10:11 am

I am using kingston 4 gig usb thumb drive
today it just made contents disappear.. i mean the drive was not listed
but lsusb shows 128mb drive!

i thought my drive went bad.
but then formatter it to fat32 with gparted and it worked fine

did some more copying and lo.. it did it again.

Ejecting the drive from Nautilus 2.28.1 and re inserting it in same machine ,
same port as well as different port did not make the drive available in Nautilus 2.28.1
Omkar Nisal
Director, OTS Private Limited
www.otsnow.com

User avatar
hunkirdowne
Level 1
Level 1
Posts: 33
Joined: Sat Nov 14, 2009 8:18 am

Re: mounting usb drives in mint8

Post by hunkirdowne » Sun Mar 28, 2010 7:09 pm

EDIT: This does nothing to answer how to get automount to work but provides what I have come up with a suitable (to me, anyway) alternative. I can mount my drives as user this way. (Personally, I prefer the GUI to not automount, at least not pop open with a folder window. Your "mileage" probably varies. ;-)

I use the CLI for discovering, mounting, and eventually hacking fstab for all my external devices. Not that it's better, it's just that I like it that way. I don't like my USB drives automounting and I don't like guessing the little letter at the end of /dev/sd_ because I'm basically a deviant. :lol:

That said, I fdisk to discover that, for the moment, my USB thumb drive is /dev/sdc. I then go into the CLI and learn it's UUID. If I'm really on the ball I check the label, if it exists, and sometimes I will use it instead but I've had mixed results. Caution about UUID: If you reformat your USB, your UUID changes. After that I will use the UUID to make an entry into fstab so my settings are persistent.

If you are not familiar with all of the commands used below, please consult the man pages (or info). For example:

Code: Select all

man fdisk

or

info fdisk
Carrying on...

First, make some directories for your devices. I'll post two examples.

Code: Select all

sudo mkdir /media/cruz0256        # This is for my 256 MB thumbdrive.  (FAT-32 filesystem)
sudo mkdir /mnt/OneTouch4         # This is for my 1 TB external USB/firewire hard drive.  (NTFS filesystem)

Find the device name of the USB disk.

Code: Select all

sudo fdisk -l | grep -v 'sda'
This will ignore the first installed disk. In my case this is my one and only hard disk.

Now that I have the device name, I can use it in my next command to get the UUID.

Code: Select all

ls -l /dev/disk/by-uuid | grep '<dev>'
(replace "<dev>" with "sdc" or whichever is your three letter device name)
Grab the UUID corresponding to your device and stick it in fstab.

Code: Select all

sudo cp -ip /etc/fstab /etc/fstab.backup        # backup, backup, backup!
sudo vim /etc/fstab
Whilst in fstab, add a line that looks something like these ones <ahem>:

Code: Select all

UUID=498E-1A54  /media/cruz0256  vfat  rw,users,async,nodev,noatime,noauto,noexec  0  0
UUID=55D123D9E79ABFAB /mnt/OneTouch4 ntfs-3g rw,nodev,uid=1000,allow_other,umask=0002 0 0
Again, please check the man pages even on stuff like fstab which will let you know why I might want to use 'async' and 'noatime' for my thumbdrives. Also, note that the way I have the OneTouch set up I can pretty much wipe the disk clean in one swell foop so if you have fat fingers and no backups, change the 'rw' to 'ro' and things will go nicely for you (until you try to write to the drive which you can't). Another alternative would be to mount as root with only root having permission to write, all others read-only. I don't do that so the next is a guess: Change the "uid=1000" to "uid=0"

There is almost certainly a more elegant (Minty? ;-) way to do this and I invite all to jump all over my stuff and point out a better way. :)
--
\___...---^---...___/
_\-------------------/

dsmurl
Level 1
Level 1
Posts: 5
Joined: Thu Apr 01, 2010 10:13 pm

Re: mounting usb drives in mint8

Post by dsmurl » Thu Apr 01, 2010 10:24 pm

I installed mint 8 on my new laptop and it will not auto mount the usb dirves. The volumes show up in the "administration>disk Utility" but do not auto mount. they do on my desktop computer but not on this new laptop I installed mint 8 on. it is an MSI A6000 with 4gigs of ram and the core 2 duo. Here is some logging info that I found but I still can't figure it out. I have auto mount set in gconf-editor also. Can someone help me out with getting my thumb drive and other usb drives to automount?

dsmurl@blue ~ $ dmesg
[ 414.184413] usb 1-7: USB disconnect, address 5
[ 416.110071] usb 1-7: new high speed USB device using ehci_hcd and address 6
[ 416.263664] usb 1-7: configuration #1 chosen from 1 choice
[ 416.279710] scsi4 : SCSI emulation for USB Mass Storage devices
[ 416.280952] usb-storage: device found at 6
[ 416.280956] usb-storage: waiting for device to settle before scanning
[ 421.280383] usb-storage: device scan complete
[ 421.673334] scsi 4:0:0:0: Direct-Access Lexar USB Flash Drive 1100 PQ: 0 ANSI: 0 CCS
[ 421.674053] sd 4:0:0:0: Attached scsi generic sg3 type 0
[ 421.677719] sd 4:0:0:0: [sdc] 7831552 512-byte logical blocks: (4.00 GB/3.73 GiB)
[ 421.679411] sd 4:0:0:0: [sdc] Write Protect is off
[ 421.679417] sd 4:0:0:0: [sdc] Mode Sense: 43 00 00 00
[ 421.679421] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 421.683412] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 421.683420] sdc: sdc1
[ 421.692414] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 421.692423] sd 4:0:0:0: [sdc] Attached SCSI removable disk
dsmurl@blue ~ $ lsusb
Bus 001 Device 006: ID 05dc:a768 Lexar Media, Inc.
Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 001 Device 002: ID 5986:0241 Acer, Inc
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 046d:c03e Logitech, Inc. Premium Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Post Reply

Return to “Mounting Partitions”