Brother HL-2135W woes

Forum rules
Before you post please read this
Level 1
Level 1
Posts: 2
Joined: Sat Sep 07, 2013 9:04 am

Brother HL-2135W woes

Postby enuenu » Sat Sep 07, 2013 9:18 am

Just installed Mint 15 for first time after a long lay off from Linux. First thing I did was try to install my Brother HL-2135W printer without success. It seemed to recognize it and install it quite quickly. However "print a test page" resulted in a very long wait then endless sheets of blank paper being spewed from the printer. Cancelling the job would not stop it. I had to turn printer power off and open it up to remove sheets that were halfwat through the rollers.I repeated the entire process twice with same result. Any help appreciated. I found a Website with Linux drivers; ... index.html

but I have no idea which file to download or what to do with it.

Any help appreciated. Last time I used Linux 5 years ago, printing was problematic. Feel like I'm in groundhog day already.

User avatar
Level 7
Level 7
Posts: 1526
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.

Re: Brother HL-2135W woes

Postby daveinuk » Sat Sep 07, 2013 9:34 am

I don't have your printer but just checked it out on the site you posted about, the site points to the driver in this link which is for the 2130, it is a .deb file so you just download/save it then go to your downloads folder and double click to open and download/install the driver.


Edit: Link . . .. :lol:

Level 1
Level 1
Posts: 2
Joined: Sat Sep 07, 2013 9:04 am

Re: Brother HL-2135W woes

Postby enuenu » Sat Sep 07, 2013 9:56 pm

Thanks. Downloaded the package suggested;

Double click it and the package installer installs it OK.
Then from Menu I go to Administration > Printers and am told no printers configured.

I click Add Printer and see my USB printer at the top of the list.
I click Forward and it is Searching for Drivers.

I am then presented with New Printer - Choose Driver
Select printer from Database is suggested. I have been through this the first time around and the printer did not work.
I could Provide PPD file but do not know where this may be, perhaps when I installed the cupswrapper package a PPD file was saved somewhere.

I am at a dead end. Any help appreciated.

Level 1
Level 1
Posts: 1
Joined: Sat Oct 05, 2013 2:44 pm

Re: Brother HL-2135W woes

Postby IWPCs » Sat Oct 05, 2013 2:48 pm

Once you've installed the files from the Brother site, point CUPS to /usr/share/cups/model/HL2130.ppd using 'Choose File'. Worked for me...

BTW, for anybody trying something similar, I found this by opening the RPM version of the driver and navigating to the cupswrapper file located at the end of the folder chain. Opening this file gave its location.

Level 1
Level 1
Posts: 5
Joined: Fri Mar 07, 2014 8:34 am

Re: Brother HL-2135W woes

Postby moonstarter666 » Wed Apr 09, 2014 6:02 pm

I've just bought the same printer (Brother HL-2135W) and the same happens to me in the Linux Mint 16 as was described in the original post.

Please visit the following link from brother website:

It also has an explanation what to do with the downloaded driver file.

It says:
Step5. Run the tool:

Code: Select all

bash linux-brprinter-installer-*.*.*-* Brother machine name

Instead of "Brother machine name" write "HL-2135W"

Level 7
Level 7
Posts: 1892
Joined: Mon May 11, 2009 1:21 am

Re: Brother HL-2135W woes

Postby pdc_2 » Wed Apr 09, 2014 6:35 pm

welcome to the forum moonstarter; not entirely clear what you have done; so if I work through things, and you can confirm things;

so you opted for the Brother installer tool; which should be a good idea;

it comes down as linux-brprinter-installer-2.0.0-1.gz

from the page ... &type3=625 it would seem the commands would be:

cd Downloads (assuming one downloaded the file to this directory and saved it there)
gunzip linux-brprinter-installer-2.0.0-1.gz
sudo bash linux-brprinter-installer-2.0.0-1 HL-2135W

then Brother say
When you see the message "Will you specify the DeviceURI ?", For USB Users: Choose N(No) we are assuming you have a standalone computer with printer connected by usb cable: correct assumption?

if you use the UP arrow from your keyboard; when the terminal is open; you can go back and see the history of the commands you used: can you confirm the above commands please?

and to check what was installed can you copy and paste this command into a terminal please
dpkg -l | grep Brother

and copy and paste back what you get please

and if you click on this link http://localhost:631/printers/ it should open CUPS (printer control) in a web browser page but it is only looking on your system the HL-2135W listed there; I enclose a snapshot below of what our MG3100 setting looks like;

On looking to see what files are needed......from a link I used to have to the Brother site......seems to me Brother have had a big backroom tidy-up: one can no longer find the individual lpr and cupswrapper packages: Brother have standardised on using the script: so one can only use the script these days

Level 1
Level 1
Posts: 5
Joined: Fri Mar 07, 2014 8:34 am

Re: Brother HL-2135W woes

Postby moonstarter666 » Thu Apr 10, 2014 12:15 am

I am sorry to hear that you're still having the issue since September 2013.

I have windows 7 and Linux on the same laptop(MSI).

1. I made the printer work on windows (wireless) - as described in Quicksetup guide for 2135W
(there is a step where you configure the wireless access of the printer [to the router])

2. In the linux I downloaded and executed the previously attached commands
(In this step I didn't connect the printer to Lniux OS via USB - totally wireless.
Since I have another linux laptop and linux PC, wanted to make sure I could make the driver installation without any wired connections)

3. When I encountered the URI question in the terminal - answered "Yes" (since I've a wireless network topology)
4. I got some options for URI -> "IP address" was chosen (I put the IP address of the printer, that I got during windows installation)

After opening the http://localhost:631/printers/ - I got the Queue list with 1 entry HL2310
After clicking it - I got the following output:
HL2130 (Idle, Accepting Jobs, Not Shared, Server Default)
Description: HL2130
Driver: Brother HL2130 for CUPS (grayscale, 2-sided printing)
Connection: socket://
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

The output of the dpkg -l | grep Brother is:

Code: Select all

ii  cupswrapperhl2130                           2.0.4-2                                 i386         Brother HL2130 CUPS wrapper driver
ii  hl2130lpr                                   2.1.0-1                                 i386         Brother HL-2130 LPR driver
ii  printer-driver-ptouch                       1.3-6                                   i386         printer driver Brother P-touch label printers

I hope it will help you.

Return to “Printers & Scanners”