Samsung ML-1865

Forum rules
Before you post please read this
Post Reply
handers
Level 1
Level 1
Posts: 1
Joined: Sat Jul 07, 2012 5:27 am

Samsung ML-1865

Post by handers » Sat Jul 07, 2012 5:46 am

Can anyone guide me through the process of setting up this printer (samsung ml-1865)

I keep getting this printed "internal error": please use proper driver ... position 0x0 (0) ... system h6fw_5.49/xl_op ... line 180 .... version SPL 5.49 10-20-2010 (so the usb-connection is properly recognised, and something is actually printed)

I found a tutorial in Spanish, which did not work out for me using Google translate, and found several suggestions on Ubuntu forums, none of which i've been able to make work (but that may have polluted the code) - I have tried the Samsung unified driver, alas to no avail - that is most likely due to my inexperience with Linux - I'm a newbie!

thanks

442
Level 1
Level 1
Posts: 5
Joined: Tue Sep 27, 2011 3:03 am

Re: Samsung ML-1865

Post by 442 » Sun Jul 08, 2012 2:02 pm

I got mine working in Wheezy after installing CUPS, the Samsung Unified Driver, and the Samsung Smart Panel. Downloading the ppd from Openprinting.org did not work. CUPS will ask you to select a ppd, which I got from the Unified Driver. This printer was plug and print in LMDE when I bought it- now it's a CF. I can't even get CUPS to work in LMDE.

442
Level 1
Level 1
Posts: 5
Joined: Tue Sep 27, 2011 3:03 am

Re: Samsung ML-1865

Post by 442 » Sun Aug 05, 2012 5:08 pm

http://news.siduction.org/2012/06/samsu ... r-journey/
Samsung Printer Journey
2012/06/29 in Blog by Ferdinand Thommes | No comments
I bought a nice and small Samsung ML 1675 Laserprinter not long ago. It is supposed to work with the Samsung Unified Linux Driver. So I googled and went to the Samsung Website and downloaded the driver and installed it. That did not bring the printer to life. The cups interface did not even see the printer anymore. I left things as they were, as it was late. The next morning my dist-upgrade was blocked by strange errors that proved to be from the Samsung mfp-driver. Removing the lot fixed the problems. So, do not install the drivers from the Samsung website, they do not work.

So I dug a bit deeper in Google and found The Samsung Unified Linux Driver Repository.

Here are the steps to get any printer / multidevice, that needs to use this driver, working in no time at all:

open a shell and become root:

su [ENTER]

root@siductionbox: cd /etc/apt/sources.list.d [ENTER]

root@siductionbox:/etc/apt/sources.list.d# touch Samsung_Printer.list && echo deb http://www.bchemnet.com/suldr/ debian extra > Samsung_Printer.list && wget -O - http://www.bchemnet.com/suldr/suldr.gpg | apt-key add – && apt-get update [ENTER]

This will set up the needed repository and install the gpg-key for it. Now you want to install the drivers:

apt-get install samsungmfp-data samsungmfp-configurator-qt4 samsungmfp-configurator-data samsungmfp-driver samsungmfp-driver-4.00.35 printer-driver-splix

That will install the needed drivers for just the printer. If that is all you need, turn on your printer and enjoy.

If you have a multi-device that can also scan, you need some more software. As with siduction, the user is already a member of group ‘lp’. there is no need for action here. Should you use a different distribution, check this by issuing, as user:

devil@siductionbox:~$ groups [ENTER]

devil lp dialout cdrom floppy audio dip video plugdev users fuse scanner netdev

If lp is present, you just need to install some extra packages on top of the above:

apt-get install samsungmfp-scanner samsungmfp-scanner-sane-fix samsungmfp-scanner-sane-fix-multiarch

NOTE: before installing the latter 2 packages, read the output of apt-cache show <packaganame> to see if they apply to you.

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Samsung ML-1865

Post by eanfrid » Sun Aug 05, 2012 5:29 pm

Why didn't you try and install the native Ubuntu/LM driver named "printer-driver-splix" ? Or is it what you called Samsung Unified Driver ? I have a ML-2250 which works perfectly with this standard driver (splix).

Package self-comment:
"Support for printing to SPL2- and SPLc-based printers. These are most
of the cheaper Samsung laser printers which do not understand standard
languages like PostScript or PCL. Both monochrome (ML-15xx, ML-16xx,
ML-17xx, ML-2xxx) and color (CLP-5xx, CLP-6xx) models are supported."
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

442
Level 1
Level 1
Posts: 5
Joined: Tue Sep 27, 2011 3:03 am

Re: Samsung ML-1865

Post by 442 » Mon Sep 17, 2012 2:46 pm

Wish I had found this sooner: http://forums.linuxmint.com/viewtopic.p ... b7#p584572

and here: http://www.openprinting.org/printer/Sam ... g-ML-1865W
Speedyx • 7 months ago −
io possiedo una Samsung ML-1865W :
da aggiungi stampante .... con driver
Samsung ML-2152WPS CUPS+Gutenprint v.52.6 Semplified
funziona tutto !
Works great.

Post Reply

Return to “Printers & Scanners”