[Solved]Canon MG5150 not working

Forum rules
Before you post please read this
Level 1
Level 1
Posts: 4
Joined: Sat Mar 30, 2013 4:21 am

[Solved]Canon MG5150 not working

Postby rabcor » Sun Mar 31, 2013 8:52 am

i downloaded the drivers from here

and then installed them from the .sh scripts (for the scanner and the printer)

After that the printer looks like it's working but it seems to hang on "sending files to printer"

I also thought of trying to use the CUPS interface to install the drivers but didn't find the proper drivers in there.

Also tried deleting the printer from the printer configuration thing and re-adding it but that doesn't help me at all.

I'm a complete novice when it comes to dealing with printers in linux, does anyone know how i can fix this?
Last edited by rabcor on Tue Apr 02, 2013 6:20 pm, edited 1 time in total.

Level 1
Level 1
Posts: 4
Joined: Sat Mar 30, 2013 4:21 am

Re: Canon MG5150 not working

Postby rabcor » Tue Apr 02, 2013 6:19 pm

Dang these must be the least responsive linux forums i've ever been to.

Here's what i had to do to fix it (and this took like an hour of googling). (found out through this)

After installing the drivers like previously described i had to...

Code: Select all

# cd /usr/lib
# ls libcn*

and then

Code: Select all

# ln -s libcnnet.so.X.X.X libcnnet.so
# ln -s libcnbpcmcmX.so.X.X.X libcnbpcmcmX.so
# ln -s libcnbpcnclapiX.so.X.X.X libcnbpcnclapiX.so
# ln -s libcnbpcnclbjcmdX.so.X.X.X libcnbpcnclbjcmdX.so
# ln -s libcnbpcncluiXXX.so.X.X.X libcnbpcncluiX.so
# ln -s libcnbpoX.so.X.X.X libcnbpoX.so
# ln -s libcnbpessX.so.X.X.X libcnbpessX.so

Where "X" is the integer (number) that you get when you do the ls. for example (from the link i provided)

Code: Select all

# ln -s libcnbpess377.so.3.3.3 libcnbpess377.so

Became something like

Code: Select all

# ln -s libcnbpess373.so.3.3.3 libcnbpess373.so

On my pc.

Hope i helped someone :)

Level 7
Level 7
Posts: 1972
Joined: Mon May 11, 2009 1:21 am

Re: [Solved]Canon MG5150 not working

Postby pdc_2 » Sun Apr 07, 2013 4:06 am

Hi rabcor; not sure if you subscribed to this thread; so not sure if you are still out there;

sorry to hear of your issues installing the Canon drivers for the MG5150:

you went to Canon Europe; and I see they issue a big tar package; with deb and rpm and source packages; one has to drill down to find the install.sh script

did you use the terminal?

You say

I also thought of trying to use the CUPS interface to install the drivers

and then

but didn't find the proper drivers in there.

......that sort of makes one wonder if the install went according to plan; eg I installed the Canon driver for my MG3100series printer and the CUPS is as in the thumbnail

......this view of CUPS comes from just installing the Canon drivers;..........it was just there.........I didn't add it later.........

if one wants to check if they have installed correctly, the command

sudo dpkg -l | grep cnijfilter

looks to see what is installed;

so I really wonder about all this: David Batson is a very experienced mandriva user; and when mandriva split, mageia was the fork from the current iteration of mandriva; I wonder where he got the need to link from...........


If anyone googles this thread later; for a how-to:

I would recommend the Canon Asia site http://support-asia.canon-asia.com/cont ... 01602.html as the deb and rpm packages are separate.........

and so download the MG5100 series IJ Printer Driver Ver. 3.40 for Linux (debian Packagearchive) which comes down as the cnijfilter-mg5100series-3.40-1-deb.tar.gz

the commands would be

cd Downloads

tar -zxvf cnijfilter-mg5100series-3.40-1-deb.tar.gz

cd cnijfilter-mg5100series-3.40-1-deb


and all should be done..........scangearmp to run the scanner is installed the same way and to run it, the command is

Return to “Printers & Scanners”