[SOLVED] Problems with driver for Canon pixma MP 140

Forum rules
Before you post please read this
Post Reply
User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

[SOLVED] Problems with driver for Canon pixma MP 140

Post by turboscrew » Thu May 30, 2013 5:10 am

With "my HW" I mean Canon pixma MP 140 printer and Intel HD graphics 2500 (Intel i3 ivy bridge)?

With Nadia I had to get the graphics driver from http://ppa.launchpad.net/glasen/intel-driver/ubuntu
That was really no problem, but my printer - canon pixma mp140 is.
It prints a job and freezes so that it doesn't even listen to power button. The power chord needs to be disconnected to reset the printer.
I tried http://ppa.launchpad.net/till-kamppeter/ppa/ubuntu and http://ppa.launchpad.net/michael-gruz/c ... ble/ubuntu
but no luck.
Last edited by turboscrew on Sun Oct 27, 2013 5:13 am, edited 1 time in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 24132
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Does Olivia support my HW

Post by xenopeek » Thu May 30, 2013 5:36 am

Intel HD graphics 2500 (i3 processor) will work fine. I have Intel HD Graphics 3000 on i5 processor, same processor generation though a bit faster. Works fine.

You already have another topic about the printer, here: http://forums.linuxmint.com/viewtopic.php?f=51&t=132652. Canon hasn't stepped up to support its products, so this still needs some work. I found this PPA, which at least has the two packages you need built for Ubuntu Raring (which is compatible with Linux Mint Olivia): https://launchpad.net/~michael-gruz/+ar ... anon-trunk
Image

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Does Olivia support my HW

Post by turboscrew » Sat Jun 01, 2013 4:15 am

About the other posting... sorry, I just lost hope - no responses for about a month...
I've been asking also in Linuxquestions and Ubuntu forums, and I have got quite a number of views, but no replies.

Thanks, I'll try the trunk version.

The other branches didn't work.

I added repos

Code: Select all

http://ppa.launchpad.net/michael-gru...-stable/ubuntu quantal main
http://ppa.launchpad.net/michael-gru...-stable/ubuntu raring main
i
nto Synaptic.

There are no 64-bit drivers for MP140 and the install of 32-bit fails due to dependancy:

Code: Select all

cnijfilter-mp140series-32:
 Depends: cnijfilter-mp140series (>= 3.90)
and that cnijfilter-mp140series (without the "-32" postfix) is not found.

Funny, because in the Quantal package description build status includes:

Built files

Code: Select all

Files resulting from this build:

...

cnijfilter-mp140series-32_3.90-63~quantal1_amd64.deb (1.5 KiB)
cnijfilter-mp160series-32_3.90-63~quantal1_amd64.deb (1.5 KiB)
cnijfilter-mp190series-32_3.90-63~quantal1_amd64.deb (1.5 KiB)
...
and raring package:

Code: Select all

 cnijfilter-mp140series-32_3.90-63~raring1_amd64.deb (1.5 KiB)
cnijfilter-mp140series_3.90-63~raring1_i386.deb (1.6 MiB)
cnijfilter-mp160series-32_3.90-63~raring1_amd64.deb (1.5 KiB)
cnijfilter-mp160series_3.90-63~raring1_i386.deb (1.5 MiB)
cnijfilter-mp190series-32_3.90-63~raring1_amd64.deb (1.5 KiB)
cnijfilter-mp190series_3.90-63~raring1_i386.deb (1.6 MiB)
Those are, however, not found in synaptic. I wonder why.

User avatar
xenopeek
Level 24
Level 24
Posts: 24132
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Does Olivia support my HW

Post by xenopeek » Sat Jun 01, 2013 4:29 am

Alternative; remove the PPAs and just download the packages you think you need directly from the PPA website. Once downloaded, just double-click to install them.
Image

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Does Olivia support my HW

Post by turboscrew » Sat Jun 01, 2013 5:32 am

The packages installed fine in Nadia (14) - there was only 32-bit divers compiled for amd64 I guess.

The driver works, but not fine.
I don't know what's the problem, but printing one page text file (about hald pages text) takes about 10 minutes.
Maybe I should install Olivia instead and try with that. Or try pixma MP 150 drivers.

Document print status says (Can't copy the line here - Document print status doesn't seem to allow copying):
"Time submitted 10 minutes ago"
and
"Status processing"

BUT: It finishes the printing eventually, and doesn't hang up requiring power chord reset.

Im printing through CUPS 1.6.1
Printers: Canon PIXMA MP140 - CUPS+Gutenprint v5.2.9

Any idea where to look for problems?

Just to show: this was the contents of the file (old stuff that I found from my HD small enough for test print):

Code: Select all

aMSN-testi

http://amsn.sourceforge.net/wiki/tiki-pagehistory.php?page=Webcam+In+aMSN&preview=47#test

----------------

Ai niin, testaa VLC:llä.
(mites /dev/Video0:n oikeudet?)

----------------

Try LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so kopete

Make sure you have the v4l libraries

It worked for me

1. create a file named /usr/local/bin/kopete, using (sudo gedit for instance)
2. copy the following lines in the file :
#!/bin/sh
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/kopete
3. give the file execution permissions :
sudo chmod a+x /usr/local/bin/kopete

Works like CHARM  :) 

----------------

http://gyachi.sourceforge.net/
(Yahoo)
-- edit --

The error log had 13274 lines like this:
D [01/Jun/2013:12:24:51 +0300] [Job 22] Read 156 bytes of back-channel data...

Then these are coming about once per minute:
D [01/Jun/2013:12:25:55 +0300] cupsdNetIFUpdate: "lo" = localhost:631
D [01/Jun/2013:12:25:55 +0300] cupsdNetIFUpdate: "eth0" = 192.168.1.33:631
D [01/Jun/2013:12:25:55 +0300] cupsdNetIFUpdate: "lo" = localhost:631
D [01/Jun/2013:12:25:55 +0300] cupsdNetIFUpdate: "eth0" = [v1.fe80::922b:34ff:fe9f:3e81+eth0]:631
D [01/Jun/2013:12:25:55 +0300] Report: clients=1
D [01/Jun/2013:12:25:55 +0300] Report: jobs=3
D [01/Jun/2013:12:25:55 +0300] Report: jobs-active=0
D [01/Jun/2013:12:25:55 +0300] Report: printers=1
D [01/Jun/2013:12:25:55 +0300] Report: printers-implicit=0
D [01/Jun/2013:12:25:55 +0300] Report: stringpool-string-count=12501
D [01/Jun/2013:12:25:55 +0300] Report: stringpool-alloc-bytes=13456
D [01/Jun/2013:12:25:55 +0300] Report: stringpool-total-bytes=232200
...
D [01/Jun/2013:12:38:19 +0300] cupsdNetIFUpdate: "lo" = localhost:631
D [01/Jun/2013:12:38:19 +0300] cupsdNetIFUpdate: "eth0" = 192.168.1.33:631
D [01/Jun/2013:12:38:19 +0300] cupsdNetIFUpdate: "lo" = localhost:631
D [01/Jun/2013:12:38:19 +0300] cupsdNetIFUpdate: "eth0" = [v1.fe80::922b:34ff:fe9f:3e81+eth0]:631
D [01/Jun/2013:12:38:19 +0300] Report: clients=0
D [01/Jun/2013:12:38:19 +0300] Report: jobs=3
D [01/Jun/2013:12:38:19 +0300] Report: jobs-active=0
D [01/Jun/2013:12:38:19 +0300] Report: printers=1
D [01/Jun/2013:12:38:19 +0300] Report: printers-implicit=0
D [01/Jun/2013:12:38:19 +0300] Report: stringpool-string-count=12501
D [01/Jun/2013:12:38:19 +0300] Report: stringpool-alloc-bytes=13456
D [01/Jun/2013:12:38:19 +0300] Report: stringpool-total-bytes=232200

Whom/where should I contact about this?

User avatar
xenopeek
Level 24
Level 24
Posts: 24132
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Problems with driver for Canon pixma MP 140

Post by xenopeek » Sat Jun 01, 2013 6:18 am

I don't know much about printers. Updated your topic subject and moved it here to perhaps get help from those more knowledgeable about such things.
Image

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Problems with driver for Canon pixma MP 140

Post by pdc_2 » Sun Jun 02, 2013 2:32 am

I understand you want to get your Canon MP140 working;

I understand you have sourced the drivers that Canon provide for this printer; it looks like it came out 5 yrs ago; when folks used 32bit systems............so there are 32bit drivers;
_______________________________________________________________________________________________________________

nowadays folks use either 32bit or 64bit and Canon supply 32bit and 64bit packages; in both rpm and deb formats; and source code;

_______________________________________________________________________________________________________________

if you want to print on a 64bit system, on an old printer, that only has 32bit driver debian or rpm packages; one needs symbolic linkks; usually after these are installed, things are fine

___________________________________________

so if one does the symbolic links first
sudo ln -s /usr/lib /usr/lib64
and
sudo ln -s /usr/local/lib /usr/local/lib64
_________________________________________________________________________-

and to go over the driver install; Canon provide a pair of drivers for most printers; a COMMON one to be installed first, and then a SPECIFIC driver for that printer;

so one goes here

http://support-asia.canon-asia.com/cont ... 83403.html and downloads the cnijfilter-common_2.80-1_i386.deb

and then one goes here

http://support-asia.canon-asia.com/cont ... 83701.html and downloads the cnijfilter-mp140series_2.80-1_i386.deb

_____________________________________________________________________________________________________________-

they could be installed by terminal sudo dpkg -i cnijfilter-common_2.80-1_i386.deb and then sudo dpkg -i cnijfilter-mp140series_2.80-1_i386.deb (if the command is issued from within the Downloads directory) or ubuntu software centre

_________________________________________________________________________________________________________

one could then restart cups
sudo service cups restart
and one can hope there is an MP140 driver and that it works

_______________________________________________________________________________________________________-

Canon also supply a programme to run the scanner; the programme is called ScanGearMP and again it has a common and a specific package

http://support-asia.canon-asia.com/cont ... 84701.html for the scangearmp-common_1.10-1_i386.deb

and

http://support-asia.canon-asia.com/cont ... 84801.html for the scangearmp-mp140series_1.10-1_i386.deb

_____________________________________________

to run ScanGearMP the command is
scangearmp
and one can then create a launcher for repeated use

______________________________________________--

we hope it goes well and let us know how it goes

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Problems with driver for Canon pixma MP 140

Post by turboscrew » Sun Jun 02, 2013 3:21 am

And the libcupsys...?

Tried without the links:

Code: Select all

$ sudo dpkg -i cnijfilter-common_2.80-1_i386.deb
(Reading database ... 178707 files and directories currently installed.)
Preparing to replace cnijfilter-common 2.80-1 (using cnijfilter-common_2.80-1_i386.deb) ...
Unpacking replacement cnijfilter-common ...
dpkg: dependency problems prevent configuration of cnijfilter-common:
 cnijfilter-common depends on libcupsys2 (>= 1.2.1).

dpkg: error processing cnijfilter-common (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 cnijfilter-common

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Problems with driver for Canon pixma MP 140

Post by pdc_2 » Sun Jun 02, 2013 3:44 am

back in 2008, Ubuntu used libcupsys2 but in 2010 it changed to libcups

so links such as this

http://r3dux.org/tag/libcupsys2/

suggest you tell the system to ignore that it cannot find libcupsys2 (as libcups is installed now)

so from a command line the advice would (after the symbolic links)
sudo dpkg -i --ignore-depends=libcupsys2 --force-architecture cnijfilter-common_2.80-1_i386.deb
and then
sudo dpkg -i --ignore-depends=libcupsys2 --force-architecture cnijfilter-mp140series_2.80-1_i386.deb
does that help things flow?

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Problems with driver for Canon pixma MP 140

Post by turboscrew » Sun Jun 02, 2013 4:04 pm

Thanks.
I'll try that as soon as I can. I'll report here.

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Problems with driver for Canon pixma MP 140

Post by pdc_2 » Sun Jun 02, 2013 11:26 pm

I'll try that
........go on.......just do it!!!!!! :D :D

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Problems with driver for Canon pixma MP 140

Post by turboscrew » Mon Jun 03, 2013 7:57 am

Well...

Code: Select all

MP140Driver $ sudo dpkg -i --ignore-depends=libcupsys2 --force-architecture cnijfilter-common_2.80-1_i386.deb
(Reading database ... 178909 files and directories currently installed.)
Unpacking cnijfilter-common (from cnijfilter-common_2.80-1_i386.deb) ...
dpkg: dependency problems prevent configuration of cnijfilter-common:
 cnijfilter-common depends on libcupsys2 (>= 1.2.1).

dpkg: error processing cnijfilter-common (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 cnijfilter-common

Code: Select all

MP140Driver $ ls -ls /usr/
total 136
60 drwxr-xr-x   2 root root 57344 Jun  3 14:43 bin
 4 drwxr-xr-x   2 root root  4096 Mar 16 00:58 games
 4 drwxr-xr-x  48 root root  4096 Apr 28 18:10 include
36 drwxr-xr-x 205 root root 36864 Jun  3 14:42 lib
 0 lrwxrwxrwx   1 root root     8 Jun  3 09:06 lib64 -> /usr/lib
 4 drwxr-xr-x  10 root root  4096 Jun  3 09:06 local
12 drwxr-xr-x   2 root root 12288 Jun  1 11:35 sbin
12 drwxr-xr-x 325 root root 12288 Jun  3 14:42 share
 4 drwxr-xr-x   5 root root  4096 Oct 18  2012 src

MP140Driver $ ls -ls /usr/local
total 32
4 drwxr-xr-x 2 root root 4096 Nov 15  2012 bin
4 drwxr-xr-x 2 root root 4096 Oct 17  2012 etc
4 drwxr-xr-x 2 root root 4096 Oct 17  2012 games
4 drwxr-xr-x 2 root root 4096 Oct 17  2012 include
4 drwxr-xr-x 4 root root 4096 Oct 17  2012 lib
0 lrwxrwxrwx 1 root root   14 Jun  3 09:06 lib64 -> /usr/local/lib
0 lrwxrwxrwx 1 root root    9 Mar 16 00:04 man -> share/man
4 drwxr-xr-x 2 root root 4096 Oct 17  2012 sbin
4 drwxr-xr-x 7 root root 4096 Oct 17  2012 share
4 drwxr-xr-x 2 root root 4096 Oct 17  2012 src

MP140Driver $ uname -a
Linux JAAMINT 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Problems with driver for Canon pixma MP 140

Post by pdc_2 » Mon Jun 03, 2013 4:44 pm

help me understand what you are intending to convey with what you have copied and pasted in your post

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Problems with driver for Canon pixma MP 140

Post by turboscrew » Sat Jun 08, 2013 6:19 am

pdc_2 wrote:help me understand what you are intending to convey with what you have copied and pasted in your post
Sorry for being away quite some time. It has been thunders around here, and I live in the country...

What I tried to say that the links should be there, Im runnind 64-bit linux and that the commands still don't work.

[edit]
With the current set-up printing a page takes about 10 minutes.
It first prints as expected about half the page. Then the print head goes one way printing something.
30 seconds later the printing head souds to return. After 2 minutes that is repeated.
This goes on quite a long time - almost the ten minutes. Then the rest of the page is printed as expected
and the page is ejected.

The reference to the thunders mean that if I had my machine running, that could have solved all my hardware
problems totally, but in a bit expensive way. That's why I kept my ADSL unconnected and the computer chords off the wall sockets.

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Problems with driver for Canon pixma MP 140

Post by turboscrew » Sun Jun 23, 2013 5:39 am

Tried with Olivia Live - the same problem with both MP140 and MP 150 drivers.

pdc_2
Level 8
Level 8
Posts: 2419
Joined: Mon May 11, 2009 1:21 am

Re: Problems with driver for Canon pixma MP 140

Post by pdc_2 » Sun Jun 23, 2013 1:25 pm

..........go on............treat yourself to a new printer..........you know you deserve it......... equivalent cost to a couple of dozen beers ...............

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Problems with driver for Canon pixma MP 140

Post by turboscrew » Fri Jun 28, 2013 9:55 am

Just a couple of months ago I got a new Mobo, processor and RAMs...
Athlon XP 1900+ changed to i3.

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Problems with driver for Canon pixma MP 140

Post by turboscrew » Sun Oct 27, 2013 5:11 am

The mystery is finally solved: USB port!

The printer was connected to USB port supporting USB 2.0/3.0.
I even tried another port, but that also happened to be USB2.0/3.0 port.

Finally, after lengthy trials of this and that, I tried with an old laptop, and the printer worked fine, so it had to be HW.
After some trying, I became to think about the USB-version, and when I connected the printer into an USB port supporting
USB 1.1/2.0, the printer worked fine.

Post Reply

Return to “Printers & Scanners”