Page 1 of 1

Network Printer not recognised

Posted: Fri Mar 14, 2014 10:50 am
by patrice4419
Hi, I have tried to set up a network printer on Linux Mint 16 Mate. The printer (Samsung CLP-325W) works well under Windows control.
Downloading the Linux driver was no problem, I see the configuration panel etc. Trying the Control Centre shows the printer and it seems another driver is loaded (it says Samsung CLP-325 Foomatic/foo2qpdl (recommended) although the driver I downloaded is from the Samsung website.
Cant see it though. The LinkSys WAG160N router has given the printer an address 192.168.1.x runs well on the Windows 7 machine.
I have tried the troubleshooter and that states - 'Unable to locate printer "cups-server".
Any comments welcome. Thanks in anticipation.

Re: Network Printer not recognised

Posted: Sun Mar 16, 2014 3:43 am
by patrice4419
Well, first of all, just call me stupid. It was mainly a bad cable! The link between computer and printer worked intermittently. Also the reason why the Samsung printer did not seem to work as a network printer with Linux Mint was that the cupsd.conf file needed an addition (under #Allow remote access add - Listen 127.0.0.1:631).
Sanity restored. Diving into the iptables again.

Solved Re: Network Printer not recognised

Posted: Fri Mar 21, 2014 6:14 pm
by patrice4419
I forgot to mention the UFW rule that I had to add for the firewall to allow a network printer.
ufw allow proto tcp to 192.168.1.x (your printer IP address) from any port 9100