Cannot Add printer (Epson xp-610) (solved) but now scanner ;

Forum rules
Before you post please read this
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Cannot Add printer (Epson xp-610) (solved) but now scanner ;

Post by Joseph. »

Hello all
Well I have tried add printer / run it in synaptic manager /downoad and run in DEB all don't show anthing at all even after I follow through everystep
Just wonder if their is a serious problem with the Database driver because no matter how many time I tried any one know a workabout

oh I did try it in petra /mate/xfce also other linux distro included ubuntu studio and all have the same problem not installing at all

So I would be very apprectiaed to have this solved soon as possible

Cheers All
Last edited by Joseph. on Wed May 28, 2014 7:17 pm, edited 2 times in total.
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

Re: Cannot Add printer (Epson xp-610)

Post by pdc_2 »

I don't understand all you are saying;

If you have an XP-610 device, go here for the printer driver that Epson supply; http://download.ebz.epson.net/dsc/du/02 ... c5b4c3574a

as you say, you need a debian package; epson-inkjet-printer-201308w_1.0.0-1lsb3.2_i386.deb or epson-inkjet-printer-201308w_1.0.0-1lsb3.2_amd64.deb .........are you 32bit?

(type
arch
in a terminal if you are not sure ..............)

......if you select OPEN from the dialogue box when you click to Download, that should enable you to "open with gdebi installer" ........and that should ........... give you a working install ..

......is any of this any help?
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610)

Post by Joseph. »

I have tried eveyrthing even was suggested by pdc_2 to get the driver to be installed for the Epson xp-610 and no luck.
either the package for the driivers are corrupted I'am using Petra 32 bit version OS linux Mint xfce and Mate well as for now I'm going to try the LM 16 -64 bit
if it still a problem then Im going to have to take back the printer.
will let you know if it worked or not.
unless if a member out their has the same printer Epson xp-610 and had no trouble installing please post how you did to make it work.
Thanks again so off to renistall a fresh LM 16 -64bit Mate or Xfce or Cinnamon

Cheers
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610)

Post by Joseph. »

Well it seems to be pretty strange now it working like a charm
first off you do need to down load the driver so
step 1 went to Epson typed in model and the it opend and directed me to another site and sed the older version say epson-inkjet-printer-201308w_1.0.0-1lsb3.2_i386.deb after down loaded it and run it nothing happen so just leave it
step 2 gone in to add printer told to look for network printer then it showed and follow on screen and everything is fine

Cheers All
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

SOLVED: Epson XP-610 works well on Epson drivers

Post by pdc_2 »

Glad this is all sorted for you; you have been extremely busy installing multiple variants of Mint: few of us would have your experience in this;
step 1 went to Epson typed in model and the it opend and directed me to another site
I have this site bookmarked http://download.ebz.epson.net/dsc/searc ... ch/?OSC=LX it is the download section of the Epson website

If it type in
XP-610
it takes me to the picture shown below;

(so anyone reading Joseph's unfortunate experience would likely feel Epson are "all at sea" but; to me; they clearly point one to the correct drivers; so I am sorry Joseph to hear of your experience above; I don't know how you ended up going "to another site" ..........maybe you were looking at the old avasys (retired) sites .............

If you click on FULL FEATURE DRIVER you end up at http://download.ebz.epson.net/dsc/du/02 ... c5b4c3574a

and for Mint you need Debian Packages; and you need to know if you have a 32bit or 64bit system:

If you are still there Joseph, you can add SOLVED to the title of the thread
Attachments
XP-610.png
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) almost solved but scan

Post by Joseph. »

Well that was the site it took me too but now another problem
Can't get the scanner to work I have check the driver from Epson same site that it directed to but as I try to install i-scan but it said unsatisfied dependency so now another problem
trying to figure if their is any package in the synaptic manger but seem nada
so if someone out their know any tip
thanks

oh by the way I am using LM petra Cinnamon 64 bit
on the acer aspire one netbook cinnamon 32 bit petra

Cheers
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by pdc_2 »

thanks Joseph; with the latest distro, there seem to be some issues;

for the scanner, Epson would say go here http://download.ebz.epson.net/dsc/du/02 ... acb85329f5

and install

1) DATA PACKAGE: iscan-data_1.28.0-2_all.deb first of all (it is at the bottom of the list!!)

2) iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb or iscan_2.29.3-1~usb0.1.ltdl7_i386.deb as appropriate (ltd7 is for newer kernels)

3) NETWORK plug-in: iscan-network-nt_1.1.1-1_amd64.deb or iscan-network-nt_1.1.1-1_i386.deb

..............could be the error is because the data package was not installed first..................if it was installed, and then the iscanltd7 would not install, can you run it in a terminal and see what error messages come up
cd Downloads
sudo dpkg -i iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb
(for to install the 64bit version)

does your terminal spell out errors? Can you copy and paste them back here please?
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by Joseph. »

pdc_2 I apperciate your help thank you now I hope to have the problem solved :)

Well I have done all the step above and no errors upon installing nada
however teir is another problem but hope it will show attachment
nope can't seem to get it work attachment :(
any how when I use simple scan and it would show it working then it would say failed to scan wheiter it wireless or wired both have the same message
I try using I-scan for linux and it would say could not send command to scanner so it seem it cannot find the scanner
so printing is not a problem just the scanning from the desktop weither it Libre office or Gimp or any other prg that can aquire scanner but it locks up the program or it seem not to find it

I can hook up my old Cannon printer and no problem using the scanner but printing is another story it would print then pause a very long time before it finish printing Can't figure that but unfortnate the driver for the two model I have both are pixma 160 and 240 go figure

Cheers
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by Joseph. »

Hello every one so her I'am again I have installed the latest Linux 17 Quano Cinnamon and it seem their is no way to resolve the problem as I have mention earlier done every and still the same scanner not working?
Is their anyone who had some problem is their brand name that may not be to well soupported in linux?
I can do wireless printing and all sort of other thing but not scanning anything even when it hooked to the usb still puzzled by it.
it do see the scanner and when I click to scan any item or doc it shows it spinning and nada nothing has been receorded or scanned.
I wonder if the developer had a chace to look at any if these comment that some member are seeking for their help has piqued any of their curiousity of what is happening?
Well thank you for your time and have a great day.
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by pdc_2 »

Joseph: a couple of commands to see what is recognised; if you can copy and paste them into a terminal; one by one; and paste back the results you get please
sane-find-scanner
scanimage -L
lsusb
_________________________________________________________

I think your device will be the same as the Workforce 610 series; and from here I think we need to add a reference to epkowa

___________

to see what we will need to do paste this command into a terminal
gedit /etc/sane.d/dll.conf
...........that uses the text editor called gedit to open the file dll.conf that is in the directory called /etc/sane.d ........and by just using gedit, you can only read it; you can play around with the file but any changes are not saved.................so we will aim to change
#epson
epson2
so that it now says
#epson
#epson2
epkowa
but if we leave the doing till a little later ........

______________________

and this sort of thing is the reference http://newton.ast.man.ac.uk/misc/karmic_scan.htm
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by Joseph. »

Thank you for you step pdc_2

here is the result from the terminal

sane-find-scanner
# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

could not open USB device 0x8087/0x8000 at 002:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x8087/0x8008 at 001:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x05dc/0xb049 at 004:004: Access denied (insufficient permissions)
could not open USB device 0x2109/0x0812 at 004:003: Access denied (insufficient permissions)
could not open USB device 0x2109/0x0812 at 004:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0003 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x047d/0x2048 at 003:002: Access denied (insufficient permissions)
could not open USB device 0x04b3/0x300a at 003:004: Access denied (insufficient permissions)
could not open USB device 0x046d/0x082d at 003:007: Access denied (insufficient permissions)
could not open USB device 0x2109/0x2812 at 003:006: Access denied (insufficient permissions)
could not open USB device 0x1c6b/0xa223 at 003:005: Access denied (insufficient permissions)
could not open USB device 0x2109/0x2812 at 003:003: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 003:001: Access denied (insufficient permissions)
# No USB scanners found. If you expected something different, make sure that
# you have loaded a kernel driver for your USB host controller and have setup
# the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.

# You may want to run this program as root to find all devices. Once you
# found the scanner devices, be sure to adjust access permissions as
# necessary.

scanimage-L
scanimage-L: command not found

isusb
No command 'isusb' found, did you mean:
Command 'lsusb' from package 'usbutils' (main)
isusb: command not found

ok so here is the result
and I will need some guide to walk me through on the next segment
as the file is a read only and not able to do ny change but I will keep trying ;-D
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by pdc_2 »

a couple of commands to see what is recognised; if you can copy and paste them into a terminal
scanimage-L
had a space after scanimage in the original text so the correct is
scanimage -L
and
isusb
No command 'isusb' found, did you mean:
Command 'lsusb'
.........yes indeed ..........it comes from list the usb devices and is shortened to
lsusb
so PLEASE have the device connected by usb cable when you do these things please

_______________________________________________________________

in the sane-find-scanner command is a line that says
could not open USB device 0x04b3/0x300a at 003:004:
is there any way that could actually be
USB device 0x04b8/0x300a
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by Joseph. »

Hello again so here is the result

redid scanimage -L

device `epson2:net:192.168.0.10' is a Epson PID 08B6 flatbed scanner
device `epkowa:usb:003:007' is a Epson XP-610 Series flatbed scanner

ok did lsusb

Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 05dc:b049 Lexar Media, Inc.
Bus 004 Device 003: ID 2109:0812
Bus 004 Device 002: ID 2109:0812
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
Bus 003 Device 004: ID 04b3:300a IBM Corp. Rapid Access IIIe Keyboard
Bus 003 Device 008: ID 046d:082d Logitech, Inc. HD Pro Webcam C920
Bus 003 Device 007: ID 04b8:08b6 Seiko Epson Corp.
Bus 003 Device 006: ID 2109:2812
Bus 003 Device 005: ID 1c6b:a223 Philips & Lite-ON Digital Solutions Corporation
Bus 003 Device 003: ID 2109:2812
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ok did sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

could not open USB device 0x8087/0x8000 at 002:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x8087/0x8008 at 001:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x05dc/0xb049 at 004:004: Access denied (insufficient permissions)
could not open USB device 0x2109/0x0812 at 004:003: Access denied (insufficient permissions)
could not open USB device 0x2109/0x0812 at 004:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0003 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x047d/0x2048 at 003:002: Access denied (insufficient permissions)
could not open USB device 0x04b3/0x300a at 003:004: Access denied (insufficient permissions)
could not open USB device 0x046d/0x082d at 003:008: Access denied (insufficient permissions)
could not open USB device 0x2109/0x2812 at 003:006: Access denied (insufficient permissions)
could not open USB device 0x1c6b/0xa223 at 003:005: Access denied (insufficient permissions)
could not open USB device 0x2109/0x2812 at 003:003: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 003:001: Access denied (insufficient permissions)
# No USB scanners found. If you expected something different, make sure that
# you have loaded a kernel driver for your USB host controller and have setup
# the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.

# You may want to run this program as root to find all devices. Once you
# found the scanner devices, be sure to adjust access permissions as
# necessary.

all right I see this " found the scanner devices, be sure to adjust access permissions as # necessary."
so now I wonder if their is a missing kernel in the os just a thought as I'am just a user here and I do try and figure out something sometime buy searching web for answer but alway best to get the answer form this fourm.
I'm sure we will get hammerd out
Cheers
will check back again for more folow up ohh this execting :D
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by pdc_2 »

thanks; let's look to see if you are a member of the scanner and the plugdev groups;

if you type
groups
in a terminal, if you copy and paste back the results please

____________________
04b8:08b6 Seiko Epson Corp.
so the ID is 04b8:08b6 and that should be useful

if you repeat the commands with sudo in front
sudo sane-find-scanner


_______________________________________--

what are we seeing in the below: do you just have one epson device? one would seem to mention epson2 which is a sane backend; and the other is labelled epkowa
device `epson2:net:192.168.0.10' is a Epson PID 08B6 flatbed scanner
device `epkowa:usb:003:007' is a Epson XP-610 Series flatbed scanner
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by Joseph. »

well here are the result and I only have one epson device.

groups

olar adm cdrom sudo dip plugdev lpadmin sambashare

sudo sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
# No USB scanners found. If you expected something different, make sure that
# you have loaded a kernel driver for your USB host controller and have setup
# the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.

oh their is nothing disabled in any of the usb port through the bios
just to let you know the mainboard I'am using is
Asus Gryphon Z87 16 gig ram processor intel i5
nothing else other than ssd

so ready to roll again
so just to let you know I have the same problem even on the LM 14 nadia and 16 Petra all had the same problem can't scan regardless wired or not

Thanks again pdc_2 wil be looking forwad to see what the next step
Cheers
nuttzo34
Level 1
Level 1
Posts: 26
Joined: Fri May 16, 2014 9:16 am

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by nuttzo34 »

I found with my epson xp-200 i had to install the lsb packages and recommended dependencies first or else the printer driver would fail to install.

To get scanning working through wifi when adding the printer set it to use lpd and for queue instead of PASSTHRU change it to /printers/epson.

My device uri looks like this

lpd://192.168.1.109:515//printers/epson

After that the scanner works flawlessly through wifi without having to edit any config files,I was able to set everything up without having to plug in the usb cable.
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by Joseph. »

Thanks nuttzo34 i have done all those step and still no luck
so just to let everyone know I will reinstall linux 17 and see how it goes again :)
so will let you all know what is happening after I do reinstall
so do continue to post any more idea on how to solve the problem
will be back in a short while
Cheers
Joseph.
Level 1
Level 1
Posts: 20
Joined: Wed Jul 25, 2012 10:20 pm
Location: Calgary Alberta Canada

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by Joseph. »

Hello back again and I installed petra 16 as LM 17 has a major flaw when installing keeps getting the error bt never mind that

I ran this command in the terminal

sudo dpkg -i iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb

:arrow: looks like ths is the error

dpkg: error processing iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb

so would this be the major problem that prevent me from scanning in both mode wired and wireless
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by pdc_2 »

you need to be inside the directory; where a package is; to install it:

............sort of like........... you can't get your socks from the sitting-room cabinet...........if your socks are in the drawer in your bedroom.........so you need to go the bedroom to get those socks........

........so maybe you downloaded the package to your Downloads directory;

so if you open the terminal anew; and issue the command
cd Downloads
and then type
ls
.this command is asking the computer to LIST what is in that directory;

if you see the package listed, then you can go ahead and install it;
sudo dpkg -i iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb
.............any joy?
nuttzo34
Level 1
Level 1
Posts: 26
Joined: Fri May 16, 2014 9:16 am

Re: Cannot Add printer (Epson xp-610) (solved) but now scann

Post by nuttzo34 »

Joseph. wrote:Thanks nuttzo34 i have done all those step and still no luck
so just to let everyone know I will reinstall linux 17 and see how it goes again :)
so will let you all know what is happening after I do reinstall
so do continue to post any more idea on how to solve the problem
will be back in a short while
Cheers
If you reinstall and try again,following the steps I took should sort the problem out.

1.go to terminal and sudo apt-get install lsb --install-recommends
After that go through the GUI to set up printing and when adding the printer use ldp and change queue setting to /printers/epson

After that go to simple scan and click scan and that is it.

I didn't manually install drivers,as long as you install the lsb package first then go the printer GUI it should install.
Post Reply

Return to “Printers & Scanners”