Epson Printers, All In Ones, etc...check here!!!

Forum rules
Before you post please read this
oldtraveler
Level 2
Level 2
Posts: 50
Joined: Thu Mar 18, 2010 7:28 pm

Re: Epson Printers, All In Ones, etc...check here!!!

Post by oldtraveler »

The Epson website provided the drivers. Take a look there.
http://www.epson.com/cgi-bin/Store/supp ... e=Overview
Dexter.Boneham
Level 1
Level 1
Posts: 19
Joined: Sun Aug 04, 2013 3:44 am
Location: Australia

Re: Epson Printers, All In Ones, etc...check here!!!

Post by Dexter.Boneham »

I did look there prior to posting. Looked again just now and followed the links. It still comes up empty for V33. The only Linux drivers I can see there are three relating to the V550.

Correction:
Looked at the V550 data packages and it seems that two are compatible with V33.
Still looking for iscan-network download.
pdc_2
Level 8
Level 8
Posts: 2420
Joined: Mon May 11, 2009 1:21 am

Epson V33 drivers on Epson site

Post by pdc_2 »

if I go here http://download.ebz.epson.net/dsc/searc ... ch/?OSC=LX

.....which is the Epson download centre for linux ...... and type V33 I get the screenshot that is below

you need data package firstly; then core package then iscan network plugin; I can see all three listed there ...............

http://download.ebz.epson.net/dsc/du/02 ... acb85329f5 links to data and core: DATA is at the BOTTOM of the list but install first ..

http://download.ebz.epson.net/dsc/du/02 ... a7bb67a744 links to the iscan plugin:

I hope this works for you
Attachments
V33.png
Dexter.Boneham
Level 1
Level 1
Posts: 19
Joined: Sun Aug 04, 2013 3:44 am
Location: Australia

Re: Epson Printers, All In Ones, etc...check here!!!

Post by Dexter.Boneham »

Thanks
When I use your links, I can see them too!
Using the link from earlier posts, V33 returns nothing. Very puzzling.
Bear1
Level 1
Level 1
Posts: 1
Joined: Wed Sep 24, 2014 12:35 pm

Re: Epson Printers, All In Ones, etc...check here!!!

Post by Bear1 »

sorry if post is out of order but have wp4530 epson. mint maya recognizes the printer as default and ready status. interface indicates that print jobs are complete but printer does nothing. epson web site has no driver listed and other efforts have fizzled due to "download errors". does anyone have a driver download site that works for this all in one?http://forums.linuxmint.com/posting.php ... =51&t=1763#
phtlsmedic1
Level 1
Level 1
Posts: 1
Joined: Sun Nov 16, 2014 12:10 pm

Re: Epson Printers, All In Ones, etc...check here!!!

Post by phtlsmedic1 »

jarndice
Level 1
Level 1
Posts: 1
Joined: Sat Feb 14, 2015 6:06 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by jarndice »

As I posted under Hardware:

Epson L350 (multifunction with ink tanks!) - Mint 17.1:
Downloaded 2x scanner drivers + printer driver (deb) (all drivers are now on the Epson site only)
Install order is important:
1) Scanner 'Data' Driver
2) Scanner 'core' Driver
3) Printer Driver

Printer and scanner now work

I think this will probably work for other models.
wibbly
Level 1
Level 1
Posts: 40
Joined: Wed Jul 16, 2014 6:13 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by wibbly »

I have tried everything that I can think of but cannot get my Epson SX235W to print.

It is on a USB connection. I don't need wireless, though I did try pressing the WPS button on the router and the wi-fi button on the printer with zero success. The W-fi light on the printer will not come on.

I have been to the Epson download centre.

http://download.ebz.epson.net/dsc/searc ... archModule

I have downloaded what I assume is the correct driver. Synaptic shows a driver as installed.

I can turn the printer on.
I can select a file to print.
I can select print.
The printer light flashes.
The print queue shows processing.
But nothing prints.

I have tried deleting the printer and reinstalling, it tells me that it is loading the driver, but no matter what, it still doesn't print?

One odd thing is that I recently installed a new motherboard and processor. I did a complete fresh install of Mint 17.2, with a new HD.
When I add the printer, the location always defaults to the name that I gave it when the old motherboard was installed, so somehow it has logged that info somewhere that I can't see.
My laptop used to print via USB (Mint 17.2 /32bit) but even that is no longer working?
I ran Bleachbit as root, but that didn't help either.

Am I missing something obvious?

Cheers

Rob
Attachments
settings.jpg
localhost.jpg
synaptic.jpg
Linuxmint 64bit version Always the latest version
Intel i5 4690k @ 3.50Ghz x 4
Ram 8GB
WD Black 1TB
GEForce GT460SE 1GB
Dr frishmouth
Level 1
Level 1
Posts: 27
Joined: Tue Dec 08, 2015 5:40 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by Dr frishmouth »

Good, but when I open http://www.avasys.jp/english/linux_e/dl_ink.html all is in Japanese, what I don't speak fluently.
How to open english version ??
TY for reply
Dr frishmouth
Level 1
Level 1
Posts: 27
Joined: Tue Dec 08, 2015 5:40 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by Dr frishmouth »

Dexter.Boneham wrote:Where are you sourcing the drivers?
I downloaded the drivers from the Epkowa.jp site shown earlier in this thread for my Epson V33 a year or so ago and it works fine.

I'm planning to move to Mint 17, but foolishly, didn't keep the deb downloads for the drivers. I just checked the website, but it seems to have dropped all linux drivers.

Is there another website I can get the drivers or is there a way to save the existing drivers in my current system prior to installation of Mint 17?

Same problem with stylus SX-230
elina
Level 1
Level 1
Posts: 13
Joined: Wed Dec 30, 2015 3:51 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by elina »

I use CX3800 All-in-one,too.
elina
Level 1
Level 1
Posts: 13
Joined: Wed Dec 30, 2015 3:51 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by elina »

I use CX3800 All-in-one,too.
elina
Level 1
Level 1
Posts: 13
Joined: Wed Dec 30, 2015 3:51 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by elina »

I use CX3800 All-in-one,too.
elina
Level 1
Level 1
Posts: 13
Joined: Wed Dec 30, 2015 3:51 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by elina »

I use CX3800 All-in-one,too.
elina
Level 1
Level 1
Posts: 13
Joined: Wed Dec 30, 2015 3:51 am

Re: Epson Printers, All In Ones, etc...check here!!!

Post by elina »

I use CX3800 All-in-one,too.
Raybrite
Level 1
Level 1
Posts: 28
Joined: Fri Mar 25, 2016 11:19 pm

Re: Epson Printers, All In Ones, etc...check here!!!

Post by Raybrite »

I went to Ayasys and it is all in Chinese for me. How do I get it in English.
intel core-i3 3.66GHz-CGA1150
GIGABYTE H81m-DS2
Dymet 4GB DDR3-1600
Western Digital 1TB Hard Drive
NVIDIA GTX750TI Video Card
User avatar
kyphi
Level 9
Level 9
Posts: 2704
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter Valley, Australia

Re: Epson Printers, All In Ones, etc...check here!!!

Post by kyphi »

Avasys no longer provides drivers for Epson. That role has been taken up by Epson itself.
Linux Mint 20.0 Cinnamon - 64bit
mike acker
Level 6
Level 6
Posts: 1499
Joined: Wed Jul 31, 2013 6:29 pm
Location: Kalamazoo, MI

Epson Workforce WF 4630

Post by mike acker »

I was able to obtain a driver here:

Epson Download Service

it says to install lsb first:
epson lsb.png
it says

Code: Select all

apt-get install lsb
i assume we need to use SUDO

the printer is still in the box; i'll update this a bit later....

( I'm doing this update on a DEBIAN LMDE/2 system -- hope it works )

2016-05-25 Did not need to install driver: Betsy found the printer and hooked it in; scanner too.

kinda odd though -- everything prints a little light; i think i'll install the driver anyway

i did the install lsb as directed by the Epson site and then installed their driver (.deb) package-- no change in operation except scanner didn't work.

after i removed the lsb ( aptget remove lsb ) -- and remove the driver (.deb) package -- i had a printer not found condition.

after I re-installed the Epson driver package -- the printer was found again -- and it appeared it knew it needed to also install the lsb stuff. after that the printer and the scanner worked again -- although the printer continues to print a bit light -- ( like it's printing draft mode ) .

on googling for the problem i found this:
Under the printer properties, try changing the media type to "plain papers-Standard-Vivid".
yep; it worked. in retrospect: i did not need to install the lsb or the print driver from Epson; however the print driver from Epson seems to be identical to the one Betsy already had.
¡Viva la Resistencia!
Dave1w
Level 1
Level 1
Posts: 5
Joined: Fri Aug 05, 2016 8:19 am

Epson XP-430 install problem

Post by Dave1w »

Hi, I need help getting a new Epson XP-430 installed on Linux Mint 16.
Software managed doesn't list the 430 (too new?) so I've downloaded the 430... .deb driver from Epson.
The "add new printer" shows the connected printer under USB and it also shows under network.
I am trying to install on USB.
In "add new printer" Searching for drivers does not list the 430 so I select "provide PPD file" and locate the downloaded PPD file in the box.
When moving forward, a pop up displays "Printer 'EPSON-XP-430-Series' requires the '/usr/lib/cups/filter/epson-escpr-wrapper' program but it is not currently installed. Please install it before using this printer."
When closing this pop up, the printer is showing in "printers local host" but will not print a test page.
In properties, the printer status indicates: "Idle - File "/usr/lib/cups/filter/epson-escpr-wrapper" not available: No such file or directory".
I have located the wrapper file but I can not move, copy/paste or "copy to" any other folder despite changing permissions to read/write.
I have dead ended on this approach.

I have also tried installing by running the downloaded 430 ..... .deb file directly.
In this case the package installer opens, I click install, grant administrative rights and quickly a pop up gdbi-gtk indicates: Could not download all required files and details show a list of "failed to fetch....." files. It says check your internet connection but there is no internet connection problem for normal use.
I have dead ended on this approach.

Final approach has been "synaptic package manager" and mark for install: "epson-escpr ...This is a transitional dummy package to transition to uniformly named printer-driver-escpr."
Upon apply, a pop up comes up indicating: "W: Failed to fetch http://mirrors.liquidweb.com/ubuntu/poo ... 1_i386.deb 404 Not Found [IP: 69.167.187.144 80]"
I have dead ended on this approach.

My internet connection is working fine for all other functions.
The printer shows up on the printer page but communication is not occuring.
For some reason the required files will not load.

I need a workaround or dam buster.

I am unfamiliar with terminal so any directions there must be aimed at a raw beginner,

Thanks for your help
Dave
User avatar
Pierre
Level 20
Level 20
Posts: 10823
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Epson XP-432 install

Post by Pierre »

the new Epson XP-432 wasn't recognised by LM17x
:(
a little searching gave some false starts.
- including that driver mentioned by mike acker
& which was installed,
( may have helped, but not immediately )

in the end - the package "Epson Inkjet Printer Driver (ESC/P-R)"
was installed via Package Manager AKA synaptic

then, Menu - Control Center - Printers - - Add - Select Device - Network Printer
( it's got a WiFi connection ) ( preset already )
then - searching for drivers - Epson - Epson 400 Series - Apply
Finally - - Print the Test Page -- it works
:D
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
Locked

Return to “Printers & Scanners”