Cant use installed printer: old thread new problem(SOLVED)

Forum rules
Before you post please read this
User avatar
cinnamoncoffee
Level 3
Level 3
Posts: 114
Joined: Sun Nov 09, 2014 8:25 am

Cant use installed printer: old thread new problem(SOLVED)

Postby cinnamoncoffee » Sat Apr 04, 2015 11:49 am

Hi, this is driving me crazy.
Ive got a HP Laserjet PRO MFP m125nw printer. Ive intalled it and it is shown in system settings. Ive installed the driver. It seems everything should work right but it just wont print. I installed this http://hplipopensource.com/hplip-web/in ... index.html but it wont run. In the terminal it says
warning: There are 10 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libjpeg (libjpeg - JPEG library)
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing REQUIRED dependency: dbus (DBus - Message bus system)
warning: Missing REQUIRED dependency: sane-devel (SANE - Scanning library development files)
INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
warning: There are 2 missing OPTIONAL dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'base': cups-ddk (CUPS DDK - CUPS driver development kit)
warning: Missing OPTIONAL dependency for option 'scan': xsane (xsane - Graphical scanner frontend for SANE)
A package manager '/usr/bin/perl -w' appears to be running. Please quit the package manager and press enter to continue (i=ignore, r=retry*, f=force, q=quit) :r
A package manager '/usr/bin/perl -w' appears to be running. Please quit the package manager and press enter to continue (i=ignore, r=retry*, f=force, q=quit) :r
A package manager '/usr/bin/perl -w' appears to be running. Please quit the package manager and press enter to continue (i=ignore, r=retry*, f=force, q=quit) :i
warning: Ignoring running package manager. Some package operations may fail.


What does this mean? How do I fix this? I couldnt install this printer neither on my dad's ubuntu laptop. I had to take it to the computer shop to install it. Now Id like to change my dad's OS to Mint but i cant because if i do, we will not have a printer. Is there a way I can fix this problem myself or do i really need to take the computer to the shop again?
I tried automatic driver installation. I tried using localhost: 631 already (now it wont even connect to that site it says "connection failed")

I have Asus X550C LM 17.1 kernel 3.13.0-37

Thank you and Happy Easter! :)
Last edited by cinnamoncoffee on Sat Nov 04, 2017 2:48 pm, edited 5 times in total.
Kernel: 3.16.0-38-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: Cinnamon 2.6.13 Distro: Linux Mint 17.2 Rafaela Machine: Mobo: ASUSTeK model: X550CA

pdc_2
Level 7
Level 7
Posts: 1890
Joined: Mon May 11, 2009 1:21 am

Re: Cant use installed printer

Postby pdc_2 » Sat Apr 04, 2015 4:54 pm

sorry to hear that this is driving you crazy; sadly, your computer can't talk to you and can only send you written messages; ..........sometimes I don't get it either but my reading of what it is trying to tell you is

warning: There are 10 missing REQUIRED dependencies.


.............so my take on that is that it is ..................warning you; ..............................that you are missing ................. ten things ..................that are required for it to do ..............what you want it to do .....

__________

all a bit strange as one would think that those packages are already installed; why would they be missing .................

you could try the command

Code: Select all

sudo apt-get install libusb libtool cups-image etc etc
.................you can see what I have done is copy and paste in the names of the 1st three things that your system lists are missing .......... you need to copy and paste in the remaining ones; including what your system calls optional dependencies ........and then try the hp command again ............ it's sort of like a platoon going into battle; if half the guys are drinking in a bar downtown; and some of the others are sleeping in the barracks; you don't do so go; so marshall your forces and then run the command again .........

User avatar
kc1di
Level 10
Level 10
Posts: 3313
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Cant use installed printer

Postby kc1di » Sat Apr 04, 2015 5:08 pm

is there some specific reason that you do not want to use the hplip driver found in the repositories. Which are supposed to work with your printer?

I would do this in a terminal

Code: Select all

sudo apt-get purge hplip
sudo apt-get install hplip


then type

Code: Select all

hp-setup


set up your printer and see if it works.
Happy Easter :)
John 3:16
Morse code an Early Digital Mode
Registered Linux User #462608
Wireless Script: http://ubuntuforums.org/showthread.php?t=2082305&p=12350385#post12350385
Good terminal command tutorial: https://ryanstutorials.net/linuxtutorial/

User avatar
cinnamoncoffee
Level 3
Level 3
Posts: 114
Joined: Sun Nov 09, 2014 8:25 am

Re: Cant use installed printer

Postby cinnamoncoffee » Sun Apr 05, 2015 1:30 am

Wow kc1di this works!!! Ive spent soooo much time on the internet trying to find the solution, tried many complicated things and this simple solution works :)
Thank you :)
Kernel: 3.16.0-38-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: Cinnamon 2.6.13 Distro: Linux Mint 17.2 Rafaela Machine: Mobo: ASUSTeK model: X550CA

User avatar
kc1di
Level 10
Level 10
Posts: 3313
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Cant use installed printer

Postby kc1di » Sun Apr 05, 2015 4:51 am

cinnamoncoffee wrote:Wow kc1di this works!!! Ive spent soooo much time on the internet trying to find the solution, tried many complicated things and this simple solution works :)
Thank you :)

Your Welcome Enjoy :)
John 3:16
Morse code an Early Digital Mode
Registered Linux User #462608
Wireless Script: http://ubuntuforums.org/showthread.php?t=2082305&p=12350385#post12350385
Good terminal command tutorial: https://ryanstutorials.net/linuxtutorial/

User avatar
cinnamoncoffee
Level 3
Level 3
Posts: 114
Joined: Sun Nov 09, 2014 8:25 am

Re: Cant use installed printer: old thread new problem please see the end

Postby cinnamoncoffee » Sat Nov 04, 2017 10:58 am

Hi after a long time! I've got exact same problem again but when I use the solution that worked last time it doesn't work anymore!
What I get is this:
~ $ hp-setup

HP Linux Imaging and Printing System (ver. 3.16.3)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

what should I do now? I already reinstalled hplip several times
Kernel: 3.16.0-38-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: Cinnamon 2.6.13 Distro: Linux Mint 17.2 Rafaela Machine: Mobo: ASUSTeK model: X550CA

User avatar
kc1di
Level 10
Level 10
Posts: 3313
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Cant use installed printer: old thread new problem please see the end

Postby kc1di » Sat Nov 04, 2017 11:35 am

Here is what I would try first go to a terminal and do the following one at a time.

Code: Select all

sudo apt-get purge hplip
sudo apt-get update
sudo apt-get install hplip


then run hp-setup again.
see if that works if now we will go from there.
John 3:16
Morse code an Early Digital Mode
Registered Linux User #462608
Wireless Script: http://ubuntuforums.org/showthread.php?t=2082305&p=12350385#post12350385
Good terminal command tutorial: https://ryanstutorials.net/linuxtutorial/

User avatar
cinnamoncoffee
Level 3
Level 3
Posts: 114
Joined: Sun Nov 09, 2014 8:25 am

Re: Cant use installed printer: old thread new problem please see the end

Postby cinnamoncoffee » Sat Nov 04, 2017 12:14 pm

hello thank you for replying to me again!
It still says:
error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.
Kernel: 3.16.0-38-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: Cinnamon 2.6.13 Distro: Linux Mint 17.2 Rafaela Machine: Mobo: ASUSTeK model: X550CA

User avatar
kc1di
Level 10
Level 10
Posts: 3313
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Cant use installed printer: old thread new problem please see the end

Postby kc1di » Sat Nov 04, 2017 12:47 pm

Is hplip-gui installed? if not install it using synaptic or terminal.
if it is try uninstalling and reinstalling it.
then run HPLIP-Toolbox from the menu , what happens?
John 3:16
Morse code an Early Digital Mode
Registered Linux User #462608
Wireless Script: http://ubuntuforums.org/showthread.php?t=2082305&p=12350385#post12350385
Good terminal command tutorial: https://ryanstutorials.net/linuxtutorial/

pdc_2
Level 7
Level 7
Posts: 1890
Joined: Mon May 11, 2009 1:21 am

maybe the required HP plug-in is needed ..

Postby pdc_2 » Sat Nov 04, 2017 1:39 pm

HP provide a site on hplip; there is a list of what they call "supported printers" and for the MFP m125nw if one checks there, it says it needs 3.14.3 or more of hplip;

and that a PLUG-IN is REQUIRED; ......... it expands that to say
8 ("Required") A downloadable driver plug-in is required for printing support.
For this device, they say it needs this for both printing and scanning support.

the command to install it seems to be

Code: Select all

hp-plugin
........... one might need to tie a luggage label onto the usb cable of the device; to remind one that if one installs a new version of the OS, that a new download of the plug-in may be needed.

_______________

instructions are at the bottom of this page https://developers.hp.com/hp-linux-imag ... lugin.html

User avatar
cinnamoncoffee
Level 3
Level 3
Posts: 114
Joined: Sun Nov 09, 2014 8:25 am

Re: Cant use installed printer: old thread new problem please see the end

Postby cinnamoncoffee » Sat Nov 04, 2017 2:47 pm

Great, thank you guys! I've managed to install it using plugin on the page. :D
Kernel: 3.16.0-38-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: Cinnamon 2.6.13 Distro: Linux Mint 17.2 Rafaela Machine: Mobo: ASUSTeK model: X550CA

pdc_2
Level 7
Level 7
Posts: 1890
Joined: Mon May 11, 2009 1:21 am

HP plug-in (SOLVED)

Postby pdc_2 » Sat Nov 04, 2017 5:56 pm

well done! Enjoy! ..... (and don't forget to put that big label on the usb cable saying ...... plug-in!)


Return to “Printers & Scanners”

Who is online

Users browsing this forum: No registered users and 4 guests