HP LaserJet P1102w - Error 5012

Forum rules
Before you post please read this
Post Reply
cybergrisu
Level 1
Level 1
Posts: 1
Joined: Fri Aug 21, 2015 4:51 am

HP LaserJet P1102w - Error 5012

Post by cybergrisu » Fri Aug 21, 2015 5:02 am

Hello!

I took me hours but I still did not get my HP LaserJet P1102w to work wirh Linux Mint 17.2 over network/wireless connection.
It does work over USB by the way.

I managed to install the "hplip-3.15.2-plugin.run" manually, so that the device is correctly found in the setup process.
But when it comes to printing I get a "Device Communication Error 5012".

So my opinion is that Mint 17.2 has a serious problem here.

Ron-N
Level 2
Level 2
Posts: 96
Joined: Fri Aug 28, 2015 1:52 am
Contact:

Re: HP LaserJet P1102w - Error 5012

Post by Ron-N » Fri Aug 28, 2015 8:26 am

Well...first of all, the HPLIP opensource webpage only supplies drivers for Mint 17.0 and 17.1. But that does not mean you can't install the latest HPLIP driver. When you download it and run it, you probably will get some warning saying that 17.2 is not supported. But continuing the installation, you will notice that all drivers and (missing) dependencies will be installed without a glitch.

I found some topics on other forums related to you problem. Best is to read these topics to solve your problem:
http://ubuntuforums.org/showthread.php?t=2001912
http://ubuntuforums.org/showthread.php?t=2226631
http://ubuntuforums.org/showthread.php?t=1249019

Don't mind the different printer models or HPLIP versions, it's all about the provided solution :wink:
Hybrid laptop hardware specifications:
Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*128 GiB SSD/1 TB HDD*

Linux Mint 17.2 Xfce/kernel version: 3.19.0-28

wilbobob
Level 3
Level 3
Posts: 125
Joined: Thu Dec 15, 2011 4:30 am
Location: Leicestershire

Re: HP LaserJet P1102w - Error 5012

Post by wilbobob » Wed Sep 02, 2015 4:01 am

Thankyou Ron-N. I upgraded to 17.2 xfce and found my 1102w wouldn't install (the HP installer couldn't find my or any wireless network). I've spent a day and a half looking for a solution, then downgraded to 17.1xfce as that is alleged to be supported but the installer failed in the same way. The first link you gave hp-setup -i <ipaddress> worked first time. When I can work up the enthusiasm I'll re-try 17.2
Hopefully the OP will find his answer too and marked this solved.
ps the Error 5012 doesn't seem relevant to the failure. From what I read it's reporting that the GUI isn't GTK+, but that doesn't prevent it working. I could be holding very firmly to the wrong end of the stick.
Go Steady, but keep going

Post Reply

Return to “Printers & Scanners”