Page 1 of 1

EPSON XP-235 / Image Scan v3

Posted: Sun Mar 06, 2016 4:48 am
by ktziotis

I am using Linux Mint 17.3 Rosa 32-bit and everything works fine. I am a new Linux user and I am not familiar with terminal commands, but I am working on it...

Recently I bought an EPSON Expression Home XP-235 all-in-one inkjet printer, because of the need of a scanner. I connected the printer to my computer via USB cable.

Printer works perfectly but Simple Scan does not recognise the scanner. I visited the sane project website: and unfortunately I didn't find XP-235 in the supported models.

Then I visited EPSON website in order to find there some solution. I found a scanner driver package in the following URL: ... 051fb3c889

I clicked on the Accept button, then I selected the Package Download Page and I found the Image Scan v3 package for Linux Mint 17. So, I got the file:


from the following URL:

I installed the file: imagescan_3.15.0-epson4linux17_i386.deb with GDebi Package Installer.

I run the application. Everything seemed to work fine. The application recognised the scanner and I got a preview of the document. The bad thing was that I couldn't save the scanned document. With the help of Nemo I found that - during my attempt to save - a file entry was normally created, but it disappeared at the end of the procedure.

So, is there any suggestion? Has this situation to do with application's write permissions?

I would be very greatful if you could help me to solve the problem.

My best regards

Re: EPSON XP-235 / Image Scan v3

Posted: Sun Mar 06, 2016 6:20 pm
by kyphi
Epson now bundle the scanner files and detail how to install them as a bundle in the included README file.

The files can be installed individually:

Right click on the downloaded "imagescan-bundle-linuxmint-17-1.1.5.x86.deb.tar.gz" and select "Extract Here" from the dropdown menu. That will create a folder "imagescan-bundle-linuxmint-". Open the folder to find 2 folders, "core" and "plugins", the install script and the README file.
If you wish you can follow the instructions there or open the "core" folder and install the .deb file with a double left click. Do the same with the 2 .deb files in the "plugins" folder.

You were very detailed in describing what you had done and where you got your information. That was much appreciated.

Re: EPSON XP-235 / Image Scan v3

Posted: Mon Mar 07, 2016 7:49 am
by ktziotis
First I would like to thank you for your reply. I read your suggestions, but I followed almost the same steps. To be more specific I opened the "core" folder and installed:


not with a double left click, but with GDebi Package Installer. I suppose it is the same thing.

I did not install the files under the "plugins" folder, because I read in the instructions in the following URL: ... l#sec6-1-2

that plugins are both optional:

1) imagescan-plugin-networkscan_1.1.0-1epson4linuxmint17_i386.deb file is necessary only when network scanning is required (I connected the printer via USB cable).

2) imagescan-plugin-ocr-engine_1.0.0-1epson4linuxmint17_i386.deb file is required only for OCR purposes. I also read in: README.rst that this is an optional feature.

I also tried to run the script, but I always got a bash execution error. Then I decided to follow the above procedure. Finally I found what the bash execution error was. It was really simple, but I never thought about it. File had not execute permission...

Anyway the point is that Image Scan generally works fine. It recognizes the scanner, I am able to get a preview of the document, I am able to set all of its parameters, but I can not save the file. As I wrote before, I found that - during my attempt to save - a file entry was normally created, but it disappeared at the end of the process.

I thought that it might has to do with write permissions. So I created a new folder named “scanner” under my home folder. I defined it as a shared folder with all options under the Share tab checked. I also changed its permissions in order to give to everyone the ability to read and write in the folder. Then I tried to save the scanned document to this folder, but it happened exactly the same thing. After that I opened a terminal window and I created with touch command under the “scanner” folder a file named “test.pdf”. I also changed its permissions in order to give to everyone the ability to read and write the file. My last attempt was to save the scanned document overwriting this file. The result was once again the same. File “test.pdf” disappeared at the end of the process.

Another funny thing is that after Image Scan installation Simple Scan does recognize the scanner. I can also get a preview and the most important thing is that I can save the file. The bad thing is that after a few scans it seems to loose accuracy. For example I scanned several times the same document in order to create a multi-pages document. After some attempts the scanned document was shifted or was split. The same thing happened when I changed the document size. For example I scanned first an A4 document and then I tried to scan an A5 document. All pages were placed at the same reference point on the scanner surface. The result of the A5 document was randomly shifted from left and top references. There is no sense.

I don't know if the above written could give you the ability to suggest any other idea or solution to the problem. Anyway many thanks for the effort.

Re: EPSON XP-235 / Image Scan v3

Posted: Mon Mar 07, 2016 5:22 pm
by kyphi
This may help (it is a downloadable pdf): ... _man_e.pdf

Re: EPSON XP-235 / Image Scan v3

Posted: Fri Mar 11, 2016 11:12 am
by ktziotis
Hello kyphi.

Thanks for your reply. I read the PDF file, but it refers to ImageScan! an application that is not recommended from EPSON for model XP-235.

Of course I did not find any solution to the problem. On the other hand I made XP-235 to work…

It seems that the problem has not to do with drivers or software. I am not an expert, but I suppose that something is not working as it should via USB connection. I suppose that, because everything works perfectly since I connected the machine to the computer by Wi-Fi through an access point.

I did not use any scanner driver or software. I just got EPSON ESC/P-R driver and EPSON Printer Utility from EPSON website.

I got EPSON ESC/P-R Driver file:


from the following URL: ... 67748e555a

I also got Epson Printer Utility file:


from the following URL: ... c5c3e983e4

I installed both with GDebi Package Installer.

After the installation printer works perfectly and I also got access to the printer's ink levels through EPSON Printer Utility. This application is very good and there is no need to install Mtink.

Simple Scan recognizes the scanner and every process of the application works perfectly.

I tested the above driver and software also with EPSON Stylus Office BX305FW+ (Wi-Fi through access point connection again) and I have got the same good results.

I solved my problem, but I still don't understand why USB connection generated all these problems to the scanner. I hope Forum might give us someday an explanation on this subject...

Re: EPSON XP-235 / Image Scan v3

Posted: Sat Mar 12, 2016 6:52 pm
by kyphi
ktziotis wrote:I read the PDF file, but it refers to ImageScan! an application that is not recommended from EPSON for model XP-235
That is not correct. ImageScan is an Epson product and is installed with the scanner driver.

The drivers from Epson are universal drivers and fit for most models.

I don't understand why you had problems with scanning and now everything works. A mystery - see Addendum below.

My Epson MFDs work in both USB and Wi-Fi mode. Of course, I had to key in the access code to my modem/router before the Epson could be used in Wi-Fi mode.


I just noticed "Image Scan v3". The file you need is "imagescan-bundle-linuxmint-17-1.1.5.x86.deb.tar.gz" from the Epson Download Centre: ... FromResult

Please read this post: viewtopic.php?f=49&t=218409&p=1143774#p1143774

Re: EPSON XP-235 / Image Scan v3

Posted: Sun Jun 26, 2016 2:23 pm
by chrisonmint
Hello all,

I just got this printer and have it set up to use WiFi. I got it on the wireless network using my Windows10 laptop and a USB cable (WPS didnt work on my router for some reason...)

I only installed the printer driver, following instructions here: ... 7029c06dd8

Its described as ESC/P-R Driver (generic driver) and I chose the "epson-inkjet-printer-escpr_1.6.5-1lsb3.2_amd64.deb" file.

Before installing, you are asked to install lsb, which pulls over a dozen other dependencies over. Ran smoothly on LM 17.3

Code: Select all

sudo apt-get install lsb
After that , the "Add Printer" wizard ran fine and applied the correct driver. I just had to click the triangle by "Network" to show all the network options and my XP-235 appeared in the list after a few seconds. I accepted all the default settings for it and it was ready for printing.

I also tried the "SimpleScan" application (the default app in LM 17.3) and this connected straight away and was able to run a full scan.

THANK YOU EPSON for providing support!

Re: EPSON XP-235 / Image Scan v3

Posted: Sat Jan 27, 2018 7:22 am
by Fla
Hi everyone;

I have an Epson XP-345 and have the exact same problem than ktziotis: I installed the Epson Driver for scanner (imagescan-bundle-linuxmint-18-1.3.23.x64) and ImageScan runs well; detect the scanner; is able to perform a preview (so I can see on my screen the image I am scanning) but when I try to save it, a file is created and then removed at the end of scan process!

I upgrade everything (now running 18.3 Mint, with the last 4.13 kernel), I have no idea why it doesn't work. I tried to launch it with sudo, same behavior. No output in the console. I have `lsb` installed. I also tried with the 32bits drivers (which installed a different version of graphicsmagick and libgraphicsmagick++-q16-12) but still can't export the file. I tried with the pdf, png and jpg format.

I can't try with Wi-Fi as my printer doesn't have it. Printing works correctly. Everything works fine with USB using Windows 7 dual boot. I'm stuck. If someone knows where to open a bug report at Epson...

Re: EPSON XP-235 / Image Scan v3

Posted: Sat Feb 03, 2018 5:09 pm
by lollo99

I#m having the same issue. Running image scan v3 on ubuntu. The scanner is connected via wifi. Everything works fine. I get a preview of the scanner. When I start the scanning process, a file is created in the directory I specify. When the process is finished, the file gets deleted again.


Re: EPSON XP-235 / Image Scan v3

Posted: Fri Mar 16, 2018 2:48 pm
by markd
This may help on a conflict.

System: EPSON XP-332 / Image Scan V3, Mint 18, 64 bit AMD.

I found that the image scan software is in conflict with xsane and the scan panel was not drawn.
The scanner was recognised but not useable.
Once xsane software was removed it worked perfectly.

Re: EPSON XP-235 / Image Scan v3

Posted: Wed May 02, 2018 7:27 am
by luvr
ktziotis wrote:
Sun Mar 06, 2016 4:48 am
I run the application. Everything seemed to work fine. The application recognised the scanner and I got a preview of the document. The bad thing was that I couldn't save the scanned document. With the help of Nemo I found that - during my attempt to save - a file entry was normally created, but it disappeared at the end of the procedure.
I have a similar problem with an Epson Perfection V39 scanner under Ubuntu 16.04.
The weird thing is, on two computers it works perfectly. On two other computers, the destination file does get created, but it disappears as soon as the scan is complete.

My conclusion: The issue must be caused by some difference between the two computers where it works on the one hand, and the two where it fails on the other.

There actually were a few differences:
  • Differences in the list of installed software packages.
    Nothing that seemed relevant for this issue, though.
  • Differences in the userids that are used on the computers.
    On the two computers were it works, I log on with the first user that got created during installation (i.e., userid 1000), whereas on the other two computers, another user logs on (userid 1001 or 1003).
    Logging in with userid 1000 on the failing computers didn't help, though. On the working computers, everything continued to work fine, irrespective of the userid that logged in to the system.
  • Differences in the locale settings.
    The two working computers use English-language settings, while the two failing computers are configured for the Dutch language.
    As a quick test, I run the imagescan application with English-language settings, as follows, from the command line:

    Code: Select all

    LC_ALL=en_US.UTF8 imagescan
    Even though the user interface continues to work in Dutch, the scanned document does now get saved!
So: If the Epson Image Scan application fails to save scanned documents, try running it with English-language settings. That seems to work.

Addendum: How to run Image Scan with English-language locale settings on a computer that uses a different language.

To run the Image Scan application with English-language settings, while running the system under a different locale, I created a small script, called, in the /usr/local/bin directory. The script contains just the following two lines:

Code: Select all

LC_ALL=en_US.utf8 /usr/bin/imagescan scan
NOTE: Remember that you will need root privileges in order to obtain write access to the /usr/local/bin directory. Alternatively, if you are the only user that will want to use the scanner on the computer, then you could save the file to a folder under your home location.

Since the script will have to be executed, you will have to set its executable flag:

Code: Select all

chmod +x /usr/local/bin/
From a command-line shell, you can now run the command. You can also create an icon, or a starter, or whatever your desktop environment calls it, with something like the following settings:

Code: Select all

[Desktop Entry]
Name=Image Scan

Re: EPSON XP-235 / Image Scan v3

Posted: Mon Oct 01, 2018 8:49 pm
by badgerMint
Thanks for posting your answers!

I've just installed Ubuntu 18.04 Desktop on the machine beside my L395 printer/scanner. I've been all day long trying to get a single pdf from the scanner. After changing the language locale, the scan finally worked!

So, just reporting my case:
- OS: Ubuntu 18.04 64bits
- Printer Device: Epson L395
- Drivers from: (note: I've installed the 3 packages I've found)
- Single Line Command: LC_ALL=en_US.utf8 /usr/bin/imagescan scan
- Printer connected through USB