Canon 120 LiDE scanner works now on linux

Forum rules
Before you post please read this
paperloader
Level 1
Level 1
Posts: 8
Joined: Wed May 14, 2014 9:08 pm

Canon 120 LiDE scanner works now on linux

Postby paperloader » Sat Dec 03, 2016 3:23 pm

I have a Canon 120 LiDE scanner that works now on Mint 18 Cinnamon. I found the fix on http://askubuntu.com/questions/652769/r ... untu-14-04. It works with simple-scan now.

bh56
Level 1
Level 1
Posts: 2
Joined: Sun Dec 18, 2016 4:33 pm

Re: Canon 120 LiDE scanner works now on linux

Postby bh56 » Sun Dec 18, 2016 10:17 pm

Hi,
I've followed the instructions in your post ie
Add ppa:
sudo add-apt-repository ppa:rolfbensch/sane-git
sudo apt update
sudo apt install sane libsane libsane-common sane-utils libsane-extras

As root, edit /etc/sane.d/genesys.conf:
sudo nano /lib/udev/rules.d/40-libsane.rules
to add:

#Canon LiDE 120
usb 0x04a9 0x190e

Running scanimage -L returns:
device `genesys:libusb:001:009' is a Canon LiDE 120 flatbed scanner
But when I use simple scan or xscanimage the scanner just vibrates.
The scanner runs fine in puppy linux with the same driver (libsane-genesys.so.1.0.26).
Could it be a permission problem?
Thanks
Brendan

bh56
Level 1
Level 1
Posts: 2
Joined: Sun Dec 18, 2016 4:33 pm

Re: Canon 120 LiDE scanner works now on linux

Postby bh56 » Tue Dec 20, 2016 3:55 pm

Should have mentioned I'm using LM18.1, 32bit with a Dell Lattitude D820.
Today, if I run from a terminal:
scanimage --resolution 300 >image.pnm
It works fine.
And simple-scan now works. Strange.

mickeymops
Level 1
Level 1
Posts: 9
Joined: Sat Dec 28, 2013 5:56 pm

Re: Canon 120 LiDE scanner works now on linux

Postby mickeymops » Thu Oct 05, 2017 12:01 pm

scanimage --resolution 300 >image.pnm

Me too, I'm on 18.2 with Canon 200 LiDE not working in Simple Scan or XSane or Skanlite, ran the above in terminal, now Simple Scan works - many thanks


Return to “Printers & Scanners”