Page 1 of 1

Epson scanner blocked by firewall

Posted: Sun Dec 04, 2016 9:28 am
by Skin
Hello, I have an epson px720wd all in one printer, the printer is working but the scanner is blocked by the firewall: can you please help me to make a rule for the scanner? I don't know where to start...

Re: Espon scanner blocked by firewall

Posted: Sun Dec 04, 2016 9:38 am
by deepakdeshp

Code: Select all

 sudo ufw disable
will disable the Mint firewall. Test the scanner with fw disabled.
By default the fw is disabled.

Please see if this helps https://sites.google.com/site/easylinuxtipsproject/17
code] sudo ufw enable[/code] will enable the firewall.
You will need to assign a fixed ip to the scanner using your router.

Re: Espon scanner blocked by firewall

Posted: Sun Dec 04, 2016 12:24 pm
by Skin
Hello, the scanner works if the firewall is disabled and I've assigned a fixed ip to the printer/scanner, the problem is that I don't know how to make a rule in mint firewal :wink:

Re: Espon scanner blocked by firewall

Posted: Sun Dec 04, 2016 5:01 pm
by all41
these rules work for my Epson WF

Code: Select all

sudo ufw allow to ip 192.168.0.10

Code: Select all

sudo ufw allow from 192.168.0.10
of coarse sub your assigned ip

Re: Epson scanner blocked by firewall

Posted: Sun Dec 11, 2016 1:36 pm
by Arrababiski
Hi Skin!

I had the same problem with an Epson SX235W as described here:

viewtopic.php?f=51&t=228387

The only way I found to make scanner work was disabling firewall or using kernel 4.2. If you success trying to make scanner work with firewall enabled or a newer kernel, please, post the solution here. ;)