CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Forum rules
Before you post please read this
User avatar
Terryphi
Level 3
Level 3
Posts: 140
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by Terryphi » Mon Mar 27, 2017 7:05 am

Latest cups update wiped my printer data and produced this error:

Code: Select all

E: /var/cache/apt/archives/cups-daemon_2.1.3-4ubuntu0.2_amd64.deb: subprocess new pre-removal script returned error exit status 1
Last edited by Terryphi on Mon Mar 27, 2017 10:45 am, edited 1 time in total.
Version: LM 19 64bit Mate

User avatar
kc1di
Level 13
Level 13
Posts: 4587
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: CUPS update 2.1.3-4ubuntu0-2 produces error

Post by kc1di » Mon Mar 27, 2017 7:17 am

try this in a terminal

Code: Select all

sudo dpkg --configure -a
see if it works then.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

User avatar
Terryphi
Level 3
Level 3
Posts: 140
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

Re: CUPS update 2.1.3-4ubuntu0-2 produces error

Post by Terryphi » Mon Mar 27, 2017 8:49 am

Code: Select all

sudo dpkg --configure -a
produces this:

Code: Select all

dpkg: dependency problems prevent configuration of cups:
 cups depends on cups-daemon (>= 2.1.3-4ubuntu0.2); however:
  Version of cups-daemon on system is 2.1.3-4.

dpkg: error processing package cups (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups-core-drivers:
 cups-core-drivers depends on cups-daemon (>= 2.1.3-4ubuntu0.2); however:
  Version of cups-daemon on system is 2.1.3-4.

dpkg: error processing package cups-core-drivers (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 cups
 cups-core-drivers

User avatar
Terryphi
Level 3
Level 3
Posts: 140
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

Re: CUPS update 2.1.3-4ubuntu0-2 produces error

Post by Terryphi » Mon Mar 27, 2017 9:12 am

it appears that the required version of cups-daemon is not available on the Ubuntu server.

User avatar
kc1di
Level 13
Level 13
Posts: 4587
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: CUPS update 2.1.3-4ubuntu0-2 produces error

Post by kc1di » Mon Mar 27, 2017 10:15 am

it would seem that is true, But try this first:
(one command at a time)

Code: Select all

sudo apt-get purge cups
sudo apt-get autoclean
sudo apt-get clean
sudo apt-get update
Then try to install cups.

Code: Select all

sudo apt-get install cups
if that does not work we'll look at your apt source list.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

fstjohn
Level 2
Level 2
Posts: 64
Joined: Fri Jan 02, 2015 3:21 pm
Location: Georgia

Re: CUPS update 2.1.3-4ubuntu0-2 produces error

Post by fstjohn » Mon Mar 27, 2017 10:44 am

Same problem here on this morning's cups update:
E: /var/cache/apt/archives/cups-daemon_2.1.3-4ubuntu0.2_amd64.deb: subprocess new pre-removal script returned error exit status 1

User avatar
Terryphi
Level 3
Level 3
Posts: 140
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

Re: CUPS update 2.1.3-4ubuntu0-2 produces error

Post by Terryphi » Mon Mar 27, 2017 10:45 am

kc1di:

Before I read your post I did a

Code: Select all

sudo apt-get install -f
and this has solved the problem.
Possibly the repository had been fixed by the time I did it.
Anyway, thanks for your suggestions. :)

User avatar
Cobber
Level 3
Level 3
Posts: 193
Joined: Wed Feb 26, 2014 5:15 am
Location: Australia

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by Cobber » Mon Mar 27, 2017 10:50 am

As usual, I thought it was just me. Didn't think to check the forum.

I used Synaptic to fix what it said was one broken package and Synaptic then went ahead and did the update okay.
PC: Dual HDD: Mint 18.2 64-Bit KDE / Windows7 Professional
HP Dv7 Laptop Dual HDD: MX Linux / Windows 7 Home
Lenovo x230 Laptop Dual boot: Mint 18.1 64-Bit KDE / Windows7 Professional

fstjohn
Level 2
Level 2
Posts: 64
Joined: Fri Jan 02, 2015 3:21 pm
Location: Georgia

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by fstjohn » Mon Mar 27, 2017 10:54 am

Ran the terminal commands. Result of last command:

$ sudo apt-get install cups
Reading package lists... Done
Building dependency tree
Reading state information... Done
cups is already the newest version (2.1.3-4ubuntu0.2).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
cups : Depends: cups-daemon (>= 2.1.3-4ubuntu0.2)
cups-core-drivers : Depends: cups-daemon (>= 2.1.3-4ubuntu0.2)
cups-daemon : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

User avatar
kc1di
Level 13
Level 13
Posts: 4587
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: CUPS update 2.1.3-4ubuntu0-2 produces error

Post by kc1di » Mon Mar 27, 2017 11:03 am

Terryphi wrote:kc1di:

Before I read your post I did a

Code: Select all

sudo apt-get install -f
and this has solved the problem.
Possibly the repository had been fixed by the time I did it.
Anyway, thanks for your suggestions. :)
Glad you found a way to fix it.
please take a moment to mark thread Solved by editing the subject line of your first post.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

fstjohn
Level 2
Level 2
Posts: 64
Joined: Fri Jan 02, 2015 3:21 pm
Location: Georgia

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by fstjohn » Mon Mar 27, 2017 11:09 am

Tried again and all OK. Fixed for me, too.

beetm
Level 1
Level 1
Posts: 12
Joined: Mon Mar 27, 2017 12:04 pm

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by beetm » Mon Mar 27, 2017 12:09 pm

I'm still getting unmet dependencies as fstjohn (10:54am) above. I've tried all the suggestions in this thread.

Any ideas?
Registered Linux User: #448206
Linux Mint 18.1 - Cinnamon amd64

User avatar
kc1di
Level 13
Level 13
Posts: 4587
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by kc1di » Mon Mar 27, 2017 12:42 pm

beetm wrote:I'm still getting unmet dependencies as fstjohn (10:54am) above. I've tried all the suggestions in this thread.

Any ideas?
go to synaptic and see if you have any broken packages. and fix them if there are any and try update again.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

beetm
Level 1
Level 1
Posts: 12
Joined: Mon Mar 27, 2017 12:04 pm

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by beetm » Mon Mar 27, 2017 1:01 pm

I did have broken packages, fixed and updated still;

Code: Select all

The following packages have unmet dependencies:
 cups : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.2 is to be installed
        Depends: cups-core-drivers (>= 2.1.3-4)
        Depends: cups-daemon (>= 2.1.3-4)
E: Unable to correct problems, you have held broken packages.
Registered Linux User: #448206
Linux Mint 18.1 - Cinnamon amd64

User avatar
kc1di
Level 13
Level 13
Posts: 4587
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by kc1di » Mon Mar 27, 2017 2:11 pm

and you tried

Code: Select all

sudo apt-get install -f
with out any package name?

if that doesn't work wait a few hours and try again - some repositories may not have synced completely yet.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

beetm
Level 1
Level 1
Posts: 12
Joined: Mon Mar 27, 2017 12:04 pm

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by beetm » Mon Mar 27, 2017 3:01 pm

Yeah, I was wondering if they all synced at the same time or not seeing as the problem was solved for some of you here. I'll wait.
Thanks for your help!
Registered Linux User: #448206
Linux Mint 18.1 - Cinnamon amd64

sdahlstrom
Level 1
Level 1
Posts: 3
Joined: Mon Mar 27, 2017 3:01 pm
Location: Ohio, USA

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by sdahlstrom » Mon Mar 27, 2017 3:15 pm

I'm having all of the same issues without any luck from the previous suggestions. I switched my software sources back to the default repositories, assuming those would be the first to get the updates. However, it didn't help. Am I wrong in my assumption that the default repositories (packages.linuxmint.com and us.archive.ubuntu.com/ubuntu) should already have the necessary updates?

User avatar
kc1di
Level 13
Level 13
Posts: 4587
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by kc1di » Mon Mar 27, 2017 4:20 pm

sdahlstrom wrote:I'm having all of the same issues without any luck from the previous suggestions. I switched my software sources back to the default repositories, assuming those would be the first to get the updates. However, it didn't help. Am I wrong in my assumption that the default repositories (packages.linuxmint.com and us.archive.ubuntu.com/ubuntu) should already have the necessary updates?
I'm assuming that the packages will be on the ubuntu.come rep. since it's a unbuntu package. I'm not shure how fast the sync is on the US server.
But I installed it at about 11AM this morning with no problems.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

bwat47
Level 2
Level 2
Posts: 64
Joined: Sun May 01, 2011 1:31 am

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by bwat47 » Mon Mar 27, 2017 9:08 pm

This still doesn't work at all for me no matter what mirror I use

OptimusPrime
Level 1
Level 1
Posts: 8
Joined: Sat Mar 18, 2017 7:41 pm

Re: CUPS update 2.1.3-4ubuntu0-2 produces error [SOLVED]

Post by OptimusPrime » Mon Mar 27, 2017 9:28 pm

Novice here...

I also did the printer update this morning and it failed. Now I have no printer function.I followed the steps from the previous posts without success.

My initial error message -
Failed to restart cups.service: Unit cups.service is masked
~ $ sudo apt-get install -f
[sudo] password for xxxxxxx:
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 33 not upgraded.

~ $ sudo apt-get purge cups
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
cups*
0 upgraded, 0 newly installed, 1 to remove and 33 not upgraded.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 212392 files and directories currently installed.)
Removing cups (2.1.3-4ubuntu0.2) ...
Purging configuration files for cups (2.1.3-4ubuntu0.2) ...

~ $ sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
Del cups-bsd 2.1.3-4ubuntu0.2 [34.8 kB]
Del cups-ppdc 2.1.3-4ubuntu0.2 [26.6 kB]
Del libcupsppdc1 2.1.3-4ubuntu0.2 [44.9 kB]
Del cups-core-drivers 2.1.3-4ubuntu0.2 [27.3 kB]
Del libcupsimage2 2.1.3-4ubuntu0.2 [16.8 kB]
Del cups-server-common 2.1.3-4ubuntu0.2 [493 kB]
Del libcups2 2.1.3-4ubuntu0.2 [196 kB]
Del libcupsimage2 2.1.3-4ubuntu0.2 [16.1 kB]
Del libcupscgi1 2.1.3-4ubuntu0.2 [27.3 kB]
Del libcupsmime1 2.1.3-4ubuntu0.2 [13.1 kB]
Del cups-client 2.1.3-4ubuntu0.2 [133 kB]
Del libcups2 2.1.3-4ubuntu0.2 [212 kB]
Del cups 2.1.3-4ubuntu0.2 [192 kB]
Del cups-common 2.1.3-4ubuntu0.2 [134 kB]
Del cups-daemon 2.1.3-4ubuntu0.2 [301 kB]
scooterpi@AO532h ~ $ sudo apt-get clean
scooterpi@AO532h ~ $ sudo apt-get update
Ign:1 http://mirrors.kernel.org/linuxmint-packages serena InRelease
Hit:2 http://mirrors.kernel.org/linuxmint-packages serena Release
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:5 http://mirror.math.ucdavis.edu/ubuntu xenial InRelease
Hit:6 http://mirror.math.ucdavis.edu/ubuntu xenial-updates InRelease
Hit:7 http://mirror.math.ucdavis.edu/ubuntu xenial-backports InRelease
Hit:8 http://archive.canonical.com/ubuntu xenial InRelease
Hit:9 https://deb.opera.com/opera-stable stable InRelease
Fetched 102 kB in 3s (33.2 kB/s)
Reading package lists... Done

~ $ sudo apt-get install cups
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cups : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.2 is to be installed
Depends: cups-core-drivers (>= 2.1.3-4)
Depends: cups-daemon (>= 2.1.3-4)
Recommends: printer-driver-gutenprint but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
(here i went to synaptic and ran fix broken packages)
~ $ sudo apt-get install cups
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cups : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.2 is to be installed
Depends: cups-core-drivers (>= 2.1.3-4)
Depends: cups-daemon (>= 2.1.3-4)
Recommends: printer-driver-gutenprint but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
~ $
So no joy for now.
How do I go about finding the dependencies and fixing the broken packages?

Post Reply

Return to “Printers & Scanners”