[SOLVED] Printer won't wake from standby

Forum rules
Before you post please read this
User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

[SOLVED] Printer won't wake from standby

Postby JerryF » Fri Oct 06, 2017 3:50 pm

I have an Epson XP-640 that is connected wirelessly to my home network (wireless router). There are 4 devices that can print to that printer: Desktop (connected to router by Ethernet cable), Laptop (connected to router wirelessly), and 2 Android tablets (also connected to router wirelessly).

When the printer is in sleep mode, every time that any of those devices wants to print, print jobs don't print. Jobs show in the queue, but just hang.

I have to turn off, then turn on the printer for print jobs to finally print. In some cases, I have to delete the print job in the queue and have the print job resent.

Anyone have suggestions on what might be going on?

Thanks!
Last edited by JerryF on Mon Oct 23, 2017 8:31 am, edited 1 time in total.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
kyphi
Level 8
Level 8
Posts: 2123
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Printer won't wake from standby

Postby kyphi » Fri Oct 06, 2017 6:48 pm

Well of course it won't print while the printer is in sleep mode. The message in the printer window states that the printer is "Unplugged or turned off". Touch one of the controls on your printer even if not lit up and wake it up, there is no need to turn it off and back on again.

It is curious though that activating a scan will wake it from sleep.

This is a common problem on a wide variety of shared printers. Epson points the finger at the router setup.

A bit of research and a few trials later ....

The solution is to set up a second printer in System Settings, Hardware, Printer and set it up as a Network Printer, i.e. click on ADD, select Network Printer and select your printer from the list or use "Find Network Printer". Set it to Default.
Linux Mint 18.3 Cinnamon - 64bit

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Printer won't wake from standby

Postby JerryF » Sat Oct 07, 2017 10:54 am

kyphi wrote:Well of course it won't print while the printer is in sleep mode. The message in the printer window states that the printer is "Unplugged or turned off". Touch one of the controls on your printer even if not lit up and wake it up, there is no need to turn it off and back on again.

It is curious though that activating a scan will wake it from sleep.

This is a common problem on a wide variety of shared printers. Epson points the finger at the router setup.

A bit of research and a few trials later ....

The solution is to set up a second printer in System Settings, Hardware, Printer and set it up as a Network Printer, i.e. click on ADD, select Network Printer and select your printer from the list or use "Find Network Printer". Set it to Default.

Thanks for your reply.

I've tried touching the "Home" button on the panel of the printer which takes it out of sleep. This still does not let print jobs go through. The jobs get stuck in the queue. I have to delete the print job from the queue, turn off the printer, turn on the printer, then resend the print job.

For years (with Windows) I've had my printers go into sleep mode and they wake up to print.

I agree: it is curious that is wakes when doing a scan. I just tried it and it woke up to scan.

The printer is already set up as a Network Printer and is the Default.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
kyphi
Level 8
Level 8
Posts: 2123
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Printer won't wake from standby

Postby kyphi » Sat Oct 07, 2017 6:50 pm

While in sleep mode, the printer does not print and all requests accumulate in the print queue. Whether or not these will print later I do not know.

I suspect that the driver being downloaded and installed when setting up a Network Printer is a Network driver. This is not shown in Driver Manager.

Do please install a new Network Printer and set it to default to see if this fixes the problem - it did for me and I now have several devices that can access the Epson Artisan and wake it from slumber.
If it does not work, you can delete the extra printer.

This video shows the process quite well: https://www.youtube.com/watch?v=5lYbZptQ0Ds

Note that the printer must be switched on.
Linux Mint 18.3 Cinnamon - 64bit

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Printer won't wake from standby

Postby JerryF » Sun Oct 08, 2017 3:18 pm

I took your advice. Same results. :(

Thanks :)
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

JeremyB
Level 17
Level 17
Posts: 7566
Joined: Fri Feb 21, 2014 8:17 am

Re: Printer won't wake from standby

Postby JeremyB » Sun Oct 08, 2017 3:29 pm

Try restarting the router. It might work, otherwise I would contact Epson about this

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Printer won't wake from standby

Postby JerryF » Sun Oct 08, 2017 3:38 pm

JeremyB wrote:Try restarting the router. It might work, otherwise I would contact Epson about this

Thanks Jeremy, I also have tried that.

I'll contact Epson. By habit, I didn't think of doing that because many other companies don't even try to support Linux.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

JeremyB
Level 17
Level 17
Posts: 7566
Joined: Fri Feb 21, 2014 8:17 am

Re: Printer won't wake from standby

Postby JeremyB » Sun Oct 08, 2017 3:42 pm

But Epson tries to support Linux and you have the same problem with Android devices also

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Printer won't wake from standby

Postby JerryF » Sun Oct 08, 2017 5:28 pm

Yeah, so I'm wondering if it's the network (router) that may be the cause.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
kyphi
Level 8
Level 8
Posts: 2123
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Printer won't wake from standby

Postby kyphi » Sun Oct 08, 2017 11:15 pm

Just to let you know what is happening on my network.

Epson Artisan powered on, the configuration screen for WLAN in my router (Fritz!Box) shows Epson as wi-fi connected and active and also shows the signal strength. Signal strength is also displayed on the Epson Artisan screen. All other devices (android and laptops) show as inactive currently but show when they were last connected.

Can you access your WLAN configuration on your router ?
Linux Mint 18.3 Cinnamon - 64bit

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Printer won't wake from standby

Postby JerryF » Mon Oct 09, 2017 12:15 pm

kyphi wrote:Just to let you know what is happening on my network.

Epson Artisan powered on, the configuration screen for WLAN in my router (Fritz!Box) shows Epson as wi-fi connected and active and also shows the signal strength. Signal strength is also displayed on the Epson Artisan screen. All other devices (android and laptops) show as inactive currently but show when they were last connected.

Can you access your WLAN configuration on your router ?

Yes, I can.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
ClixTrix
Level 4
Level 4
Posts: 213
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Printer won't wake from standby

Postby ClixTrix » Mon Oct 23, 2017 8:08 am

I have some questions that might help diagnose the problem:

1) Is the printer assigned a static IP address or using DHCP and what is the address?

2) If you are using DHCP for the printer, have you tried using a static IP address?

3) If the router is running DHCP server, what is the address range it's assigning and what is the renewal period?

4) if the the printer has a static address, is it an address outside the DHCP range (if router is running DHCP server)?

5) You mentioned that the printer is connected to your computer via ethernet cable. Does that mean you're using a direct cable and not connecting both devices to the router via ethernet cables? If that is true, is the computer also using wifi to access the router? If these assumptions are correct, disconnect the ethernet from the printer and see if the other wifi devices can print after printer sleeps.

6) When the printer is sleeping, have you tried running PING from terminal to see if it responds? Most printers also provide a console that can be accessed from browser by simply entering the printer address into the URL line, like accessing router.

Here's an example of PING to my Epson WF-2760 while sleeping.
Last edited by ClixTrix on Mon Oct 23, 2017 8:31 am, edited 1 time in total.
Linux Mint 18.2 x64 Cinnamon Kernel 4.10.0-42 Xenial
Gigabyte GA-AB350M-D3H (F5a) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 16GB (2x8GB) /XFX HD5450-1GB
SSD Samsung EVO 960 250GB / HDD WD1600BEKT 160GB / SSD Toshiba OCZ VX500 512GB

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Printer won't wake from standby

Postby JerryF » Mon Oct 23, 2017 8:30 am

ClixTrix wrote:...

Here's an example of PING to my Epson WF-2760 while sleeping.


When I recently went back from MATE to Cinnamon, I did a complete reinstall of the printer on all devices. It now wakes from sleep using all devices.

Per question 5---to reiterate, the printer is connected wirelessly to the router. The desktop is connected to the router by Ethernet cable.

When I get the chance, I will perform the ping as you suggest and post results to see if I get same results. For enlightenment for myself, I will answer your questions too.

I will mark as solved.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
ClixTrix
Level 4
Level 4
Posts: 213
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: [SOLVED] Printer won't wake from standby

Postby ClixTrix » Mon Oct 23, 2017 8:50 am

Glad problem is solved. Odd that switching back to Cinnamon was a fix? :?

I was suspicious the printer might be using DHCP and was not getting DHCP renewals. That might explain it showing wifi connected, but not reachable for printing. I've had the same problem with an Arris DCX3635-W Cable Gateway/Router that's got buggy microcode for tracking connected wifi devices and DHCP. I was tempted to ask if you're using WOW! cable. The router tables get confused, even with static addressing. Only way to fix that problem is to cycle the printer off/on.

I also considered a conflict with both local ethernet and wifi connection, especially if you were doing direct cable between printer and computer. Epson implements IP address on my Epson using same address for both the ethernet port and the wifi.
Linux Mint 18.2 x64 Cinnamon Kernel 4.10.0-42 Xenial
Gigabyte GA-AB350M-D3H (F5a) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 16GB (2x8GB) /XFX HD5450-1GB
SSD Samsung EVO 960 250GB / HDD WD1600BEKT 160GB / SSD Toshiba OCZ VX500 512GB

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Printer won't wake from standby

Postby JerryF » Mon Oct 23, 2017 6:17 pm

Hi ClixTrix:

Thanks for your reply.

ClixTrix wrote:1) Is the printer assigned a static IP address or using DHCP and what is the address?

I assigned a static IP address at 192.168.1.5

2) If you are using DHCP for the printer, have you tried using a static IP address?

N/A

3) If the router is running DHCP server, what is the address range it's assigning and what is the renewal period?

Yes, the router's connection type is DHCP. The start address is 192.168.1.2 to 192.168.1.254, but I can't find anything that says a renewal period.

4) if the the printer has a static address, is it an address outside the DHCP range (if router is running DHCP server)?

No.

5) You mentioned that the printer is connected to your computer via ethernet cable. Does that mean you're using a direct cable and not connecting both devices to the router via ethernet cables? If that is true, is the computer also using wifi to access the router? If these assumptions are correct, disconnect the ethernet from the printer and see if the other wifi devices can print after printer sleeps.

The printer is connected wirelessly to the router. Only the desktop is connected to the router by Ethernet cable.

6) When the printer is sleeping, have you tried running PING from terminal to see if it responds? Most printers also provide a console that can be accessed from browser by simply entering the printer address into the URL line, like accessing router.


I pinged my sleeping Epson XP-640 at 192.168.1.5. I got the a similar result as you (see below).

Code: Select all

PING 192.168.1.5 (192.168.1.5) 56(84) bytes of data.
64 bytes from 192.168.1.5: icmp_seq=1 ttl=64 time=5.34 ms
64 bytes from 192.168.1.5: icmp_seq=2 ttl=64 time=2.05 ms
64 bytes from 192.168.1.5: icmp_seq=3 ttl=64 time=3.63 ms
64 bytes from 192.168.1.5: icmp_seq=4 ttl=64 time=1.96 ms
64 bytes from 192.168.1.5: icmp_seq=5 ttl=64 time=2.15 ms
^C
--- 192.168.1.5 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 1.968/3.030/5.342/1.308 ms


I entered the printer's IP address into a browser and yes, it has an interface/console with Basic and Advanced Settings:
2017_10_23_01.jpg

2017_10_23_02.jpg
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
ClixTrix
Level 4
Level 4
Posts: 213
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: [SOLVED] Printer won't wake from standby

Postby ClixTrix » Tue Oct 24, 2017 6:56 am

When the Router is providing DHCP service, any static assigned addresses need to be outside the DHCP pool range, e.g use 192.168.1.200 for the printer and any other static addressed devices up to .254, and give the DCHP pool the range 192.168.1.2 - 199. The use of .5 is inside the pool range and a conflict. Epson's instructions on how to setup a static IP may have mentioned that requirement.

What's the make and model of the router? I'm asking because some router devices (like the gateway I mentioned) use multiple reserved addresses at the lower end of the subnet, e.g. my gateway uses .1 for the router and .2 for MOCA (ethernet over cable). So, it's generally safer to use static addresses at the upper end of the subnet range and the reserve DHCP pool at the lower end.

The renewal is based upon a DHCP lease which is often default at 24 hours, but usually has a setting in the router configuration....and usually where the pool range is set. I ask because a renewal request happens at half-life, e.g. 24 lease gets renewal at 12 hours.
Linux Mint 18.2 x64 Cinnamon Kernel 4.10.0-42 Xenial
Gigabyte GA-AB350M-D3H (F5a) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 16GB (2x8GB) /XFX HD5450-1GB
SSD Samsung EVO 960 250GB / HDD WD1600BEKT 160GB / SSD Toshiba OCZ VX500 512GB

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: [SOLVED] Printer won't wake from standby

Postby JerryF » Tue Oct 24, 2017 8:24 am

ClikTrix,

Thanks again for your reply. I so grateful to members like you---I'm learning so much! I am not experienced with networks. I got certified as a desktop technician, and had one class in wireless as a network class (which we didn't learn anything about what you're referencing).

When I set up the static IP addresses, I googled how to do that, so I didn't check Epson's website. I should have started there.

My router is Netis WF2419. As of now, I have 6 devices set up with static IP addresses. 192.168.1.2 - 7. I haven't seen anything about the need for address 192.168.1.2 for MOCA in any of the manuals for the router. As of right now, .2 address is reserved for the desktop which is connected by Ethernet cable to the router.

I will reassign the reserved address devices to the upper range and set the DHCP range below that upper range. Should I also reassign the .2 desktop that's connected by Ethernet cable to router?

P.S. I have the latest firmware installed for the router. As for the printer, there is a firmware update - recovery, but that's only if the printer's control panel displays a Recovery Mode error.
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.

User avatar
ClixTrix
Level 4
Level 4
Posts: 213
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: [SOLVED] Printer won't wake from standby

Postby ClixTrix » Tue Oct 24, 2017 9:47 am

Normally, I use static addresses for services items, e.g. printer, NAS, Server, etc. I would set the desktop and any other PC/Laptop/Pad/Phone to use DHCP to get their addresses and set the printer to a high address above a DHCP pool range. However, if you want to give every device a fixed address, just disable DHCP Server in the router configuration. That way the router won't get confused. The downside is every device that comes in the door would need to be manually addressed with a static IP, like a guest needing Internet. Without disrupting the current static addresses, you could also try assigning DHCP pool to a high address range and test. Technically, that should work....IF your router has no problem with that change.

MOCA is normally on Gateway boxes (with integrated router) from cable providers, like WOW. The MOCA provides services to any TV or other device in the home using the cable as an ethernet. Usually, it's an Arris box. No, that Netis WF2419 router isn't MOCA.
Linux Mint 18.2 x64 Cinnamon Kernel 4.10.0-42 Xenial
Gigabyte GA-AB350M-D3H (F5a) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 16GB (2x8GB) /XFX HD5450-1GB
SSD Samsung EVO 960 250GB / HDD WD1600BEKT 160GB / SSD Toshiba OCZ VX500 512GB

User avatar
JerryF
Level 7
Level 7
Posts: 1730
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: [SOLVED] Printer won't wake from standby

Postby JerryF » Tue Oct 24, 2017 11:04 am

I think I'll try the latter approach.

...Without disrupting the current static addresses, you could also try assigning DHCP pool to a high address range and test. Technically, that should work....IF your router has no problem with that change.

Because I only have a few devices and don't see myself getting a whole lot more in the future, I could set the lower range of DHCP higher than my static addresses (example: lower range 192.168.1.20 and leave the upper range where it is.)

P.S. The only reason I started with static addressing was that the scanner part wasn't being recognized. In the forums, I found that I had to edit the contents of two files /etc/sane.d/dll.conf and /etc/sane.d/epson2.conf

dll.conf needed two lines:
epson2
net


and

epson2.conf needed to be edited:
net autodiscovery had to be changed to net 192.168.1.5 which is the printer's IP address now.

If I leave the line contents as net autodiscovery, scanner isn't recognized.

Thanks again! This experience is better than taking a class, and I love learning!!!
Don't forget to edit your original post and add [SOLVED] to the beginning of the Subject line if your problem has been fixed.
My main language is English. I speak very little Portuguese, and a whole lot of gibberish.


Return to “Printers & Scanners”