[SOLVED] Not printing in 18.02

Forum rules
Before you post please read this
bobbraz
Level 1
Level 1
Posts: 13
Joined: Wed Nov 01, 2017 1:54 pm

Re: Not printing in 18.02

Postby bobbraz » Sat Nov 04, 2017 5:38 pm

I have removed HPLIP in order to start over again.
Is there a terminal command line to install it?
As in sudo apt install ?????.
Thanks. Bob.

User avatar
Joe2Shoe
Level 2
Level 2
Posts: 50
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Not printing in 18.02

Postby Joe2Shoe » Sat Nov 04, 2017 7:42 pm

See my last post.

Step 1. Remove and Reinstall HPLIP.

Step 2. Install HPLIP Binary Plugin (either automatically or manually).
Good luck.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

bobbraz
Level 1
Level 1
Posts: 13
Joined: Wed Nov 01, 2017 1:54 pm

Re: Not printing in 18.02

Postby bobbraz » Mon Nov 06, 2017 12:32 pm

Thanks to all. Because of your help I got this up and running again.
Thank You!!

bobbraz
Level 1
Level 1
Posts: 13
Joined: Wed Nov 01, 2017 1:54 pm

Re: Not printing in 18.02

Postby bobbraz » Mon Nov 06, 2017 12:34 pm

Sorry but how to I mark this as solved?? <G>
Bob.

User avatar
jimallyn
Level 16
Level 16
Posts: 6755
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Not printing in 18.02

Postby jimallyn » Mon Nov 06, 2017 6:08 pm

bobbraz wrote:Sorry but how to I mark this as solved?

Go to your first post and click on the pencil icon to edit your post. Add <SOLVED> to the subject line, then re-save.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

bobbraz
Level 1
Level 1
Posts: 13
Joined: Wed Nov 01, 2017 1:54 pm

Re: Not printing in 18.02 solved

Postby bobbraz » Mon Nov 06, 2017 6:22 pm

Thank you!

User avatar
Joe2Shoe
Level 2
Level 2
Posts: 50
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Not printing in 18.02 solved

Postby Joe2Shoe » Mon Nov 06, 2017 8:14 pm

Exactly what worked to get it up and running, so others will be able to fix the same issue?
Glad it worked out for you.
Whooppee!
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

pdc_2
Level 7
Level 7
Posts: 1895
Joined: Mon May 11, 2009 1:21 am

Re: Not printing in 18.02 solved

Postby pdc_2 » Tue Nov 07, 2017 3:47 am

yes, back in post #6 Bob you reported a host of errors and missing files;

would be willing to run
hp-check
again, for us to see what your system reports: indeed in post #14 jimallyn suggested you think of reinstalling as they seemed so much wrong: jim cut to the chase; where the rest of us were thinking the same thing!!

......... so how did you get out of the maze; and will you run the above command again for us?

bobbraz
Level 1
Level 1
Posts: 13
Joined: Wed Nov 01, 2017 1:54 pm

Re: [SOLVED] Not printing in 18.02

Postby bobbraz » Tue Nov 07, 2017 5:20 pm

Sure. Here's the report. I purged than re-installed and despite this report everything is working fine.
Thanks again for the help.


bob@bob-HP-Notebook:~$ hp-check
Saving output in log file: /home/bob/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.7)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
OK
MISSING - Missing Dependency or Permission or Plug-in
INCOMPAT - Incompatible dependency-version or Plugin-version

warning: 12-17.10 version is not supported. Using 12-17.04 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

Kernel: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:35:14 UTC 2017 GNU/Linux
Host: bob-HP-Notebook
Proc: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:35:14 UTC 2017 GNU/Linux
Distribution: 12 17.10
Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.7
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 12 distro 17.10 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.7

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.7
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/simple-scan %SANE_URI%

[fax]
email_address =
voice_phone =

[installation]
date_time = 11/07/17 13:18:39
version = 3.17.7

[last_used]
device_uri = "hp:/usb/DeskJet_3630_series?serial=CN68J3H0S406MP"
printer_name =
working_dir = .

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1509908940
notify_upgrade = false
pending_upgrade_time = 0


<Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.21 OK -
error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - MISSING 'xsane needs to be installed'
scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
error: dbus DBus - Message bus system REQUIRED - 1.10.22 MISSING 'DBUS may not be installed or not running'
policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
network network -wget OPTIONAL - 1.19.1 OK -
avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -

------------------------
| General Dependencies |
------------------------

error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
error: libpthread libpthread - POSIX threads library REQUIRED - b'2.26' MISSING 'libpthread needs to be installed'
error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
sane SANE - Scanning library REQUIRED - - OK -
error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 MISSING 'libcrypto needs to be installed'
python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.3 OK -
python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.4 OK -
python3-xml Python XML libraries REQUIRED - 2.2.3 OK -
error: python3-devel Python devel - Python development files REQUIRED 2.2 3.6.3 MISSING 'python3-devel needs to be installed'
python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -

--------------
| COMPILEDEP |
--------------

error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - - MISSING 'gcc needs to be installed'
error: make make - GNU make utility to maintain groups of programs REQUIRED 3.0 - MISSING 'make needs to be installed'

---------------------
| Python Extentions |
---------------------

cupsext CUPS-Extension REQUIRED - 3.17.7 OK -
hpmudext IO-Extension REQUIRED - 3.17.7 OK -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
hpaio HPLIP-SANE-Backend REQUIRED - 3.17.7 OK 'hpaio found in /etc/sane.d/dll.conf'
scanext Scan-SANE-Extension REQUIRED - 3.17.7 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/ENVY_4500_series?serial=CN4C9251Y305X4' is a Hewlett-Packard ENVY_4500_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

Device URI Model
-------------------------------- -------------------
hp:/usb/ENVY_4500_series?serial= HP ENVY 4500 series
CN4C9251Y305X4

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------


DeskJet-3630
------------
Type: Printer
Device URI: hp:/usb/DeskJet_3630_series?serial=CN68J3H0S406MP
PPD: /etc/cups/ppd/DeskJet-3630.ppd
warning: Failed to read /etc/cups/ppd/DeskJet-3630.ppd ppd file
PPD Description:
Printer status: printer DeskJet-3630 is idle. enabled since Fri 03 Nov 2017 08:54:09 AM PDT
error: Unable to communicate with device (code=12): hp:/usb/DeskJet_3630_series?serial=CN68J3H0S406MP
error: Device not found
error: Communication status: Failed

ENVY-4500
---------
Type: Printer
Device URI: hp:/usb/ENVY_4500_series?serial=CN4C9251Y305X4
PPD: /etc/cups/ppd/ENVY-4500.ppd
warning: Failed to read /etc/cups/ppd/ENVY-4500.ppd ppd file
PPD Description:
Printer status: printer ENVY-4500 is idle. enabled since Tue 07 Nov 2017 01:18:02 PM PST
Communication status: Good


--------------
| PERMISSION |
--------------

USB ENVY-4500 Required - - OK Node:'/dev/bus/usb/002/014' Perm:' root lp rw- rw- rw- rw- r--'

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible
error: 'libdbus-1-dev' package is missing/incompatible
error: 'libjpeg-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible
error: 'build-essential' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp-mibs-downloader' package is missing/incompatible
error: 'openssl' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'libtool' package is missing/incompatible
error: 'libtool-bin' package is missing/incompatible
error: 'build-essential' package is missing/incompatible
error: 'build-essential' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'xsane' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Total Errors: 18
Total Warnings: 0


Done.
bob@bob-HP-Notebook:~$

pdc_2
Level 7
Level 7
Posts: 1895
Joined: Mon May 11, 2009 1:21 am

Re: [SOLVED] Not printing in 18.02

Postby pdc_2 » Tue Nov 07, 2017 9:57 pm

so I haven't lined up all the reported deficiences from the earlier post; with this list; seems to me most are unchanged;

_____
we all like to think things are vaguely rational; and hplip would baulk at the missing things;

going back over things, it seems like the sequence is

Code: Select all

hp-check
and then

Code: Select all

hp-setup
....... but it sort of seems like hplip set up the printer; even though there were many missing items ...... interesting .............

____-
in this post, from the thread just before this one viewtopic.php?f=51&t=255042 meneer commented
hp-check revealed dependency issues. The hplip installer is pretty good at fixing these,


but for Bob, it didn't seem to resolve the deficiencies

User avatar
Joe2Shoe
Level 2
Level 2
Posts: 50
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: [SOLVED] Not printing in 18.02

Postby Joe2Shoe » Wed Nov 08, 2017 9:38 am

pdc_2, I noticed that, also. Cups and python are fubar. Maybe updating/reinstalling those two may resolve some if not all dependencies. But, the printer prints, regardless. Go figure.

I believe he missed this section that I posted earlier (very important, which reflects the python dependencies.)
Manually install HPLIP (the latest version, based on what version of Python is on your system):
If your python version is 2.6 or greater, please download this Download Tarball.
To run the installer manually, after extracting the tarball, cd into the 3.17.10 directory (or the download directory) and run hplip-install.

Or, if Python version is 2.5 or less, please download this HPLIP tarball.
To run the installer manually, after extracting the tarball, cd into the 3.17.10_py2.5 directory (or the download directory) and run hplip-install.

I'm sure these dependency issues will cause lots of chaos and havoc on down the line................

My last worlds on this topic..."Mongo go where choo-choo go..." :lol:
Tally ho!
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

steveb7az
Level 1
Level 1
Posts: 5
Joined: Thu May 14, 2015 1:10 am

Re: [SOLVED] Not printing in 18.02

Postby steveb7az » Tue Nov 21, 2017 12:46 am

I ran into this same problem just recently. Everything had been working fine but my drive failed so I had to do a clean install of 18.2. Although I configured my LJ4000n the same as before it would only print test pages, nothing else. For me the solution was:

1. Run hp-check and install the "missing/incompatible" packages;
2. Run hp-plugin;
3. Run hp-setup.

pdc_2
Level 7
Level 7
Posts: 1895
Joined: Mon May 11, 2009 1:21 am

Re: [SOLVED] Not printing in 18.02

Postby pdc_2 » Tue Nov 21, 2017 3:50 am

thanks; interesting you needed?

Code: Select all

hp-plugin
as HP says no plug-in needed; they suggest hplip > 0.9.5 is needed for your 4000N;


Return to “Printers & Scanners”