[SOLVED] HP OfficeJet 8715 plugged in via USB not detected. Simple Scanner says No Scanners Detected.

Forum rules
Before you post please read this
Post Reply
James_Smith
Level 4
Level 4
Posts: 366
Joined: Wed Feb 18, 2015 6:41 pm

[SOLVED] HP OfficeJet 8715 plugged in via USB not detected. Simple Scanner says No Scanners Detected.

Post by James_Smith » Thu Dec 14, 2017 11:53 pm

I just updated to LM 18.3 and just got a new printer/scanner (HP OfficeJet Pro 8715).

Last week this computer was LM 18.2 and the printer I had was an HP OfficeJet Pro 8500. It worked fine (via USB cable—I never connected it via WiFi). I didn't have any trouble at all. Now this one is giving me a hard time.

Here's my computer's hw/sw information:

Code: Select all

System:    Host: mac-Inspiron-13-7378 Kernel: 4.13.0-19-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 13-7378
           Mobo: Dell model: 0DD6CR v: A00
           Bios: Dell v: 1.9.0 date: 06/05/2017
CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
           clock speeds: max: 3100 MHz 1: 2700 MHz 2: 2700 MHz 3: 2700 MHz
           4: 2700 MHz
Graphics:  Card: Intel Device 5916 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-19-generic
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
           Card-2: Atheros usb-ID: 001-003
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 384.2GB (21.8% used)
           ID-1: /dev/sda model: SK_hynix_SC308_S size: 256.1GB
           ID-2: USB /dev/sdb model: SD/MMC/MS_PRO size: 128.2GB
           Optical: No optical drives detected.
Partition: ID-1: / size: 117G used: 67G (61%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 59.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 241 Uptime: 4:50 Memory: 3643.9/15913.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by James_Smith on Thu Dec 21, 2017 3:45 am, edited 2 times in total.
sudo apt-get --purge remove macOS

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Simple Scanner: No Scanners Detected

Post by austin.texas » Fri Dec 15, 2017 12:03 am

Have you installed hplip ? If not, you should.

Code: Select all

sudo apt-get install hplip
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

James_Smith
Level 4
Level 4
Posts: 366
Joined: Wed Feb 18, 2015 6:41 pm

Re: Simple Scanner: No Scanners Detected

Post by James_Smith » Fri Dec 15, 2017 12:32 am

austin.texas wrote:Have you installed hplip ? If not, you should.

Code: Select all

sudo apt-get install hplip
Yup!

Code: Select all

mac@Inspiron-13-7378 ~ $ sudo apt-get install hplip
[sudo] password for mac: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
hplip is already the newest version (3.16.3+repack0-1).
The following packages were automatically installed and are no longer required:
  linux-headers-4.8.0-53 linux-headers-4.8.0-53-generic
  linux-image-4.8.0-53-generic linux-image-extra-4.8.0-53-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
mac@Inspiron-13-7378 ~ $ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  linux-headers-4.8.0-53 linux-headers-4.8.0-53-generic
  linux-image-4.8.0-53-generic linux-image-extra-4.8.0-53-generic
0 upgraded, 0 newly installed, 4 to remove and 2 not upgraded.
After this operation, 315 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 658755 files and directories currently installed.)
Removing linux-headers-4.8.0-53-generic (4.8.0-53.56~16.04.1) ...
Removing linux-headers-4.8.0-53 (4.8.0-53.56~16.04.1) ...
Removing linux-image-extra-4.8.0-53-generic (4.8.0-53.56~16.04.1) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
Error! echo
Your kernel headers for kernel 4.8.0-53-generic cannot be found at
/lib/modules/4.8.0-53-generic/build or /lib/modules/4.8.0-53-generic/source.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
update-initramfs: Generating /boot/initrd.img-4.8.0-53-generic
Warning: No support for locale: en_US.utf8
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.13.0-19-generic
Found initrd image: /boot/initrd.img-4.13.0-19-generic
Found linux image: /boot/vmlinuz-4.13.0-17-generic
Found initrd image: /boot/initrd.img-4.13.0-17-generic
Found linux image: /boot/vmlinuz-4.13.0-16-generic
Found initrd image: /boot/initrd.img-4.13.0-16-generic
Found linux image: /boot/vmlinuz-4.11.0-14-generic
Found initrd image: /boot/initrd.img-4.11.0-14-generic
Found linux image: /boot/vmlinuz-4.10.0-38-generic
Found initrd image: /boot/initrd.img-4.10.0-38-generic
Found linux image: /boot/vmlinuz-4.10.0-35-generic
Found initrd image: /boot/initrd.img-4.10.0-35-generic
Found linux image: /boot/vmlinuz-4.10.0-33-generic
Found initrd image: /boot/initrd.img-4.10.0-33-generic
Found linux image: /boot/vmlinuz-4.10.0-28-generic
Found initrd image: /boot/initrd.img-4.10.0-28-generic
Found linux image: /boot/vmlinuz-4.10.0-27-generic
Found initrd image: /boot/initrd.img-4.10.0-27-generic
Found linux image: /boot/vmlinuz-4.10.0-26-generic
Found initrd image: /boot/initrd.img-4.10.0-26-generic
Found linux image: /boot/vmlinuz-4.8.0-53-generic
Found initrd image: /boot/initrd.img-4.8.0-53-generic
Found linux image: /boot/vmlinuz-4.4.0-83-generic
Found initrd image: /boot/initrd.img-4.4.0-83-generic
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-4.8.0-53-generic (4.8.0-53.56~16.04.1) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
dkms: removing: ndiswrapper 1.60 (4.8.0-53-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  ndiswrapper
Version: 1.60
Kernel:  4.8.0-53-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

ndiswrapper.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.8.0-53-generic/updates/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
update-initramfs: Deleting /boot/initrd.img-4.8.0-53-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.8.0-53-generic /boot/vmlinuz-4.8.0-53-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.13.0-19-generic
Found initrd image: /boot/initrd.img-4.13.0-19-generic
Found linux image: /boot/vmlinuz-4.13.0-17-generic
Found initrd image: /boot/initrd.img-4.13.0-17-generic
Found linux image: /boot/vmlinuz-4.13.0-16-generic
Found initrd image: /boot/initrd.img-4.13.0-16-generic
Found linux image: /boot/vmlinuz-4.11.0-14-generic
Found initrd image: /boot/initrd.img-4.11.0-14-generic
Found linux image: /boot/vmlinuz-4.10.0-38-generic
Found initrd image: /boot/initrd.img-4.10.0-38-generic
Found linux image: /boot/vmlinuz-4.10.0-35-generic
Found initrd image: /boot/initrd.img-4.10.0-35-generic
Found linux image: /boot/vmlinuz-4.10.0-33-generic
Found initrd image: /boot/initrd.img-4.10.0-33-generic
Found linux image: /boot/vmlinuz-4.10.0-28-generic
Found initrd image: /boot/initrd.img-4.10.0-28-generic
Found linux image: /boot/vmlinuz-4.10.0-27-generic
Found initrd image: /boot/initrd.img-4.10.0-27-generic
Found linux image: /boot/vmlinuz-4.10.0-26-generic
Found initrd image: /boot/initrd.img-4.10.0-26-generic
Found linux image: /boot/vmlinuz-4.4.0-83-generic
Found initrd image: /boot/initrd.img-4.4.0-83-generic
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
sudo apt-get --purge remove macOS

User avatar
jimallyn
Level 18
Level 18
Posts: 8469
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Simple Scanner: No Scanners Detected

Post by jimallyn » Fri Dec 15, 2017 4:11 am

austin.texas wrote:Have you installed hplip ?
I believe all versions of Mint come with hplip pre-installed.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Simple Scanner: No Scanners Detected

Post by pdc_2 » Fri Dec 15, 2017 5:15 am

so I think Mint 18.3 has only hplip 3.16.3 and HP https://developers.hp.com/hp-linux-imag ... ices/index think the 8715 needs at least 3.16.5 so you had best install the latest (3.17.11 I think it is ..) from here

https://developers.hp.com/hp-linux-imag ... g/gethplip

and if that doesn't trigger an automatic setup, then

Code: Select all

hp-setup
in a terminal should ..........and if one wants to proceed very thoroughly then run

Code: Select all

hp-check
before the setup command ............

James_Smith
Level 4
Level 4
Posts: 366
Joined: Wed Feb 18, 2015 6:41 pm

Re: Simple Scanner: No Scanners Detected

Post by James_Smith » Fri Dec 15, 2017 4:57 pm

pdc_2 wrote:so I think Mint 18.3 has only hplip 3.16.3 and HP https://developers.hp.com/hp-linux-imag ... ices/index think the 8715 needs at least 3.16.5 so you had best install the latest (3.17.11 I think it is ..) from here

https://developers.hp.com/hp-linux-imag ... g/gethplip
Ok, I'm downloading 3.17.11 now (I'm in the middle of nowhere, so my internet speed is slow) but in the meantime, I decided to open up my update manager to see what updates are available and I got this peculiar message:
W: http://www.openprinting.org/download/pr ... elease.gpg: Signature by key F8897B6F00075648E248B7EC24CBF5474CFD1E2F uses weak digest algorithm (SHA1)
W: GPG error: http://download.opensuse.org/repositori ... untu_16.04 Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E3757B8E0D988D6E
W: The repository 'http://download.opensuse.org/repositori ... untu_16.04 Release' is not signed.
I'm a little busy so I can't focus on it now, but I wanted to put this out there for the troubleshooters of this forum as a possible hint.

And, here's another possible hint: the printer is slooooooooow. Very slow. Slowest printer I've seen since the 1990s. It takes over 7 minutes to print anything. And this isn't just with my Linux machine: I tried it with a Windows 7 machine and a Windows 10 machine and it's consistently over 7 minutes to print anything—and that's using a USB connection.

Thanks for your help. I will return to this thread later today.
sudo apt-get --purge remove macOS

James_Smith
Level 4
Level 4
Posts: 366
Joined: Wed Feb 18, 2015 6:41 pm

Re: Simple Scanner: No Scanners Detected

Post by James_Smith » Tue Dec 19, 2017 1:00 am

pdc_2 wrote:so I think Mint 18.3 has only hplip 3.16.3 and HP https://developers.hp.com/hp-linux-imag ... ices/index think the 8715 needs at least 3.16.5 so you had best install the latest (3.17.11 I think it is ..) from here

https://developers.hp.com/hp-linux-imag ... g/gethplip

and if that doesn't trigger an automatic setup, then

Code: Select all

hp-setup
in a terminal should ..........and if one wants to proceed very thoroughly then run

Code: Select all

hp-check
before the setup command ............
Hmmm... I am very confused now.

Well, for one thing, I can't print or scan now. I was able to print one thing the other day just before I made this post. Now it won't print anything. It does print with a Windows 10 computer.

So, I downloaded hplip 3.17.11 as you recommended and saved it to my desktop. As I expected, this
Image
appeared on my desktop.

Being ignorant (and having not carefully read your post), I double-clicked it and it did this...
Image

And then this...
Image

I thought maybe I should run it in Terminal, but that wasn't an option. So then I re-read your post and saw your instructions. Here is what happened when I tried hp-setup:

Code: Select all

mac@iPad-2 ~ $ hp-setup

HP Linux Imaging and Printing System (ver. 3.16.3)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb

Done.
Note: Please ignore where it says iPad. That's a long story. Suffice it to say that this is a Dell Inspiron 13 7378.

When I tried hp-check, this happened:

Code: Select all

mac@iPad-2 ~ $ hp-check
Saving output in log file: /home/mac/hp-check.log

HP Linux Imaging and Printing System (ver. 3.16.3)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP  
supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed
to successfully compile HPLIP.                                                          
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied   
package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper     
dependencies installed to successfully run.                                             
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check 
both of the above cases (both compile- and run-time dependencies).                      

Check types:                                                                            
a. EXTERNALDEP - External Dependencies                                                  
b. GENERALDEP - General Dependencies (required both at compile and run time)            
c. COMPILEDEP - Compile time Dependencies                                               
d. [All are run-time checks]                                                            
PYEXT SCANCONF QUEUES PERMISSION                                                        

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: linuxmint-18.3 version is not supported. Using linuxmint-17.3 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.13.0-19-generic #22~16.04.1-Ubuntu SMP Mon Dec 4 15:35:18 UTC 2017 GNU/Linux
 Host: iPad-2
 Proc: 4.13.0-19-generic #22~16.04.1-Ubuntu SMP Mon Dec 4 15:35:18 UTC 2017 GNU/Linux
 Distribution: linuxmint 18.3
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.16.3
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  18.3 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.16.3

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.16.3
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = "hpfax:/usb/Officejet_Pro_8500_A910?serial=CN11OAK2V2"
printer_name = 
working_dir = .

[commands]
scan = /usr/bin/simple-scan %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list = 

[fax]
voice_phone = 
email_address = 

[upgrade]
notify_upgrade = true
last_upgraded_time = 1512287220
pending_upgrade_time = 0

[installation]
date_time = 12/18/17 22:42:04
version = 3.16.3


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------------------
|  External Dependencies |
--------------------------

 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.25          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.6.32          OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 error: dbus          DBus - Message bus system                                    REQUIRED        -               1.10.6          MISSING    'DBUS may not be installed or not running'
 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.18            OK         -
 network              network -wget                                                OPTIONAL        -               1.17.1          OK         -
 error: xsane         xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             -               MISSING    'xsane needs to be installed'

-------------------------
|  General Dependencies |
-------------------------

 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.3.0           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.5.2           OK         -
 error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
 error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 python3-pyqt4        PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.11.4          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.1.0           OK         -
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.5.2           MISSING    'python3-devel needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.0.2           MISSING    'libcrypto needs to be installed'
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.23'         OK         -
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.0           OK         -
 python3-pyqt4-dbus   PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             4.11.4          OK         -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'

---------------
|  COMPILEDEP |
---------------

 error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'
 error: gcc           gcc - GNU Project C and C++ Compiler                         REQUIRED        -               5.4.0           MISSING    'gcc needs to be installed'
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.1             OK         -

----------------------
|  Python Extentions |
----------------------

 hpmudext             IO-Extension                                                 REQUIRED        -               3.16.3          OK         -
 cupsext              CUPS-Extension                                               REQUIRED        -               3.16.3          OK         -

-----------------------
|  Scan Configuration |
-----------------------

 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.16.3          OK         -
'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.16.3          OK         'hpaio found in /etc/sane.d/dll.conf'

-----------------------
|  Other Dependencies |
-----------------------


------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
HP-HP-OfficeJet-Pro-8710
------------------------
Type: Unknown
Device URI: usb://HP/OfficeJet%20Pro%208710?serial=CN77QB30V9&interface=1
PPD: /etc/cups/ppd/HP-HP-OfficeJet-Pro-8710.ppd
warning: Failed to read /etc/cups/ppd/HP-HP-OfficeJet-Pro-8710.ppd ppd file
PPD Description: 
Printer status: printer HP-HP-OfficeJet-Pro-8710 disabled since Mon 18 Dec 2017 10:41:20 PM EST Unplugged or turned off
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

error: Unsupported model: HP_OfficeJet_Pro_8710
 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libdbus-1-dev' package is missing/incompatible 
error: 'libcups2' package is missing/incompatible 
error: 'libsane-dev' package is missing/incompatible 
error: 'libcups2-dev' package is missing/incompatible 
error: 'cups-bsd' package is missing/incompatible 
error: 'cups-client' package is missing/incompatible 
error: 'libcupsimage2-dev' package is missing/incompatible 
error: 'libusb-1.0.0-dev' package is missing/incompatible 
error: 'libjpeg8-dev' package is missing/incompatible 
error: 'python3-dev' package is missing/incompatible 
error: 'libsnmp-dev' package is missing/incompatible 
error: 'snmp-mibs-downloader' package is missing/incompatible 
error: 'openssl' package is missing/incompatible 
error: 'libtool' package is missing/incompatible 
error: 'build-essential' package is missing/incompatible 

Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible 
error: 'python3-notify2' package is missing/incompatible 

Total Errors: 14
Total Warnings: 1


Done.
Note: The HP printer was plugged in via USB when I did hp-setup and hp-check.

Ok, so what should I do? It almost seems like a contradictory message. It says the HP OfficeJet 8710 (of which the 8715 is a subset) is not supported, but it also lists missing dependencies in a way that makes it seem as if I should install them to get this thing to work.

That leads me to the follow question. Should I go to Synaptic Package Manager, find all of the missing packages listed above and install them?
sudo apt-get --purge remove macOS

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: HP OfficeJet 8715 plugged in via USB but not detected. Simple Scanner says No Scanners Detected. Can't scan or print

Post by pdc_2 » Tue Dec 19, 2017 3:59 am

thanks James; so it seems to me you still just have the 3.16.3 version of hplip installed;

so this page from HP suggests how to install hplip https://developers.hp.com/hp-linux-imag ... tall/index and it's here for completeness;

but if you are happy to copy the commands below; and paste them into a terminal; we should be able to get the new version installed; (to paste into the terminal; if you right-click at the flashing text prompt in the terminal, and look for PASTE in the menu that appears ........)

........... firstly, if we just confirm that 3.16.3 is what is installed; if you paste

Code: Select all

dplg -l hplip
that is asking the computer to LIST what is recorded in Debian package manager about hplip ...... for mine it says
|/ Name Version Architecture Description
+++-=======================-================-================-===================================================
ii hplip 3.16.3+repack0-1 amd64 HP Linux Printing and Imaging System (HPLIP)
_________________
if you get the same, then let's proceed to install the newer version and first command is

Code: Select all

cd Desktop
and if you then type

Code: Select all

ls
... that is asking the computer to LIST what is on the Desktop; there should be hplip-3.17.11.run and if so the command is

Code: Select all

sh hplip-3.17.11.run
and that should start up the install;

___________

we are installing this 3.17.11 version as HP say you need at least 3.16.5 to power your printer; and 3.16.3 is what is on Mint 18.3 as it comes from Ubuntu 16.04

James_Smith
Level 4
Level 4
Posts: 366
Joined: Wed Feb 18, 2015 6:41 pm

Re: HP OfficeJet 8715 plugged in via USB but not detected. Simple Scanner says No Scanners Detected. Can't scan or print

Post by James_Smith » Tue Dec 19, 2017 7:11 pm

pdc_2 wrote:thanks James; so it seems to me you still just have the 3.16.3 version of hplip installed;

so this page from HP suggests how to install hplip https://developers.hp.com/hp-linux-imag ... tall/index and it's here for completeness;

but if you are happy to copy the commands below; and paste them into a terminal; we should be able to get the new version installed; (to paste into the terminal; if you right-click at the flashing text prompt in the terminal, and look for PASTE in the menu that appears ........)

........... firstly, if we just confirm that 3.16.3 is what is installed; if you paste

Code: Select all

dplg -l hplip
that is asking the computer to LIST what is recorded in Debian package manager about hplip ...... for mine it says
|/ Name Version Architecture Description
+++-=======================-================-================-===================================================
ii hplip 3.16.3+repack0-1 amd64 HP Linux Printing and Imaging System (HPLIP)
_________________
if you get the same, then let's proceed to install the newer version and first command is

Code: Select all

cd Desktop
and if you then type

Code: Select all

ls
... that is asking the computer to LIST what is on the Desktop; there should be hplip-3.17.11.run and if so the command is

Code: Select all

sh hplip-3.17.11.run
and that should start up the install;

___________

we are installing this 3.17.11 version as HP say you need at least 3.16.5 to power your printer; and 3.16.3 is what is on Mint 18.3 as it comes from Ubuntu 16.04
Dude.

DUDE!


Not only did you tell me how to fix it you gave me a deeper understanding of Linux and the command line (which I was just really starting to get into).

Thank you! Send me your address. I'd like to have some flowers and candy delivered to your house.

It still takes between six and eight minutes to print something, but that's an issue with the printer. it does the same thing on Windows 10 and Windows 8.
sudo apt-get --purge remove macOS

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: HP OfficeJet 8715 plugged in via USB but not detected. Simple Scanner says No Scanners Detected. Can't scan or print

Post by pdc_2 » Wed Dec 20, 2017 12:34 pm

thanks James; glad to hear it is now printing; 8 minutes seems a tad long; and you say the same happens on windows;

Post Reply

Return to “Printers & Scanners”