Page 1 of 1

[SOLVED] Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 2:03 am
by Riong88
Hi,

Rookie to the Mint 18.3. I'm trying to install my Brother MFC-J625DW. However, it failed to print anything after drivers installed, and I understand that lib32 is no longer available. I'm using the latest linux-brprinter-installer-2.2.0-1. Please help!

Re: Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 2:16 am
by tenfoot
Have a look at pjotr's

https://sites.google.com/site/easylinuxtipsproject/17

Follow the instructions for installing Brother printers. I did and it was completely successful.

And then go to the Home page and find a host of other good tips. It is well worth the visit.

Re: Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 2:17 am
by catweazel
Did you ty this?

Re: Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 3:27 am
by Riong88
Hi,

Thanks for your kind reply! Procedures are partially working. Scanning is working now, but not for printing. I'm using USB direct connection. Printer display screen turns on when a job is send, however, nothing comes out from the printer and the printer queue is empty.

Re: Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 4:00 am
by catweazel

Re: Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 4:48 am
by Riong88
Already did, but still cannot print. Here is the installation messages for your reference.

The following packages have unmet dependencies:
base-files : PreDepends: awk
dictionaries-common : Depends: debconf (>= 1.5.5) but it is not going to be installed or
debconf-2.0
Depends: libtext-iconv-perl but it is not going to be installed
ia32-libs : Depends: gstreamer0.10-plugins-base:i386
Depends: gstreamer0.10-plugins-good:i386
Depends: gtk2-engines:i386
Depends: gtk2-engines-murrine:i386
Depends: gtk2-engines-oxygen:i386
Depends: gtk2-engines-pixbuf:i386
Depends: gvfs:i386
Depends: ibus-gtk:i386
Depends: libacl1:i386
Depends: libaio1:i386
Depends: libao4:i386
Depends: libasound2:i386
Depends: libasound2-plugins:i386
Depends: libasyncns0:i386
Depends: libattr1:i386
Depends: libaudio2:i386
Depends: libcanberra-gtk-module:i386
Depends: libcap2:i386
Depends: libcapi20-3:i386
Depends: libcups2:i386
Depends: libcupsimage2:i386
Depends: libdbus-glib-1-2:i386
Depends: libesd0:i386
Depends: libfontconfig1:i386
Depends: libfreetype6:i386
Depends: libgail-common:i386
Depends: libgconf-2-4:i386
Depends: libgdbm3:i386
Depends: libgettextpo0:i386
Depends: libglapi-mesa:i386
Depends: libglu1-mesa:i386
Depends: libgphoto2-6:i386
Depends: libgphoto2-port10:i386 but it is not installable or
libgphoto2-port12:i386
Depends: libgtk2.0-0:i386
Depends: libmpg123-0:i386
Depends: libncursesw5:i386
Depends: libnspr4:i386
Depends: libnss3:i386
Depends: libodbc1:i386
Depends: libopenal1:i386
Depends: libpulse-mainloop-glib0:i386
Depends: libpulsedsp:i386
Depends: libqt4-dbus:i386
Depends: libqt4-network:i386
Depends: libqt4-opengl:i386
Depends: libqt4-qt3support:i386
Depends: libqt4-script:i386
Depends: libqt4-scripttools:i386
Depends: libqt4-sql:i386
Depends: libqt4-svg:i386
Depends: libqt4-test:i386
Depends: libqt4-xml:i386
Depends: libqt4-xmlpatterns:i386
Depends: libqtcore4:i386
Depends: libqtgui4:i386
Depends: libqtwebkit4:i386
Depends: librsvg2-common:i386
Depends: libsane:i386
Depends: libsdl-image1.2:i386
Depends: libsdl-mixer1.2:i386
Depends: libsdl-net1.2:i386
Depends: libsdl-ttf2.0-0:i386
Depends: libsdl1.2debian:i386
Depends: libsqlite3-0:i386
Depends: libssl1.0.0:i386
Depends: libstdc++5:i386
Depends: libstdc++6:i386
Depends: libxaw7:i386
Depends: libxml2:i386
Depends: libxslt1.1:i386
Depends: libxss1:i386
Depends: libxtst6:i386
Depends: odbcinst1debian2:i386
Depends: xaw3dg:i386
Depends: libgl1-mesa-dri:i386
Depends: libgl1-mesa-glx:i386
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
lib32stdc++6 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) but 5.4.0-6ubuntu1~16.04.5 is to be installed
Depends: lib32gcc1 (>= 1:4.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
dpkg -x mfcj625dwlpr-3.0.1-1.i386.deb /
dpkg -x mfcj625dwcupswrapper-3.0.0-1.i386.deb /
(Reading database ... 277219 files and directories currently installed.)
Removing mfcj625dwcupswrapper:i386 (3.0.0-1) ...
lpadmin: The printer or class does not exist.
[ ok ] Restarting cups (via systemctl): cups.service.
Purging configuration files for mfcj625dwcupswrapper:i386 (3.0.0-1) ...
dpkg-deb: building package 'mfcj625dwlpr' in 'mfcj625dwlpr-3.0.1-1a.i386.deb'.
dpkg -b ./brother_driver_packdir mfcj625dwlpr-3.0.1-1a.i386.deb
dpkg-deb: building package 'mfcj625dwcupswrapper' in 'mfcj625dwcupswrapper-3.0.0-1a.i386.deb'.
dpkg -b ./brother_driver_packdir mfcj625dwcupswrapper-3.0.0-1a.i386.deb
dpkg -i --force-all mfcj625dwlpr-3.0.1-1a.i386.deb
(Reading database ... 277216 files and directories currently installed.)
Preparing to unpack mfcj625dwlpr-3.0.1-1a.i386.deb ...
Unpacking mfcj625dwlpr:i386 (3.0.1-1) over (3.0.1-1) ...
Setting up mfcj625dwlpr:i386 (3.0.1-1) ...
dpkg -i --force-all mfcj625dwcupswrapper-3.0.0-1a.i386.deb
Selecting previously unselected package mfcj625dwcupswrapper:i386.
(Reading database ... 277216 files and directories currently installed.)
Preparing to unpack mfcj625dwcupswrapper-3.0.0-1a.i386.deb ...
Unpacking mfcj625dwcupswrapper:i386 (3.0.0-1) ...
Setting up mfcj625dwcupswrapper:i386 (3.0.0-1) ...
Restarting cups (via systemctl): cups.service.
lpadmin -p MFCJ625DW -E -v usb://Brother/MFC-J625DW?serial=BROH3F187649 -P /usr/share/cups/model/Brother/brother_mfcj625dw_printer_en.ppd
#
Will you specify the Device URI? [Y/n] ->n

Re: Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 4:53 am
by Riong88
BTW, manually created the spool, drwx------ 2 lp lp 4096 Feb 3 16:17 mfcj625dw
Don't know whether it's correct or not!

Re: Trying to install my Brother MFC-J625DW

Posted: Sat Feb 03, 2018 6:21 am
by Riong88
Yes, I agree with you that the spool is either not working or configured properly.

Re: Trying to install my Brother MFC-J625DW

Posted: Sun Feb 04, 2018 5:12 am
by Riong88
Finally, I fix it by re-install the Mint. Thanks for your help!