Drivers missing Canon Pixma MP600

Forum rules
Before you post please read this
Post Reply
oldporridge
Level 1
Level 1
Posts: 6
Joined: Mon Feb 05, 2018 3:46 pm

Drivers missing Canon Pixma MP600

Post by oldporridge » Mon Feb 05, 2018 4:02 pm

My Canon PIXMA MP600 printer will print from my old laptop, but cannot scan documents – where can I find the missing 'scanning' drivers please?

The Canon website does not offer them.

My searches show that this is a common problem with other Canon printer models too, but following the links provided just leads me into dead ends or technical bewilderment.

Please note that I am aged Linux Mint novice, so please keep any replies technically simple if possible.

Linux Mint 17.2 'Rafaela' Cinnamon 32 bit

Thanks
Oldporridge

User avatar
catweazel
Level 17
Level 17
Posts: 7748
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Drivers missing Canon Pixma MP600

Post by catweazel » Tue Feb 06, 2018 12:58 am

¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

oldporridge
Level 1
Level 1
Posts: 6
Joined: Mon Feb 05, 2018 3:46 pm

Re: Drivers missing Canon Pixma MP600

Post by oldporridge » Thu Feb 15, 2018 3:09 pm

Thanks Catweazel, but I can't get it to work for me.

The scanning function on the printer works fine, and I've checked the connections - so it's looking like a driver issue.

I downloaded sane-pixma.5.gz and opened it – still wouldn't scan.

I've probably missed something very simple – can anyone point it out to me please?

This is likely to prove embarrassing so I'm getting in first and I'll blame it on being oldist……

Cheers

User avatar
Ozo
Level 5
Level 5
Posts: 765
Joined: Tue Dec 22, 2015 11:49 am
Location: Titusville, Florida USA

Re: Drivers missing Canon Pixma MP600

Post by Ozo » Thu Feb 15, 2018 4:08 pm

I use Simple-Scan to access scanner controls but that may not work for you. Try it though as it might be all you need. Link below.

Of course if this is a problem of missing dependencies it can be a real pain.. I don't know what that means either but just say the system could be damaged. Folks here will attempt to aid you in restoring the system with inputs to the terminal and advise re-loading the operating system as a last resort only but I find that helpful only occasionally so I do it the hard way and redo the whole thing.

https://opensource.com/life/14/8/3-tool ... ux-desktop

oldporridge
Level 1
Level 1
Posts: 6
Joined: Mon Feb 05, 2018 3:46 pm

Re: Drivers missing Canon Pixma MP600

Post by oldporridge » Thu Mar 01, 2018 10:58 am

Thanks for the link Ozo, but Simple-Scan doesn't work for me either.

So it's back to square one...........

User avatar
administrollaattori
Level 14
Level 14
Posts: 5471
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Drivers missing Canon Pixma MP600

Post by administrollaattori » Thu Mar 01, 2018 11:03 am

What tells a terminal-command

Code: Select all

scanimage -L

User avatar
Pjotr
Level 20
Level 20
Posts: 10968
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Drivers missing Canon Pixma MP600

Post by Pjotr » Thu Mar 01, 2018 11:04 am

Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

oldporridge
Level 1
Level 1
Posts: 6
Joined: Mon Feb 05, 2018 3:46 pm

Re: Drivers missing Canon Pixma MP600

Post by oldporridge » Fri Apr 20, 2018 4:57 pm

Thanks Pjotr but that link doesn't solve the issue - Step 8 requires me to go to the Canon website and download the drivers for the scanning part - but these don't exist on the Canon site for Linux!

Incidently this laptop is 32-bit.

My printer prints but doesn't scan using Linux - the OS found the print drivers during the initial installation, but not the scanning drivers - so it's back to square one.

oldporridge
Level 1
Level 1
Posts: 6
Joined: Mon Feb 05, 2018 3:46 pm

Re: Drivers missing Canon Pixma MP600

Post by oldporridge » Fri Apr 20, 2018 5:15 pm

Cheers Administrollaattori but i don't understand your posting - probably because I'm out of my depth.

I went to scanimage.vidriotechnologies.com but don't see how that helps

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Scanning on Canon Pixma MP600

Post by pdc_2 » Fri Apr 20, 2018 5:19 pm

so this is all about scanning from the MP600

one should not need a scanning driver; as the SANE project (Scanning Access Now Easy) works to ensure connection;

so when one searches on the MP600, the SANE team say support for this device is COMPLETE http://www.sane-project.org/sane-mfgs.html#Z-CANON

_______

so we would need you to copy some commands from below; and paste them into a terminal; the terminal is the tv screen on the bottom line; and to PASTE, if you right-click at the text prompt; (the flashing rectangle in the terminal): then when you right-click you should see Paste as an option there ........... does that check out ok?

Code: Select all

lsusb

Code: Select all

sane-find-scanner

Code: Select all

scanimage -L

Code: Select all

sudo sane-find-scanner

Code: Select all

sudo scanimage -L
you will see the last two commands have the sudo preface so you will need to enter your sudo pasword there

(You might like to edit the title of your very first post to say Scanning for the MP600 ........ as this is not about drivers; )

oldporridge
Level 1
Level 1
Posts: 6
Joined: Mon Feb 05, 2018 3:46 pm

Unable to scan - Canon Pixma MP600

Post by oldporridge » Fri Nov 09, 2018 5:18 pm

Thanks and apologies for the delay in responding, for I have been away in a remote place with no internet access. I'm now back.

I did come across the SANE project in my earlier searches but couldn't work out what it was, or how to use it, though I did suspect it might involve the Terminal, but I have not done any programming since the late 1960's (Algol 60), so looked elsewhere for something hopefully simpler.

I have successfully copied all the commands into the Terminal, but cannot enter my SUDO password to complete the process.

I do know what my SUDO password is, but cannot enter it (or anything else!) where indicated, either before I've copied the commands or after I've pasted them. Please clarify.

Incidentally I've also tried to edit the title to my first message but that seems to be unsuccessful as well - I'm clearly losing the plot - so it goes......

Cheers

Post Reply

Return to “Printers & Scanners”