Canon Wifi Printer not visible/can't install or configure

Forum rules
Before you post please read this
Post Reply
Level 1
Level 1
Posts: 1
Joined: Thu Feb 22, 2018 9:51 pm

Canon Wifi Printer not visible/can't install or configure

Post by JimBob7 » Thu Feb 22, 2018 11:04 pm


Thanks to every one for running these forums.

I run Mint 18.3 KDE on my T410 Lenovo and Dell Optiplex machines and have a consistent problem with my Canon MB5160 printer when installing over the WIFI. Mint is my preferred distro and KDE preferred desktop so i am trying to not have to change distro or desktop for the sake of one printer.

If I run the install from the Canon driver and script the read out states "printer not visible on network". I can install the same printer using the the USB port. File "cnijfilter2-5.40-1-deb.tar.gz" is downloadable from Canon and this is the one i have tried. Have tried to install via CUPS, seems to install a similar driver but same difference - it doesn't work.

The printer is powered on, firewall is off, I think the printer IP is dynamic at the moment.

Have tried Kubuntu to compare and the printer works over WiFi without any configuration, i think that's called driverless setup? Kubuntu works

Have tried Mint with another desktop and been able to use printer after install and sometimes driverless. Mint works when i use other desktops.

I am kind of stumped guys. Any advice? It don't get what is with that specific distro/desktop combination which seems to not work with this printer.

User avatar
Level 13
Level 13
Posts: 4990
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Canon Wifi Printer not visible/can't install or configure

Post by kc1di » Fri Feb 23, 2018 8:54 am

Hi if you can set the printer IP address to a fixed address outside the normal DHCP range say in the .200's or so This will ensure it does not change from turning on or off and from plugging in other devices.
do the install from cannon with printer plugged in to usb then unplug it and to to a web browser and enter this address in the address line:

Code: Select all

cups will come up click on add printer - See if it finds any network printers. If it finds you follow the prompts to add the printer. Good luck.
Easy tips :
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

User avatar
Level 2
Level 2
Posts: 55
Joined: Thu Oct 26, 2017 1:23 pm

Re: Canon Wifi Printer not visible/can't install or configure

Post by mrjimphelps » Fri Feb 23, 2018 11:23 am

Do you have a Windows computer available? Or can you borrow a Windows laptop?

I have found that it is often difficult to get a Canon printer to install straight up as a network printer on my home network; I always have to use the "plug in the USB cable to set it up as a network printer" option. Once I go through that process, I can unplug the USB cable, and from that point forward, the Canon wifi printer is available as a network printer on my home network.

The problem is, there is no "plug in the USB cable to set it up as a network printer" option available in Linux. That option is only available in the Windows version of the Canon install software.

Once you get your Canon printer on the network using the USB cable method, you will be able to easily add the printer on your Linux machine. Therefore, install it first on a Windows machine, to make it available on the network. Then all you'll need to do is "add a printer" on your Linux machine, because it will now show up as an available printer.

If you don't have a Windows computer available, then you might be able to do the above procedure from a Windows virtual machine, if you have one set up in your Linux computer.

Post Reply

Return to “Printers & Scanners”