(SOLVED)Installation UFRII driver Canon LBP6030w Linux17.3 Fails

Forum rules
Before you post please read this
Post Reply
jannes2
Level 1
Level 1
Posts: 5
Joined: Fri May 04, 2018 3:05 pm

(SOLVED)Installation UFRII driver Canon LBP6030w Linux17.3 Fails

Post by jannes2 » Fri May 04, 2018 3:43 pm

Have a dual boot windows 10 and linux. Printer works well on Windows but I cannot install the driver for Linux

Downloaded UFRII LT printer Driver Ver.1.40 from Canon

then run installation script: Output abreviated

Machine Type = i386
Package Type = rpm
./32-bit_Driver/RPM/cndrvcups-ufr2lt-uk-1.40-1.i386.rpm
Package list =
./32-bit_Driver/RPM/cndrvcups-common-3.80-1.i386.rpm
./32-bit_Driver/RPM/cndrvcups-ufr2lt-uk-1.40-1.i386.rpm
./32-bit_Driver/RPM/cndrvcups-utility-1.00-1.i386.rpm
libglade2
./install.sh: regel 298: dnf: opdracht niet gevonden (not found)
./install.sh: regel 311: dnf: opdracht niet gevonden
NG: libglade2

Then I decided after much puzzling to enable " yum"

then I got other output from installation

# yum upgrade
libglade2
There are no enabled repos.
Run "yum repolist all" to see the repos you have.
You can enable repos with yum-config-manager --enable <repo>

This is the first time I ask for help so sorry if essentials are missing, willing to learn.
Last edited by jannes2 on Sat May 05, 2018 10:41 am, edited 2 times in total.

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Installation UFRII driver Canon LBP6030w Linux17.3 Fails

Post by kc1di » Fri May 04, 2018 4:43 pm

Hello jannes2 and Welcome to Linux Mint Forums,

I'm afraid that you are in the wrong distrobution or forum or both.
RPM packages are Fedora /Redhat Package system and will not work directly in Mint which uses .deb packages.
Also Mint Does not use Yum as a package manager That is also a Fedora/redhat system. (yum in not used in newer Fedora releases either they use dnf now.)

This Ask ubuntu page will help you install the correct driver for you printer. https://askubuntu.com/questions/995115/ ... on-lbp6030 If you indeed have Mint installed on your system.
Good Luck.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

jannes2
Level 1
Level 1
Posts: 5
Joined: Fri May 04, 2018 3:05 pm

Re: Installation UFRII driver Canon LBP6030w Linux17.3 Fails

Post by jannes2 » Fri May 04, 2018 6:59 pm

Hello kc1di,
I hope I am in the good forum, I am a Linux Mint user for 4 years now.
I used the same distribution as the "askubuntu" .
I immediatly have removed yum.
The script chooses " Package Type = rpm" and that must be the problem.
The distribution contains also the deb files.
I will have a close look at the shell script tomorrow (I have some experience with Unix).
Anyhow your answer helps me a lot for the moment.

jannes2
Level 1
Level 1
Posts: 5
Joined: Fri May 04, 2018 3:05 pm

Re: Installation UFRII driver Canon LBP6030w Linux17.3 Fails

Post by jannes2 » Sat May 05, 2018 3:58 am

*SOLVED*

I had 'rpm' installed on my system (incorrectly?) leading the installer script to believe it should deal with RPM packages, either with yum or dnf.

Changing the "if which rpm" statement in the installer script to "if which rpmx" (or removing rpm from the system) solved it.

Thanks for helping me

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Installation UFRII driver Canon LBP6030w Linux17.3 Fails

Post by kc1di » Sat May 05, 2018 5:43 am

Glad you got it going :)
please edit the subject line of your original post and add [Solved] Thanks.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Post Reply

Return to “Printers & Scanners”