HP Printer m475dn failing into install - CUPS filter failed - HPLIP 3.18.6 install failes with ownership issues

Forum rules
Before you post please read this
Post Reply
phat_fil
Level 1
Level 1
Posts: 2
Joined: Fri Sep 11, 2015 6:25 am

HP Printer m475dn failing into install - CUPS filter failed - HPLIP 3.18.6 install failes with ownership issues

Post by phat_fil » Sun Jun 24, 2018 11:43 am

I have used this printer for years without issue but recently it has decided to stop working, it might coincide with an upgrade to kernal 4.13.0-43, I tried removing the printer and reinstalling but when I came to find the printer driver that I have always used, it was no longer within the HPLIP list. I removed HPLIP and attempted to reinstall the latest version from the website 3.18.6 but when I sh the file I get this message

Code: Select all

hplip-3.18.6.run: 371: cd: can't cd to hplip-3.18.6
chown: changing ownership of './.PyCharmCE2017.3/system/cythonExtensions/build/_pydevd_bundle/pydevd_cython.o': Operation not permitted
chown: changing ownership of './.PyCharmCE2017.3/system/cythonExtensions/build/_pydevd_bundle': Operation not permitted
chown: changing ownership of './.PyCharmCE2017.3/system/cythonExtensions/build': Operation not permitted
chown: changing ownership of './.PyCharmCE2017.3/system/cythonExtensions/_pydevd_bundle_ext/pydevd_cython.so': Operation not permitted
chown: changing ownership of './.PyCharmCE2017.3/system/cythonExtensions/_pydevd_bundle_ext/__init__.py': Operation not permitted
chown: changing ownership of './.PyCharmCE2017.3/system/cythonExtensions/_pydevd_bundle_ext': Operation not permitted
chown: changing ownership of './.PyCharmCE2017.3/system/cythonExtensions': Operation not permitted
chown: cannot access './.gvfs': Permission denied
chown: changing ownership of './.local/share/gvfs-metadata/root': Operation not permitted
chown: changing ownership of './.local/share/gvfs-metadata/root-690474a2.log': Operation not permitted

I have fairly recently started playing around with python2.7 and pyqt4 using Pycharm and I am wondering if I have inadvertently managed to mess up the permissions to python.
If I try to install HPLIP-GUI from the software Manager it will install but will not start. If I run "python /usr/bin/hp-toolbox" I get:



Code: Select all

HP Linux Imaging and Printing System (ver. 3.17.11)
HP Device Manager ver. 15.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

\Traceback (most recent call last):
  File "/usr/bin/hp-systray", line 35, in <module>
    from base import utils, module
  File "/usr/share/hplip/base/module.py", line 30, in <module>
    from . import tui, utils, device
  File "/usr/share/hplip/base/device.py", line 41, in <module>
    from . import status
  File "/usr/share/hplip/base/status.py", line 49, in <module>
    import hpmudext
ImportError: /usr/lib/python3/dist-packages/hpmudext.cpython-35m-x86_64-linux-gnu.so: undefined symbol: hpmud_make_par_uri
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 145, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
PermissionError: [Errno 13] Permission denied: '/var/crash/_usr_share_hplip_systray.py.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/hp-systray", line 35, in <module>
    from base import utils, module
  File "/usr/share/hplip/base/module.py", line 30, in <module>
    from . import tui, utils, device
  File "/usr/share/hplip/base/device.py", line 41, in <module>
    from . import status
  File "/usr/share/hplip/base/status.py", line 49, in <module>
    import hpmudext
ImportError: /usr/lib/python3/dist-packages/hpmudext.cpython-35m-x86_64-linux-gnu.so: undefined symbol: hpmud_make_par_uri
warning: Unable to connect to dbus. Is hp-systray running?
error: dBus initialization error. Exiting.
Segmentation fault (core dumped)
Can anyone help me decipher the above errors please?
My tech specs bellow:



Code: Select all

       Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 5758 v: 01
           Mobo: Dell model: 0PV7TH v: A00 Bios: Dell v: A04 date: 08/06/2015
CPU:       Dual core Intel Core i5-5250U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6385
           clock speeds: max: 2700 MHz 1: 925 MHz 2: 1300 MHz 3: 951 MHz
           4: 1330 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.01hz
           GLX Renderer: Mesa DRI Intel HD Graphics 6000 (Broadwell GT3)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network:   Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 07:00.0
           IF: enp7s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (16.1% used)
           ID-1: /dev/sda model: ST1000LM024_HN size: 1000.2GB
Partition: ID-1: / size: 909G used: 143G (17%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 472M used: 319M (72%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 8.50GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 60.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A fan-2: 0 fan-3: 0
Info:      Processes: 243 Uptime: 1:37 Memory: 2317.6/7888.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

pdc_2
Level 8
Level 8
Posts: 2382
Joined: Mon May 11, 2009 1:21 am

HP Printer m475dn

Post by pdc_2 » Sun Jun 24, 2018 9:18 pm

so to get hplip to support an HP device; it seems to need to be listed in the "Supported Devices" link that HP maintains;

and I can't find your device listed there; its full name seems to be the HP LaserJet Pro 400 color MFP M475dn https://support.hp.com/us-en/product/HP ... el/4337754

and it's a fine looking machine; all I can find is a unix driver when you click on the above link: it comes down as a .zip file ......... I can only wonder if one installed it, if it might help?

on Open Printing, http://www.openprinting.org/printers/manufacturer/HP they list many devices; so one can see what is supported; I can't see your device there either; but you say it worked before ..

>>>>>>

you could try deleting your existing hplip

Code: Select all

sudo apt purge hplip
then install the latest hplip from their website

Post Reply

Return to “Printers & Scanners”