Page 1 of 1

A driver for Samsung Xpress C460FW??

Posted: Sun Jul 01, 2018 1:54 pm
by IamJohn
I used to be able to use SimpleScan without any problems. But a few updates to Mint later that changed. Printing still works fine but scanning is wonky.

If the printer is powered up when I start SimpleScan, SimpleScan immediately shuts down but reappears and stays when I restart it. Odd I thought. But SimpleScan would not scan multiple pages from the auto-document feed -- it only scanned the first page although it claimed to be scanning the other pages which just disappeared after they were 'scanned'. I had to add other pages individually after which SimpleScan was happy to export all the pages to a PDF or whatever.

Then yesterday I started SimpleScan before powering up the printer and I got a message saying I needed to install drivers from Samsung; I had not seen this message before because I usually started the printer prior to SimpleScan.

I had gone to Samsung a long time ago when this problem cropped up only to learn that they had been taken over by HP and tried to install their Unified Driver. There was and is a Unified Linux Driver that was supposed to work on ALL versions of Linux
https://support.hp.com/ca-en/drivers/se ... l/17157235

But the problem I had was that the driver was in the name.tar.gz format and would not install in Mint notwithstanding HP's declaration to the contrary.

Can anyone tell me how to get this proprietary driver to install since it appears that Linux kernel support for my printer/scanner disappeared some time ago?

Re: A driver for Samsung Xpress C460FW??

Posted: Mon Jul 02, 2018 6:16 am
by pdc_2
so if you click to download and save, you should get uld_V1.00.39_01.17.tar.gz in your Downloads folder

into a terminal

Code: Select all

cd Downloads

Code: Select all

tar -zxvf uld_V1.00.39_01.17.tar.gz

Code: Select all

cd uld

Code: Select all

sudo ./install.sh
and watch the terminal as it runs

Re: A driver for Samsung Xpress C460FW??

Posted: Mon Jul 02, 2018 8:53 pm
by IamJohn
Thanks for the help pdc_2. Your instructions worked perfectly and the installation said it completed.

Unfortunately I still have the same scanning problem: SimpleScan scans the first page and then pulls the other pages through one after the other but only the first one actually scans. And I have to start SimpleScan twice since the first time it just shuts down immediately.

I went into the driver manager to see if I needed to manually chose to use the Samsung driver but the manager said there were no proprietary drivers in use. Moreover, there was no place where I could select the Samsung driver as a default driver.

Have I missed something or was there something else I was supposed to do? Or did the installation not work despite my watching it do so in terminal?

Any suggestions as to how to get the scanner ADF to work properly?

Re: A driver for Samsung Xpress C460FW??

Posted: Tue Jul 03, 2018 4:30 pm
by IamJohn
It occurred to me that as a Linux newbee, I might be asking the wrong question.

I cannot figure out why Mint says there are no proprietary drivers in use even after I installed the Samsung driver.....and rebooted Mint just to see if that made any difference. It did not.

Is there a way in Mint to tell it to use a specific driver for a device?