[SOLVED] Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Forum rules
Before you post please read this
Post Reply
User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

[SOLVED] Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by McFlow61 » Tue Jul 03, 2018 11:46 am

Hi everyone, I need some help.

Just installed Linux Mint 19 'Tara' and downloaded drivers for the scanner Epson Stylus DX4400 from manufacturer's page: iscan-cx4400-bundle-1.0.0.x86.deb.tar.gz but it doesn't work.

On Linux Mint 17.3 'Rosa' did work perfectly. I did the same operations than on Linux Mint 19

I have checked lsusb to view if is detected and it does. Bus 002 Device 002: ID 04b8:083f Seiko Epson Corp. Stylus CX4300/CX4400/CX5500/CX5600/DX4400/DX4450

Simple Scan says I have an Epson Scanner and is needed to install additional software, but I did it before. I reinstall the software and the same message is shown.

Iscan for Linux, the software from Epson, shows this notice: "Can't send command to scanner. Check status scanner"

Xsane don't find devices on the computer.

I tried on other usb ports and it doesn't work.

Printer is detected directly from Linux and there is no problem, but I cannot scan.

Anybody can help me?

Thanks to everyone.

Greetings.
Last edited by McFlow61 on Sun Jul 08, 2018 6:29 am, edited 1 time in total.
Fear is soul's executioner

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Epson Stylus DX4400

Post by pdc_2 » Tue Jul 03, 2018 6:47 pm

in this bug report to Ubuntu last year; where Epson scanners stopped working;

https://bugs.launchpad.net/ubuntu/+sour ... ug/1728012

What was suggested; post #25 has the details
1. install libsane1 1.0.27-1~experimental2ubuntu2.1
2.

Code: Select all

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane
If the connection is usb, they suggest a udev rule ....... maybe you paste the above command; (see what libsane version you have in Mint 19 ..) .. reboot ... any joy?
<<<<<<<<<<<<<<<<
EDIT: added 7th July: for 32bit users, please see post #10 where McFlow has success with the above link; by adding a 32bit alteration: good news is, it works!
Last edited by pdc_2 on Sat Jul 07, 2018 3:22 pm, edited 1 time in total.

User avatar
kyphi
Level 8
Level 8
Posts: 2340
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by kyphi » Tue Jul 03, 2018 6:58 pm

Hello McFlow61 and Welcome.

If you are using a 32 bit system the scanner bundle you mentioned is correct. You need a different bundle for 64 bit.

What did you do to unpack the tar.gz file? Did you follow the Instructions in the bundle?

Epson's Imagescan for Linux may not work via wi-fi because Epson has as yet not updated their drivers for Linux Mint 19 but Simple Scan does work.
Linux Mint 19 Cinnamon - 64bit

User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

Re: Epson Stylus DX4400

Post by McFlow61 » Wed Jul 04, 2018 6:12 am

pdc_2 wrote:
Tue Jul 03, 2018 6:47 pm
in this bug report to Ubuntu last year; where Epson scanners stopped working;

https://bugs.launchpad.net/ubuntu/+sour ... ug/1728012

What was suggested; post #25 has the details
1. install libsane1 1.0.27-1~experimental2ubuntu2.1
2.

Code: Select all

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane
If the connection is usb, they suggest a udev rule ....... maybe you paste the above command; (see what libsane version you have in Mint 19 ..) .. reboot ... any joy?
Hi, thank you for your comment.

I'm using a 32 bit system, Linux Mint 19 'Tara' Xfce version
The scanner is connected by usb port.

I pasted the command in a terminal, this is the result: target '/usr/lib/x86_64-linux-gnu/sane' is not a directory.

How can I view the libsane version? In the directory /usr/lib/sane/ there are the following files: 'libsane-epkowa.la' 'libsane-epkowa.so.1' and 'libsane-epkowa.so.1.0.15'
Do I need to install libesane1 1.0.27-1? How I get the installation package?

No joy at the moment but surely it comes, thank you and greetings.
Fear is soul's executioner

User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by McFlow61 » Wed Jul 04, 2018 6:43 am

kyphi wrote:
Tue Jul 03, 2018 6:58 pm
Hello McFlow61 and Welcome.

If you are using a 32 bit system the scanner bundle you mentioned is correct. You need a different bundle for 64 bit.

What did you do to unpack the tar.gz file? Did you follow the Instructions in the bundle?

Epson's Imagescan for Linux may not work via wi-fi because Epson has as yet not updated their drivers for Linux Mint 19 but Simple Scan does work.
Hi kyphi, thank you for your comment.

I'm using a 32 bit system and the scanner is connected on an usb port, not wi-fi connection.

I follow the instructions in the bundle, extract the tar.gz with the extracting app and in the terminal window at the right directory where files were extracted I typed './install.sh' the script provided into the bundle. No mistakes notices.

Also I did this in a terminal window at download directory, where is the tar.gz file:

tar xaf iscan-cx4400-bundle-1.0.0.x86.deb.tar.gz
cd iscan-cx4400-bundle-1.0.0.x86.deb
./install.sh

Here the result of command: (sorry it is in spanish)

Obj:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Ign:2 http://ftp.cixug.es/mint/packages tara InRelease
Obj:3 http://archive.canonical.com/ubuntu bionic InRelease
Des:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
Des:5 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Obj:6 http://ftp.cixug.es/mint/packages tara Release
Des:7 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Descargados 247 kB en 2s (149 kB/s)
Leyendo lista de paquetes... Hecho
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Nota, seleccionando «libsane1» en lugar de «libsane»
libsane1 ya está en su versión más reciente (1.0.27-1~experimental3ubuntu2).
El paquete indicado a continuación se instaló de forma automática y ya no es necesario.
libgle3
Utilice «sudo apt autoremove» para eliminarlo.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
(Leyendo la base de datos ... 278587 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../iscan_2.30.1-1~usb0.1.ltdl7_i386.deb ...
Desempaquetando iscan (2.30.1-1~usb0.1.ltdl7) sobre (2.30.1-1~usb0.1.ltdl7) ...
Preparando para desempaquetar .../iscan-data_1.36.0-1_all.deb ...
Desempaquetando iscan-data (1.36.0-1) sobre (1.36.0-1) ...
Preparando para desempaquetar .../iscan-plugin-cx4400_2.1.3-1_i386.deb ...
Desempaquetando iscan-plugin-cx4400 (2.1.3-1) sobre (2.1.3-1) ...
Configurando iscan-data (1.36.0-1) ...
Configurando iscan (2.30.1-1~usb0.1.ltdl7) ...
Procesando disparadores para desktop-file-utils (0.23+linuxmint3) ...
Configurando iscan-plugin-cx4400 (2.1.3-1) ...
Procesando disparadores para gnome-menus (3.13.3-11ubuntu1) ...
Procesando disparadores para mime-support (3.60ubuntu1) ...
Procesando disparadores para man-db (2.8.3-2) ...
Procesando disparadores para udev (237-3ubuntu10) ...
Procesando disparadores para libc-bin (2.27-3ubuntu1) ...


What else can I do?

Thank you and greetings.
Fear is soul's executioner

User avatar
kyphi
Level 8
Level 8
Posts: 2340
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by kyphi » Wed Jul 04, 2018 9:31 pm

Both XSane and Simple Scan work fine in Linux Mint 18 Cinnamon 64 bit with either a USB or Wi-Fi connection.

Epson's Image Scan for Linux does not work at all currently. It is "a work in progress".
Linux Mint 19 Cinnamon - 64bit

User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by McFlow61 » Thu Jul 05, 2018 5:48 am

kyphi wrote:
Wed Jul 04, 2018 9:31 pm
Both XSane and Simple Scan work fine in Linux Mint 18 Cinnamon 64 bit with either a USB or Wi-Fi connection.

Epson's Image Scan for Linux does not work at all currently. It is "a work in progress".
Hi kyphi.

I've got installed on an Acer Aspire 5670 series Linux Mint 17.3 Xfce and also Linux Mint 19 Xfce, both 32 bit system. Windows XP too.

I know is an old computer laptop, but it runs fine as my need is for. Maybe the solution is buy a modern computer, but I resist to do it.

On Mint 17.3, both Simple Scan and Epson's Image Scan for Linux work very well. It doesn't on Mint 19, both.

As you say it is "a work in progress" only I just wait for Linux Mint team fix this issue.

Thanks and greetings
Fear is soul's executioner

User avatar
kyphi
Level 8
Level 8
Posts: 2340
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by kyphi » Fri Jul 06, 2018 1:07 am

I do not think that this is an issue for the Linux Mint Development Team but rather for the Epson Development Team.

The comment made earlier that a bug report had stated that Epson scanners stopped working should read that some Epson scanners had stopped working last year as a result of changes introduced by SANE (Scanner Access Now Easy).
I have two Epson scanners and both work fine with Simple Scan and XSane. It is the scanning utility provided by Epson "Image Scan!for Linux" that no longer works.

Hopefully I will find out why.
Linux Mint 19 Cinnamon - 64bit

User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by McFlow61 » Fri Jul 06, 2018 12:10 pm

kyphi wrote:
Fri Jul 06, 2018 1:07 am
I do not think that this is an issue for the Linux Mint Development Team but rather for the Epson Development Team.

The comment made earlier that a bug report had stated that Epson scanners stopped working should read that some Epson scanners had stopped working last year as a result of changes introduced by SANE (Scanner Access Now Easy).
I have two Epson scanners and both work fine with Simple Scan and XSane. It is the scanning utility provided by Epson "Image Scan!for Linux" that no longer works.

Hopefully I will find out why.
Hi kyphi

Epson's Image Scan for Linux works yet on Linux Mint 17.3, so I would think is an issue of Linux Mint 19, don't you? Another thing should be if Epson's Imagen Sacan doesn't work and Simple Scan or XSane do, there I would think is an issue of Epson's. But both don't work on Mint 19. I repeat that they do on Mint 17.3.

If SANE introduced changes... who's the blame? SANE? EPSON? LINUX? If SANE wouldn't introduce changes, would be all ok? Or not? Or now is Epson who has to give a solution. There isn't?

Conclusion: I'll keep working with Linux Mint 17.3 and the obsolete windows xp till I could buy a new laptop or a new Printer Scanner.

Thanks, best regards
Fear is soul's executioner

User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

Re: Epson Stylus DX4400

Post by McFlow61 » Sat Jul 07, 2018 1:47 pm

pdc_2 wrote:
Tue Jul 03, 2018 6:47 pm
in this bug report to Ubuntu last year; where Epson scanners stopped working;

https://bugs.launchpad.net/ubuntu/+sour ... ug/1728012

What was suggested; post #25 has the details
1. install libsane1 1.0.27-1~experimental2ubuntu2.1
2.

Code: Select all

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane
If the connection is usb, they suggest a udev rule ....... maybe you paste the above command; (see what libsane version you have in Mint 19 ..) .. reboot ... any joy?
Solved!

Hi pdc_2

Cause I have a 32 bit system I've tried this:

Code: Select all

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/i386-linux-gnu/sane
Just reboot and.. magic all works perfectly, Simple Scan, Xsane and even iscan Epsons Image Scan for Linux.

Thank you my friends
Fear is soul's executioner

User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by McFlow61 » Sat Jul 07, 2018 2:09 pm

joy joy joy joy

I jump full of joy :D :D :D
Fear is soul's executioner

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by pdc_2 » Sat Jul 07, 2018 3:20 pm

Hi mcflow; delighted to hear of your success; we learn from each other all the time; you have helped everyone;

.. as you own this thread, if you go back to the title of your first post; if you add SOLVED in that line; anyone searching can find it;

I will edit my earlier post to highlight the 32bit issue:

User avatar
kyphi
Level 8
Level 8
Posts: 2340
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by kyphi » Sat Jul 07, 2018 5:20 pm

@ pdc_2
Although my Epson scanner worked fine with Simple Scan and XSane, Image Scan did not.
The line suggested by you # ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane restored full functioning to Image Scan without a reboot. Thank you.
Linux Mint 19 Cinnamon - 64bit

User avatar
McFlow61
Level 1
Level 1
Posts: 8
Joined: Tue Jul 03, 2018 11:01 am
Location: The world
Contact:

Re: Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by McFlow61 » Sun Jul 08, 2018 6:28 am

kyphi wrote:
Sat Jul 07, 2018 5:20 pm
@ pdc_2
Although my Epson scanner worked fine with Simple Scan and XSane, Image Scan did not.
The line suggested by you # ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane restored full functioning to Image Scan without a reboot. Thank you.
Hi pdc_2

Cool!

A hug and best regards!
Fear is soul's executioner

samiel60
Level 3
Level 3
Posts: 129
Joined: Thu Apr 13, 2017 1:03 pm

Re: [SOLVED] Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by samiel60 » Mon Jul 09, 2018 5:21 pm

The creation of the link is good for now LM19 recognizes my Epson V350,
but Xsane works only as root and not as user. Have i to change some permission,
or to create an UDEV rule?
thanx
s

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

udev rule needed??

Post by pdc_2 » Mon Jul 09, 2018 11:11 pm

my apologies for not acknowledging the thanks from kyphi a couple of days ago; many thanks and sorry I missed your reply; very pleased to be able to help so skilled a forum helper

Samiel60; are you launching xsane from a terminal; the word
root
is more of a rpm word (ie Red Hat and OpenSuse); Mint tend to use sudo more

If you go back to the link where the symbolic links are discussed; one of the posts around #25 talks of a udev rule; most folks seem to find things work just with the link; you could add the udev rule that was suggested by the bug reporters;

as you can see from the title of the thread; it is now listed as SOLVED: so if you need lots of answers, maybe we get the forum moderators to peel your entry off and start a new thread ..

as I said in this or another post; it is frustrating to get problems in the software; but to read the many entries in the bug report; it is the open and contributory nature of open software: dynamic and rapidly responsive; it is great to see it in action

samiel60
Level 3
Level 3
Posts: 129
Joined: Thu Apr 13, 2017 1:03 pm

Re: [SOLVED] Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by samiel60 » Tue Jul 10, 2018 9:35 am

I found the solution. The link is good for the system finds the scanner.
Moreover, to use it as simple user I had to create the file /etc/udev/rules.d/99-local.rule
and putting inside the following srings:

Code: Select all

SUBSYSTEM="usb_device", ACTION="add", GOTO="epson_rules_end"

# Epson Perfection V350 Photo
ATTR{idVendor}="0x04b8", ATTR{idProduct}="0x012f", SYMLINK+="scan-epson", MODE="0666", OWNER="samiel", GROUP="scanner"

LABEL="epson_rules_end"
thnax
s

ad4
Level 1
Level 1
Posts: 2
Joined: Wed Sep 19, 2018 3:15 pm

Re: [SOLVED] Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by ad4 » Wed Sep 19, 2018 3:25 pm

Hello,

I cannot manage to get the scan program working.
I use a scan-printer combo "Epson Stylus DX 4400" on a 64 bits system.
I installed Epson drivers from their web site and followed the above but it fails.
I noticed that there's a IScan version 3 in the Flatpak repo. I also tried it but nothing works.

I also tried on LMDE 3 and the result is the same : I have to get back to a proprietary OS when I need to scan (which really bores me...).

Could someone write a step-by-step tutorial for this DX 4400 scanner on a 64 bits system in order to get things work ?

Thx in adv.
Regards.

ad4
Level 1
Level 1
Posts: 2
Joined: Wed Sep 19, 2018 3:15 pm

Re: [SOLVED] Scanner Epson Stylus DX4400 works on Linux Mint 17.3 but not on Linux Mint 19

Post by ad4 » Sun Sep 23, 2018 8:33 am

Hi,

I finally managed to get things working on LMDE 3 !
I also did it with Linuxmnt 19 : please see at the end of message.

Here's how :

Installation of IScan 2.30.1 (three 64 bits .deb files)

and

creation of rules file with : sudo nano /etc/udev/rules.d/79-udev-epson.rules
text of the rules file follows :
-------

Code: Select all

SUBSYSTEM="usb_device", ACTION="add", GOTO="epson_rules_end"

# Epson
ATTR{idVendor}="0x04b8", ATTR{idProduct}="0x012f", SYMLINK+="scan-epson", MODE="0666", OWNER="YOUR_USER_NAME_GOES_HERE", GROUP="scanner"

LABEL="epson_rules_end"
-------

PLEASE do NOT forget to reboot and to turn off and on your scanner-printer !

I'm sooooooooooooooooooo glad i freed myself from the proprietary OS that came with my PC !!!
AND THX TO THE LINUXMINT TEAM FOR BRINGING US A DEBIAN BASED EDITION
:-)

For Linuxmint 19 :
do the same AND add the following line in a terminal :
sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane

Post Reply

Return to “Printers & Scanners”