Pixma MX479

Forum rules
Before you post please read this
Post Reply
Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Pixma MX479

Post by Softech7 » Fri Jul 06, 2018 12:54 pm

Just got done installing Linux 19 and going the initial setup and now i'm not able to get my network print to connect using this new CUPS setup. I didn't have this issue with the lesser versions. Need help PLEASE. I use the canon Pixma MX479. I get this 'server-error-internal-error' what does that mean.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Pixma MX479 what about trying the Canon drivers?

Post by pdc_2 » Fri Jul 06, 2018 6:48 pm

I didn't have this issue with the lesser versions
as you joined in 2017, I am assuming you have run Mint 17 and Mint 18;

can I suggest you install the drivers that Canon supply for the MX470 series Pixmas; if you go here http://support-asia.canon-asia.com/cont ... 86902.html and click to download and SAVE what will be cnijfilter-mx470series-4.10-1-deb.tar.gz

If you open a terminal; copy each command below 1 by 1, and paste into the terminal;

Code: Select all

cd Downloads

Code: Select all

tar -zxvf cnijfilter-mx470series-4.10-1-deb.tar.gz

Code: Select all

cd cnijfilter-mx470series-4.10-1-deb

Code: Select all

sudo ./install.sh
that last command runs the install script; so watch it carefully; it will ask you some questions: hopefully the install script will give you the best chance of a successful config

(many of the MX470series are listed as airprint-compatible: curiously the 479 is not; airprint came into Ubuntu 17.04 and as Mint 19 uses 18.04, it should now be a part of Mint 19 and it means the system should auto-config printers that are airprint compatible: time will tell if this is 100% so ...........)

Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Re: Pixma MX479

Post by Softech7 » Thu Jul 12, 2018 8:52 pm

I done everything that you had described. With no luck, Its funny, I had no problems with the mint 18.3 version. Right now, I can only use localhost. Just wish i could use it over the network; Still could use help please.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Pixma MX479

Post by pdc_2 » Thu Jul 12, 2018 9:50 pm

so can you type or paste two commands into the terminal;

first,

Code: Select all

lpinfo -v
and if you copy what you get, and paste it into a reply; inside code tags: the 5th icon from the left in the above line.

then

Code: Select all

dpkg -l cnijfilter*
and do the same; thanks

Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Re: Pixma MX479

Post by Softech7 » Sat Jul 14, 2018 3:19 pm

Ok, I done everything that you had suggested on top of what was done before. when I go into the printer setup and go to the network printer setup. Linux does see what i have and when i click on it to finallize the confirmation of the printer and gets CUPS to get the drivers for it, comes back to CUPS operation server-error-internal-error. I get this error no matter which option 1} IPP Network printer via DNS SD or 2} Driverless IPP.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Pixma MX479

Post by pdc_2 » Sun Jul 15, 2018 3:55 am

googling on your error, if you go up to Home folder from the Menu at bottom left; when Home Folder opens; go 3 down in left column; and look for the /etc folder and open it and look for cups and then look for cupsd.conf.O which you can open with LibreOffice and see if there is text there; sometimes it seems to be empty

from this elderly post viewtopic.php?t=51175 they copied contents from the backup default file to the active one; to cure the problem; I have done a screenshot of the file that one is looking for in the cups folder

cupsd.conf.O.png
cupsd.conf.O.png (10.8 KiB) Viewed 380 times

Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Re: Pixma MX479

Post by Softech7 » Mon Sep 10, 2018 9:43 pm

Sorry about late reply, been busy reinstalling lm 18.3 to get printer to work. reinstalled 19.0 with same problem, followed your directions to the best of my ability with no luck. I really wish linux mint folks would figure this out. I still need help.

Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Re: Pixma MX479

Post by Softech7 » Mon Sep 10, 2018 10:05 pm

If anyone can tell me where to get the files to get CUPS, please tell me or show me. All my cupsd.cof.O is completely empty and when i try to reinstall the cups i get same thing. Need help, Im not able to connect to the CUPS server at all.

User avatar
trytip
Level 8
Level 8
Posts: 2489
Joined: Tue Jul 05, 2016 1:20 pm

Re: Pixma MX479

Post by trytip » Mon Sep 10, 2018 11:00 pm

systemctl start cups systemctl start cups-browsed does that do anything? if you search your system monitor for "cups" ?
Image

Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Re: Pixma MX479

Post by Softech7 » Tue Sep 11, 2018 7:31 am

/etc/cups/cupsd.conf.O is completely empty and both commands you gave after copy/paste quickly does what ever. No browse no nothing.

Not sure if I should continue with LM19 or go back to LM 18. I need printer access. Is there a way to copy a working CUPS folder from someone.

Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Re: Pixma MX479

Post by Softech7 » Tue Sep 11, 2018 7:35 am

The post above with all the files in the CUPS folder, ssl is empty, class file does not exist, and the cups confO file is empty.
I downloaded LM19 from Linux Mint site and verified the copy.

Softech7
Level 1
Level 1
Posts: 11
Joined: Fri Jul 21, 2017 1:34 am

Re: Pixma MX479

Post by Softech7 » Fri Sep 14, 2018 8:06 pm

I went ahead and figured out how to upgrade with a youtube video on how to do all the steps. I don't understand why a fresh install would cause so much issues. Thanks all for the help that you have given me.

Everything works great.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Pixma MX479 solved by a fresh install

Post by pdc_2 » Sat Sep 15, 2018 12:10 am

just like this viewtopic.php?f=51&t=277256 (the post below yours)
Perhaps not the quickest solution but I bought a CD of Mint 19 MATE from Linux mint shop and did a fresh install. Printer works without even having to do all the HP stuff. just opened my file clicked print and the HP showed, selected and prints.
I am not sure how one can verify an install has gone well; quite a few "printer" problems are miraculously cured by a fresh install

Post Reply

Return to “Printers & Scanners”