HP LaserJet Pro MFP M281fdw

Forum rules
Before you post please read this
cliffcoggin
Level 1
Level 1
Posts: 30
Joined: Sat Sep 17, 2016 6:40 pm
Location: England

Re: HP LaserJet Pro MFP M281fdw

Post by cliffcoggin » Sun Aug 05, 2018 10:26 am

Mr. T.

I have just returned for the first time since resolving the installation of this printer on my Mint 18.3 machine so I may not have grasped all the salient points since then. If so, apologies.

Your version of HPLIP (3.17.something) would have detected the printer automatically, just as it did with mine, which is why you had to do nothing by way of special installation. However if you want to scan wirelessly you need to install HPLIP 3.18.5 or higher, as I noted in an earlier post. That version of HPLIP was not available in Synaptic or the Mint software manager so it had to be downloaded from HP. I suggest you do the same and let it install automatically. It will detect your operating system and ask you to confirm it. If your OS is not listed just cancel the installation. Incidentally it will also remove any older versions of HPLIP during the process, so special preparations are unnecessary. If all else fails you may have to revert to the older HPLIP for printing, and wait until the Mint repository is updated for the scanning capability of 3.18.x.

https://developers.hp.com/hp-linux-imag ... g/gethplip
will get you the download.
There is a link on that page with step by step installation instructions, though you should watch for detail discrepancies. For example I downloaded to Downloads not Desktop etc.

pdc_2
Level 8
Level 8
Posts: 2386
Joined: Mon May 11, 2009 1:21 am

Re: HP LaserJet Pro MFP M281fdw

Post by pdc_2 » Sun Aug 05, 2018 2:34 pm

thanks Cliff;
If all else fails you may have to ... wait until the Mint repository is updated for the scanning capability of 3.18.x.
past experience is sadly that does not happen; so Mint 20 will come out in July-Aug 2020; and will snapshot the latest hplip of that time; the intervening updates of 19.1 and 19.2 will not bring updates of hpip; as it is not in the ubuntu repositories; folks have to go to the HP site to get the latest;
For example I downloaded to Downloads not Desktop etc.
indeed; in the Mint the default when one selects to SAVE a package on download, is that the Downloads directory is default; unless one sets something else

srq2625
Level 4
Level 4
Posts: 290
Joined: Tue Jan 08, 2013 11:35 am
Location: State: Constant Confusion, Country: D'oh

Re: HP LaserJet Pro MFP M281fdw

Post by srq2625 » Mon Aug 06, 2018 5:38 pm

MrT wrote:
Sat Aug 04, 2018 2:53 pm
@srq2625.. so many dependencies missing. Did you download your tarball.gz file?... LM 19 is not really covered among the selections... what libs did you install? The commands above, as given, would not install or do anything. Thank you
Yes, there are lot of dependencies. Here's a step-by-step to get the job done (I just installed and fully updated LM19 MATE for this list howto):
  1. Download the tar file from here - look under the "Advance Options" section
  2. Go to the location where the .tar.gz file was downloaded and

    Code: Select all

    tar xf hplip-3.18.7.tar.gz
  3. Install the packages needed for a successful compile and installation:

    Code: Select all

    apt-get install build-essential libjpeg-turbo8-dev avahi-utils cups libcups2 libcups2-dev cups-bsd cups-client libcupsimage2 libcupsimage2-dev libdbus-1-dev g++ ghostscript cups-filters ghostscript-x libssl-dev libsnmp-dev snmp libc6 libtool libtool-bin libusb-1.0-0-dev make wget policykit-1 policykit-1-gnome python3-dbus python3-gi python3-dev python3-notify2 python3-pil python3-pyqt4 gtk2-engines-pixbuf python3-dbus.mainloop.qt python3-reportlab python3-lxml sane libsane-dev sane-utils xsane python-dev
    
  4. cd into the code directory cd hplip-3.18.7
  5. Configure....

    Code: Select all

    ./configure --prefix=/usr --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib/x86_64-linux-gnu --enable-qt4 --enable-hpcups-install --enable-cups-drv-install --disable-cups-ppd-install --disable-hpijs-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-foomatic-rip-hplip-install --enable-fax-build --enable-dbus-build --enable-network-build --enable-scan-build --disable-policykit --disable-libusb01_build --disable-udev_sysfs_rules --enable-doc-build
    
  6. Compile the code: make
  7. Install some things needed for the setup

    Code: Select all

    sudo apt-get install --install-recommends python-qt4 python-qt4-dev python-pyqt5 python-dbus
  8. Install the software: sudo make install
  9. Run hp-setup
  10. Now, install what's needed to get connected to the scanner hp-plugin

MrT
Level 3
Level 3
Posts: 122
Joined: Tue Jun 20, 2017 3:21 pm

Re: HP LaserJet Pro MFP M281fdw

Post by MrT » Mon Aug 06, 2018 10:45 pm

Thank you. I will attempt what you suggested.

MrT
Level 3
Level 3
Posts: 122
Joined: Tue Jun 20, 2017 3:21 pm

Re: HP LaserJet Pro MFP M281fdw

Post by MrT » Wed Aug 08, 2018 11:45 am

I am running into this problem:

The following packages have unmet dependencies:
python3-dev : Depends: libpython3-dev (= 3.6.5-3ubuntu1) but it is not going to be installed
Depends: python3.6-dev (>= 3.6.5-2~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have python 3.6.6 installed via Anaconda.
mrt@mrt-WT73VR-7RM ~ $ python -V
Python 3.6.6 :: Anaconda custom (64-bit)


All the other dependencies seem to be met.

Post Reply

Return to “Printers & Scanners”