Cannot install Epson XP640 printer or scanner

Forum rules
Before you post please read this
dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Sat Jul 07, 2018 9:40 am

I downloaded the drivers 64bit files ok, installed in terminal....and NOTHING. doesn't show up in the driver list at all.
went to localhost 631 page...but it want's a ppd file. can't find it. won't print or scan.
i just installed mint 18 xfce. printer works fine in windows 7, but not in Mint xfce.
where do i find this ppd file? searched the printer driver folder, not there.

help?
Last edited by Moem on Sat Jul 07, 2018 10:15 am, edited 1 time in total.
Reason: Removed all-caps.

User avatar
Pierre
Level 17
Level 17
Posts: 7406
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: CANNOT INSTALL EPSON XP640 PRINTER OR SCANNER

Post by Pierre » Sat Jul 07, 2018 9:53 am

this Tutorial is for Ubuntu 18.04:
https://tutorialforlinux.com/2018/04/04 ... d-install/
but, that method should also work with LinuxMint 18x as well.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Cannot install Epson XP640 printer or scanner

Post by pdc_2 » Sat Jul 07, 2018 3:42 pm

Hi duran; so pierre has pointed you to a good tutorial;

the post above you is about the WF-2750 and it uses exactly the same driver: epson-inkjet-printer-escpr_1.6.22-1lsb3.2_amd64.deb

if you think it is safely installed, if you open Synaptic ....... it is the programme that allows one to install and delete packages;

if you type
epson
in its search box, it should say epson-inkjet-printer-escpr_1.6.22-1lsb3.2 if it safely installed;

<<<<<<<<<
to get a printer configured, you need to do two things: 1) install the driver and 2) register the printer with lpadmin

If the driver is installed, if you go to the PRINTERS folder ...... start at MENU bottom left and look in the ADMINISTRATION folder? There is an ADD button ..... it should find the printer if it is wireless; and it has already been set up to talk to your router; ... it should offer to set it up for you ..

doing it this GUI way should save using the CUPS interface

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Sat Jul 07, 2018 4:16 pm

ok, thanks to all for answers.....i got the printer installed following the tutorial ok. But NOT the scanner.
when i followed those instructions, and typed in: "imagescan" , it pulled up a scanning dialogue page that says:
NO DEVICES FOUND" ... so what can i do now??

oh, in synaptic, it shows "epson-printer-utility" and "printer-driver-escpr, and escputil"

but the printer works ok, just no scanner.

User avatar
JerryF
Level 10
Level 10
Posts: 3032
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Cannot install Epson XP640 printer or scanner

Post by JerryF » Sat Jul 07, 2018 5:28 pm

I had the exact same model you do. Unfortunately, the ink ran inside and was a huge mess. Anyway...

Is your Epson connected by wireless? If so, I've attached a Libre Office Document with the steps I had to take for mine to work. Since you already have the printer working, start with the section "To enable Wi-Fi for Epson devices..."

Hope this works for you!
Attachments
Set up Epson Printer and Scanner.odt
(18.47 KiB) Downloaded 20 times
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Sat Jul 07, 2018 5:57 pm

i have the printer connected by wi-fi. i downloaded the imagescan*.deb file....ran the ./install.sh file ok...and it shows this:
/tmp $ cd /tmp/imagescan*
dave@PRIMARY /tmp/imagescan-bundle-linuxmint-18-1.3.32.x64.deb $ ./install.sh
[sudo] password for dave:
(Reading database ... 207002 files and directories currently installed.)
Preparing to unpack .../imagescan_3.42.0-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan (3.42.0-1epson4linuxmint18) over (3.42.0-1epson4linuxmint18) ...
Preparing to unpack .../imagescan-plugin-ocr-engine_1.0.0-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan-plugin-ocr-engine (1.0.0-1epson4linuxmint18) over (1.0.0-1epson4linuxmint18) ...
Preparing to unpack .../imagescan-plugin-gt-s650_1.0.0-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan-plugin-gt-s650 (1.0.0-1epson4linuxmint18) over (1.0.0-1epson4linuxmint18) ...
Preparing to unpack .../imagescan-plugin-networkscan_1.1.1-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan-plugin-networkscan (1.1.1-1epson4linuxmint18) over (1.1.1-1epson4linuxmint18) ...
Setting up imagescan (3.42.0-1epson4linuxmint18) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Setting up imagescan-plugin-gt-s650 (1.0.0-1epson4linuxmint18) ...
Setting up imagescan-plugin-networkscan (1.1.1-1epson4linuxmint18) ...
Setting up imagescan-plugin-ocr-engine (1.0.0-1epson4linuxmint18) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
dave@PRIMARY /tmp/imagescan-bundle-linuxmint-18-1.3.32.x64.deb $

so it seems to install.....since i get no error messages.....but.....again the imagescan dialogue pages says no devices found.

driving me nuts...... maybe i should switch to Mint "Cinnamon" ?? and try it there?

i really like xfce...has all the programs i use installed already.

User avatar
JerryF
Level 10
Level 10
Posts: 3032
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Cannot install Epson XP640 printer or scanner

Post by JerryF » Sat Jul 07, 2018 6:14 pm

dduran1210 wrote:
Sat Jul 07, 2018 5:57 pm
i have the printer connected by wi-fi. i downloaded the imagescan*.deb file....ran the ./install.sh file ok...and it shows this:

Code: Select all

/tmp $ cd /tmp/imagescan*
dave@PRIMARY /tmp/imagescan-bundle-linuxmint-18-1.3.32.x64.deb $ ./install.sh
[sudo] password for dave: 
(Reading database ... 207002 files and directories currently installed.)
Preparing to unpack .../imagescan_3.42.0-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan (3.42.0-1epson4linuxmint18) over (3.42.0-1epson4linuxmint18) ...
Preparing to unpack .../imagescan-plugin-ocr-engine_1.0.0-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan-plugin-ocr-engine (1.0.0-1epson4linuxmint18) over (1.0.0-1epson4linuxmint18) ...
Preparing to unpack .../imagescan-plugin-gt-s650_1.0.0-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan-plugin-gt-s650 (1.0.0-1epson4linuxmint18) over (1.0.0-1epson4linuxmint18) ...
Preparing to unpack .../imagescan-plugin-networkscan_1.1.1-1epson4linuxmint18_amd64.deb ...
Unpacking imagescan-plugin-networkscan (1.1.1-1epson4linuxmint18) over (1.1.1-1epson4linuxmint18) ...
Setting up imagescan (3.42.0-1epson4linuxmint18) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Setting up imagescan-plugin-gt-s650 (1.0.0-1epson4linuxmint18) ...
Setting up imagescan-plugin-networkscan (1.1.1-1epson4linuxmint18) ...
Setting up imagescan-plugin-ocr-engine (1.0.0-1epson4linuxmint18) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
dave@PRIMARY /tmp/imagescan-bundle-linuxmint-18-1.3.32.x64.deb $ 
so it seems to install.....since i get no error messages.....but.....again the imagescan dialogue pages says no devices found.

driving me nuts...... maybe i should switch to Mint "Cinnamon" ?? and try it there?

i really like xfce...has all the programs i use installed already.
Have you looked at my document and tried editing the files I list? Make a copy of the originals first, then edit the files.

Reboot after editing.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Sun Jul 08, 2018 2:00 am

Hi JerryF, yeah, i went back again and edited the document and made the changes step by step. I did the apt-get update, then rebooted after editing
the doc. came back to the terminal ...typed in imagescan and got the same message in the dialogue box again " no devices found". Yet I can
print ok. Just can't scan.

User avatar
JerryF
Level 10
Level 10
Posts: 3032
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Cannot install Epson XP640 printer or scanner

Post by JerryF » Sun Jul 08, 2018 10:18 am

If you have it on, try turning off Firewall temporarily.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Sun Jul 08, 2018 11:23 am

Firewall was disabled. never on.

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Sun Jul 08, 2018 11:26 am

has to be a bug in the deb files, i think.

downloaded all again & still can't find device on network.

but the network is fine, printer works fine.

User avatar
JerryF
Level 10
Level 10
Posts: 3032
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Cannot install Epson XP640 printer or scanner

Post by JerryF » Sun Jul 08, 2018 6:10 pm

Bummer! :cry:

I'm out of ideas.

Edit:
When you downloaded drivers, did you get them from here:

http://download.ebz.epson.net/dsc/searc ... h/?OSC=LX)
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Tue Jul 10, 2018 11:33 am

Hi Jerry, ok i deleted xfce and installed cinnamon. installed the printer ok. when i got to the instructions: dpkg --install iscan-data_$ver-$rel_all.deb

i get this error message:

Code: Select all

dave@primary ~/Downloads $ sudo dpkg --install iscan-data_$ver-$rel_all.deb
dpkg: error processing archive iscan-data_-.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 iscan-data_-.deb
this was after i did this:
Optional:
Download and install Image Scan! For Linux at http://support.epson.net/linux/en/iscan_c.html
End of optional.

Code: Select all

dave@primary ~/Downloads $ tar xaf iscan-bundle-1.0.0.x64.deb.tar.gz

dave@primary ~/Downloads $    cd iscan-bundle-1.0.0.x64.deb

dave@primary ~/Downloads/iscan-bundle-1.0.0.x64.deb $    ./install.sh

[sudo] password for dave: 
Ign:1 http://packages.linuxmint.com serena InRelease
Hit:2 http://packages.linuxmint.com serena Release                             
Hit:3 http://archive.canonical.com/ubuntu xenial InRelease                     
Get:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]     
Hit:6 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial InRelease
Hit:7 http://archive.ubuntu.com/ubuntu xenial InRelease                        
Get:8 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]       
Get:9 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]     
Fetched 323 kB in 3s (98.7 kB/s)   
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  gimp-help-common
Use 'sudo apt autoremove' to remove it.
The following NEW packages will be installed:
  xsltproc
0 upgraded, 1 newly installed, 0 to remove and 31 not upgraded.
Need to get 13.4 kB of archives.
After this operation, 150 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 xsltproc amd64 1.1.28-2.1ubuntu0.1 [13.4 kB]
Fetched 13.4 kB in 0s (21.8 kB/s) 
Selecting previously unselected package xsltproc.
(Reading database ... 239217 files and directories currently installed.)
Preparing to unpack .../xsltproc_1.1.28-2.1ubuntu0.1_amd64.deb ...
Unpacking xsltproc (1.1.28-2.1ubuntu0.1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up xsltproc (1.1.28-2.1ubuntu0.1) ...
Selecting previously unselected package iscan.
(Reading database ... 239227 files and directories currently installed.)
Preparing to unpack .../iscan_2.30.1-1~usb0.1.ltdl7_amd64.deb ...
Unpacking iscan (2.30.1-1~usb0.1.ltdl7) ...
Selecting previously unselected package iscan-data.
Preparing to unpack .../iscan-data_1.36.0-1_all.deb ...
Unpacking iscan-data (1.36.0-1) ...
Selecting previously unselected package iscan-network-nt.
Preparing to unpack .../iscan-network-nt_1.1.1-1_amd64.deb ...
Unpacking iscan-network-nt (1.1.1-1) ...
Setting up iscan-data (1.36.0-1) ...
Setting up iscan (2.30.1-1~usb0.1.ltdl7) ...
Setting up iscan-network-nt (1.1.1-1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for udev (229-4ubuntu12) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
so this installed ok with no errors, but then i got the error message listed at the top of the page here.
where do i get this archive???

thank you for your help.

User avatar
JerryF
Level 10
Level 10
Posts: 3032
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Cannot install Epson XP640 printer or scanner

Post by JerryF » Tue Jul 10, 2018 12:45 pm

dduran1210 wrote:
Tue Jul 10, 2018 11:33 am
Hi Jerry, ok i deleted xfce and installed cinnamon. installed the printer ok. when i got to the instructions: dpkg --install iscan-data_$ver-$rel_all.deb
I'm not sure which instructions you're talking about. I just tried to download the scanner driver at Epson Center and got this message:
The page you requested is unavailable

Any particular reason you deleted Xfce and installed Cinnamon? Just curious.


i get this error message:

Code: Select all

dave@primary ~/Downloads $ sudo dpkg --install iscan-data_$ver-$rel_all.deb
dpkg: error processing archive iscan-data_-.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 iscan-data_-.deb

...but then i got the error message listed at the top of the page here.
where do i get this archive???

thank you for your help.
[/quote]
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Epson XP640 what about symbolic links

Post by pdc_2 » Tue Jul 10, 2018 2:58 pm

phew; all very tricky; if I can post a comment?

In this bug report https://bugs.launchpad.net/ubuntu/+sour ... ug/1728012 from last year, things had changed on Ubuntu; and Mint comes from Ubuntu; so they suggested telling the system where to find files it was looking for; ... sort of like ....... where are my socks? ..... oh they are in that drawer ......

so they suggested

1)

Code: Select all

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane
2) and they also suggested a udev rule

Code: Select all

# chmod device EPSON group
ATTRS{manufacturer}=="EPSON", DRIVERS=="usb", SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="*", MODE="0777"
that is put inside /etc/udev/rules.d/79-udev-epson.rules; you have likely got that file already

Code: Select all

gedit /etc/udev/rules.d/79-udev-epson.rules
will let you read it safely in read-only variant;

COMMENT: I think from other posts that 1) alone will work: so maybe try that first; do a reboot and see if the link helps; if not, we can give some details on how to edit the file:

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Tue Jul 10, 2018 8:28 pm

well, i did the first one...and entered it in the terminal. no error message.
then i rebooted. checked the scanner in the menu....1. IMAGESCAN FOR LINUX: could NOT send command to scanner...check status.
(the printer is on and working ok.)
2. SIMPLE SCAN: opens a dialogue box and it says: NO SCANNER DETECTED.

i went to the udev folder and yes that line in #2 is in the file already.

I deleted xfce and installed Cinnamon, thinking maybe that would accept the scanner....but that didn't work either.

I THINK i got the instructions from here: but hit so many sites i'm not sure...but here's what i copied & followed these instructions:

Code: Select all

Go to Epson’s website.
Go to Support.
Search for printer model.
Choose Linux as the OS.
Under Drivers, click on Support for Linux.
Click on Linux Drivers for Epson Products.
This will take you to http://download.ebz.epson.net/…

(Quick link for above steps:  http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX)

Enter product model.
Download suggested utilities.

Using your File Manager, go to your Downloads folder.  Look for a file with an extension name of .deb
Right click the file and select “Open With Gdebi Package Installer”

In Mint menu, open Printers
Click Add
Click Network Printer
Click on your printer listed.  Connection on the right should be IPP network printer via DNS-SD
Click Forward.  This will search for drivers.
Epson (recommended) should be selected as default.
Click Forward
Select your model number (or the closest model number)
Click Forward
Click Apply
It should ask you to print a test page.  Click “Print Test Page”.
Note:  for some reason, a notification may show that there is a CUPS error in printing.
Click “Ok”

Optional:
Download and install Image Scan! For Linux at http://support.epson.net/linux/en/iscan_c.html
End of optional.

To enable Wi-Fi for Epson devices, you have to edit two configuration files on your system:  you must have root permissions to edit these files.

/etc/sane.d/dll.conf
and
/etc/sane.d/epson2.conf

Open the file “dll.conf” and remove all entries EXCEPT the following two:
net
epson2

Save the file.

Open the file “epson2.conf”
and in the area for Network Attached Devices

Type the following:
net 192.168.1.5 (put the actual IP address of your printer)
If “net autodiscovery” is listed, remove it.

Save the file.

This should enable scanning using wi-fi network.
this did not work either !

User avatar
JerryF
Level 10
Level 10
Posts: 3032
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Cannot install Epson XP640 printer or scanner

Post by JerryF » Wed Jul 11, 2018 8:17 am

Ah, those instructions that I had given you!

I'm sorry that they didn't help you. I'm at a loss of why your scanner won't get recognized.

:cry:
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

dduran1210
Level 2
Level 2
Posts: 60
Joined: Thu Nov 15, 2012 11:47 am

Re: Cannot install Epson XP640 printer or scanner

Post by dduran1210 » Wed Jul 11, 2018 7:43 pm

well, thanks for your help anyway. Guess I better keep windows after all.....at least I can scan from there without any problems.

Just don't understand why I can't get the scanner installed here and especially why EPSON...offers NO support for linux at all!

Had I known that, i would have bought an HP printer instead.

User avatar
kyphi
Level 8
Level 8
Posts: 2307
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Cannot install Epson XP640 printer or scanner

Post by kyphi » Wed Jul 11, 2018 10:10 pm

...typed in imagescan
the correct command is iscan.

Why don't you try your Epson with a USB cable connection before configuring for wi-fi.

There is no Epson XP640 but there is an Epson XP-640. The Epson Download Centre does not respond to wrong entries.
Linux Mint 19 Cinnamon - 64bit

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Cannot install Epson XP640 scanner

Post by pdc_2 » Thu Jul 12, 2018 2:56 am

I read this earlier; I see kyphi has said what I was wondering about: but if it is ok to comment as well;

dduran: can you type or paste

Code: Select all

lpinfo -v
and also

Code: Select all

lpstat -t
in a terminal; and can you copy what you get there; and paste it back here from the two commands; putting it inside the code display: it is the button on the line above this text; which is 5 from the left;

this link is Epson telling you heaps of info http://download.ebz.epson.net/man/linux ... nv3_e.html It is available on the page where you clicked to download the driver package; it is called manual

so they do give support; there just ain't anyone on a telephone to help you; it must all be frustrating and make you very annoyed; if you can give us the info above?

Post Reply

Return to “Printers & Scanners”