SOLVED udev rule fixes Epson Perfection V350 Photo

Forum rules
Before you post please read this
Post Reply
samiel60
Level 3
Level 3
Posts: 120
Joined: Thu Apr 13, 2017 1:03 pm

SOLVED udev rule fixes Epson Perfection V350 Photo

Post by samiel60 » Mon Jul 09, 2018 2:54 pm

I've got a Epson Perfection V350 Photo. It works fine with Debian
and worked fine with LM SYlvia.
I installer its own driver (iscan) as in Debian,
but Tara doesn't recognise the scanner:
"search for devices ... no devices available".
The same if I launch xsane from console as root.
Any suggestion?
thanx
s

PS
the installation pgogram tells me
viene selezionato "libsane1" al posto di "libsane"
libsane1 è già alla versione più recente (1.0.27-1~experimental3ubuntu2).
can it be a trouble for I've libsane1 instead of libsane?

PS2
I read this post
viewtopic.php?f=51&t=272238
but my sistem is 64 bit...
Last edited by samiel60 on Tue Jul 10, 2018 4:25 pm, edited 2 times in total.

samiel60
Level 3
Level 3
Posts: 120
Joined: Thu Apr 13, 2017 1:03 pm

Re: scanner epson not found

Post by samiel60 » Mon Jul 09, 2018 3:15 pm

I tried:

Code: Select all

 sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane
Now, when I try to launch Xsane I receive:
No possible to open device 'epkova:interpreter:003:003: access to resource denied
I'm able to use scanner (now working) only as root.
plz that I added my user to scanner group in /etc/group

Tom739
Level 1
Level 1
Posts: 21
Joined: Sun Dec 03, 2017 5:40 am

Re: scanner epson not found

Post by Tom739 » Mon Jul 09, 2018 4:18 pm

Hi samiel60,

when I installed iscan for my Epson Perfection 3170 Photo, I had to modify the udev settings in order to allow non-root users to use the scanner. Please find more details under this link:

viewtopic.php?f=51&t=259235

Regards
Tom

samiel60
Level 3
Level 3
Posts: 120
Joined: Thu Apr 13, 2017 1:03 pm

Re: scanner epson not found

Post by samiel60 » Mon Jul 09, 2018 4:59 pm

in my case, scanner now is identified:

Code: Select all

root@darkstar:~# sane-find-scanner
found USB scanner (vendor=0x04b8 [EPSON], product=0x012f [EPSON Scanner]) at libusb:003:002
and

Code: Select all

root@darkstar:~# scanimage -L
device `epkowa:interpreter:003:002' is a Epson Perfection V350 flatbed scanner
Moreover, it works as root. So my "only" problem is (perhaps)
how to change a permission or a udev rule "only" to make the scanner
works as user too. But I'm not able to see which rule...

thanx!!

samiel60
Level 3
Level 3
Posts: 120
Joined: Thu Apr 13, 2017 1:03 pm

Re: scanner epson not found

Post by samiel60 » Tue Jul 10, 2018 9:36 am

Solved!
I had to create the file /etc/udev/rules.d/99-local.rule
and putting inside the following srings:

Code: Select all

SUBSYSTEM="usb_device", ACTION="add", GOTO="epson_rules_end"

# Epson Perfection V350 Photo
ATTR{idVendor}="0x04b8", ATTR{idProduct}="0x012f", SYMLINK+="scan-epson", MODE="0666", OWNER="samiel", GROUP="scanner"

LABEL="epson_rules_end"

s

pdc_2
Level 8
Level 8
Posts: 2309
Joined: Mon May 11, 2009 1:21 am

SOLVED udev rule fixes Epson Perfection V350 Photo

Post by pdc_2 » Tue Jul 10, 2018 3:02 pm

well done; great work

As you have done so well at solving it; and you own the thread;

if you change the title of the first post to add SOLVED but I can suggest you change that title to SOLVED udev rule fixes Epson Perfection V350 Photo

..... it just helps people find your good solution

<<<<<<<<
that is a very fulsome udev rule; where did you find it?

samiel60
Level 3
Level 3
Posts: 120
Joined: Thu Apr 13, 2017 1:03 pm

Re: SOLVED udev rule fixes Epson Perfection V350 Photo

Post by samiel60 » Wed Jul 11, 2018 11:43 am

some years ago I published a short article about:
how use scanner as user in Slackware....

Post Reply

Return to “Printers & Scanners”