Mint 18/19 And Canon Color Laser All In One

Forum rules
Before you post please read this
Zulu95
Level 1
Level 1
Posts: 18
Joined: Wed Jul 18, 2018 3:03 pm

Re: Mint 18/19 And Canon Color Laser All In One

Post by Zulu95 » Fri Aug 03, 2018 11:28 am

Tried one quick print and got the following errors:
E [19/Jul/2018:09:32:09 -0500] [cups-deviced] PID 2421 (gutenprint52+usb) stopped with status 1!
E [19/Jul/2018:09:32:41 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [19/Jul/2018:09:32:45 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [19/Jul/2018:09:32:45 -0500] copy_model: empty PPD file
E [19/Jul/2018:09:32:45 -0500] [Client 18] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8200C-Series) from localhost
E [19/Jul/2018:09:32:45 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [19/Jul/2018:09:32:45 -0500] copy_model: empty PPD file
E [19/Jul/2018:09:32:45 -0500] [Client 21] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8200C-Series) from localhost
E [19/Jul/2018:09:32:59 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [19/Jul/2018:09:32:59 -0500] copy_model: empty PPD file
E [19/Jul/2018:09:32:59 -0500] [Client 27] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8200C-Series) from localhost
E [19/Jul/2018:09:32:59 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [19/Jul/2018:09:32:59 -0500] copy_model: empty PPD file
E [19/Jul/2018:09:32:59 -0500] [Client 30] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8200C-Series) from localhost
E [19/Jul/2018:09:33:21 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [19/Jul/2018:09:33:24 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [19/Jul/2018:09:33:24 -0500] copy_model: empty PPD file
E [19/Jul/2018:09:33:24 -0500] [Client 35] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/printer) from localhost
E [19/Jul/2018:09:33:24 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Mint 18/19 And Canon Color Laser All In One

Post by pdc_2 » Fri Aug 03, 2018 8:21 pm

so thanks to FFiXCollector for testing this and finding it all works fine on his machine; that is what Canon reported too; very helpful; many thanks
Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer
I think you need to do some googling: either you or I do it; but if you start off first and see what you can find:

.. I would assume you have a standalone desktop? that is a home setup? with a single printer that you are trying to connect to? and no others? and just a home network with a single router?

<<<<<<<<

when I google on
Unable to create PPD file: Printer does not support required IPP attributes or document formats.
I get https://github.com/OpenPrinting/cups-filters/issues/22 and they seem to have some ideas there ... but actually ..... as they mention airprint ..

<<<<<<<,
actually, this 8280 is airprint-compatible;

please see how many icons are in the PRINTERS folder; right-click on each; look in PROPERTIES and look in MAKE & MODEL ..

I am wondering if you have more than one; and if one just says
Canon-MF8200C-Series
because I think that means it is using an airprint link rather than the Canon UFR that should be mentioned .... if it is installed ...........

Zulu95
Level 1
Level 1
Posts: 18
Joined: Wed Jul 18, 2018 3:03 pm

Re: Mint 18/19 And Canon Color Laser All In One

Post by Zulu95 » Sat Aug 04, 2018 7:45 am

I am using a LM19 labtop connecting wi-fi to one Canon printer via one wireless router. I'll fire up the LM19 computer later and give you the answers as to which printer/driver is being used.
Cheers,

Zulu95
Level 1
Level 1
Posts: 18
Joined: Wed Jul 18, 2018 3:03 pm

Re: Mint 18/19 And Canon Color Laser All In One

Post by Zulu95 » Tue Aug 14, 2018 10:33 pm

UPDATE:
Make & Model Canon MF8200C Series UFRII LT if that helps.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Mint 18/19 And Canon Color Laser All In One

Post by pdc_2 » Tue Aug 14, 2018 11:15 pm

so it worked fine for FFIX (and Canon say it works fine for them): but somewhere there is a problem for you; je sais pas malheursement

Zulu95
Level 1
Level 1
Posts: 18
Joined: Wed Jul 18, 2018 3:03 pm

Re: Mint 18/19 And Canon Color Laser All In One

Post by Zulu95 » Thu Aug 16, 2018 1:16 pm

Ni moi malheureusement. Zu viele wichtigere Dinge, die im Moment mehr Zeit verbringen.

emmfranklin
Level 1
Level 1
Posts: 7
Joined: Mon Jun 09, 2014 4:39 am

Re: Mint 18/19 And Canon Color Laser All In One

Post by emmfranklin » Fri Jan 18, 2019 1:03 am

I had canon ir3230 working absolutely fine in linux 17.
when i upgraded to linux 19 the printer stopped working.

two days of trial and error and nothing worked.

finally i did these steps and i don't know at which point the problem got solved.

i am writing this method for canon ir3230.
you may modify it for your own printer

i am not an expert linux . so i wont be able to give details . ill do my best.

my steps are copy pasted from various forums

remove cups and reinstall cups.

i tried removing cups and then tried reinstalling cups . i seem to have broken few packages so i did this.

update linux
this is the command
sudo aptitude update && sudo aptitude install gtkorphan

Continue by running:

sudo aptitude update && sudo aptitude upgrade
This is used to double-check that you have all the updates.


To clear out the broken packages use the command:

sudo aptitude -f

or

go to synaptic edit click fix broken packages

now install cups

how to install cups

https://community.linuxmint.com/software/view/cups


restart cups
sudo /etc/init.d/cups restart
restart ccpd in case you have it.


remove/delete canon ir3230 entry from printer dialog box
remove canon printer driver utility

reinstall canon printer driver utility from the command only
use this command
cd linux-UFRII-drv-v350-uken

sudo ./install.sh

reinstall your specific printer from utility


restart pc
no print

open printer dialog box
right click ir3230
click properties
click change from make and model
select option of provide ppd file
and give this file

Canon-imageRunner_3225-pxlmono.ppd
you will get this file
here
http://www.openprinting.org/driver/pxlmono

select canon image runner 3225 in the drop down
reinstall from ppd file

now test page printed
it works
Top
14 posts • Page 1 of 1

emmfranklin
Level 1
Level 1
Posts: 7
Joined: Mon Jun 09, 2014 4:39 am

Re: Mint 18/19 And Canon Color Laser All In One

Post by emmfranklin » Fri Jan 18, 2019 1:04 am

I had canon ir3230 working absolutely fine in linux 17.
when i upgraded to linux 19 the printer stopped working.

two days of trial and error and nothing worked.

finally i did these steps and i don't know at which point the problem got solved.

i am writing this method for canon ir3230.
you may modify it for your own printer

i am not an expert linux . so i wont be able to give details . ill do my best.

my steps are copy pasted from various forums

remove cups and reinstall cups.

i tried removing cups and then tried reinstalling cups . i seem to have broken few packages so i did this.

update linux
this is the command
sudo aptitude update && sudo aptitude install gtkorphan

Continue by running:

sudo aptitude update && sudo aptitude upgrade
This is used to double-check that you have all the updates.


To clear out the broken packages use the command:

sudo aptitude -f

or

go to synaptic edit click fix broken packages

now install cups

how to install cups

https://community.linuxmint.com/software/view/cups


restart cups
sudo /etc/init.d/cups restart
restart ccpd in case you have it.


remove/delete canon ir3230 entry from printer dialog box
remove canon printer driver utility

reinstall canon printer driver utility from the command only
use this command
cd linux-UFRII-drv-v350-uken

sudo ./install.sh

reinstall your specific printer from utility


restart pc
no print

open printer dialog box
right click ir3230
click properties
click change from make and model
select option of provide ppd file
and give this file

Canon-imageRunner_3225-pxlmono.ppd
you will get this file
here
http://www.openprinting.org/driver/pxlmono

select canon image runner 3225 in the drop down
reinstall from ppd file

now test page printed
it works
Top
14 posts • Page 1 of 1

Post Reply

Return to “Printers & Scanners”