Black bar in scans, Canon LIDE 100 scanner, Mint 19, reverting to libsane 1.0.25 backends fixes

Forum rules
Before you post please read this
Post Reply
mintytux
Level 1
Level 1
Posts: 1
Joined: Fri Jul 20, 2018 12:03 pm

Black bar in scans, Canon LIDE 100 scanner, Mint 19, reverting to libsane 1.0.25 backends fixes

Post by mintytux » Fri Jul 20, 2018 2:08 pm

I am posting this workaround in case it helps others with the same problem.

Problem Summary: Canon LIDE 100 scanner produces a vertical black strip on all scans in Linux Mint 19 using multiple programs (SimpleScan, XSane, etc.). The scanner worked flawlessly in Mint 18.


Relevant Hardware/Software Configuration:
- Architecture: x86_64
- OS: Linux Mint 19
- Scanner: Canon LIDE 100
- Relevant applications: SimpleScan, Xsane
- Relevant libraries: libsane 1.0.27, genesys backend


Workaround Summary:
Revert libsane backends to version 1.0.25. I followed the general process from here: https://askubuntu.com/questions/567863/ ... using-sane


Workaround Details:

- Download the libsane 1.0.25 backends source from: http://http.debian.net/debian/pool/main ... rig.tar.gz.
- Unpack the archive
- Install prerequisite packages to build libsane backends from source:

Code: Select all

sudo apt-get install libusb-dev build-essential libsane-dev
sudo apt-get install libavahi-client-dev libavahi-glib-dev libjpeg-dev
- Build and install libsane 1.0.25:

Code: Select all

cd sane-backends
./configure
make
sudo make install
- Double-check that 1.0.25 is FIRST in the library load order for libsane:

Code: Select all

sudo ldconfig -v | grep libsane
- You should see something like:

Code: Select all

libsane.so.1 -> libsane.so.1.0.25
libsane.so.1 -> libsane.so.1.0.27
- Run SimpleScan or XSane to test

Post Reply

Return to “Printers & Scanners”