SOLVED Since upgrade from 18.3 to 19.0 my network printer Canon I-sensys MF8540Cdn doesn't work anymore

Forum rules
Before you post please read this
Post Reply
User avatar
petgil
Level 1
Level 1
Posts: 24
Joined: Tue Jan 17, 2017 6:42 pm

SOLVED Since upgrade from 18.3 to 19.0 my network printer Canon I-sensys MF8540Cdn doesn't work anymore

Post by petgil » Sun Aug 05, 2018 6:40 pm

Hi everyone, Since I upgraded from 18.3 to 19.0 (Cinnamon 64 Bit) my network printer Canon I-sensys MF8540Cdn doesn't work anymore.
I installed the latest driver provided by Canon (Did not solved the problem).
Then I removed the printer out of the system settings and rebooted the pc.
Now if I want to add the printer again in the system settings I get a CUPS error message.
"An error occurred during the CUPS-operation: 'server-error-internal-error' "
Every help/hints ect... to get my network printer Canon I-sensys MF8540Cdn working again is more then welcome.
Thanks in advance

My CUPS log file:
[06/Aug/2018:00:09:40 +0200] Unknown directive JobPrivateAccess on line 90 of /etc/cups/cupsd.conf.
E [06/Aug/2018:00:09:40 +0200] Unknown directive JobPrivateValues on line 91 of /etc/cups/cupsd.conf.
E [06/Aug/2018:00:09:40 +0200] Unknown directive SubscriptionPrivateAccess on line 92 of /etc/cups/cupsd.conf.
E [06/Aug/2018:00:09:40 +0200] Unknown directive SubscriptionPrivateValues on line 93 of /etc/cups/cupsd.conf.
E [06/Aug/2018:00:16:01 +0200] [cups-deviced] PID 3251 (gutenprint52+usb) stopped with status 1!
E [06/Aug/2018:00:16:19 +0200] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [06/Aug/2018:00:16:21 +0200] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [06/Aug/2018:00:16:21 +0200] copy_model: empty PPD file
E [06/Aug/2018:00:16:21 +0200] [Client 16] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8500C-Series) from localhost
E [06/Aug/2018:00:16:21 +0200] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [06/Aug/2018:00:16:21 +0200] copy_model: empty PPD file
E [06/Aug/2018:00:16:21 +0200] [Client 19] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MF8500C-Series) from localhost
Last edited by petgil on Tue Aug 07, 2018 9:40 am, edited 1 time in total.

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Since upgrade from 18.3 to 19.0 my network printer Canon I-sensys MF8540Cdn doesn't work anymore

Post by pdc_2 » Sun Aug 05, 2018 11:29 pm

sorry to hear of your problems;

it seems to me exactly the same problem is reported here viewtopic.php?f=51&t=273723&start=20

the phrase seems; I think: to have something to do with the airprint support that is built in;

your device is airprint compatible; as I understand the theory; you plug in the printer; Mint; running airprint; should spot it; configure it; and away you go:

do you have more than one icon in the PRINTERS folder?

(I can't test this as I am hanging back with 18.3 till the dust settles: it could take months)

.... we all use the term "upgrade" but I increasingly say to myself: is what I have .. 18.3 ...... ok .. and I have to say yes: sorry to hear you are having problems

User avatar
petgil
Level 1
Level 1
Posts: 24
Joined: Tue Jan 17, 2017 6:42 pm

SOLVED Since upgrade from 18.3 to 19.0 my network printer Canon I-sensys MF8540Cdn doesn't work anymore

Post by petgil » Tue Aug 07, 2018 9:46 am

I managed to solve the problem.
I found a part of the solution here: viewtopic.php?f=51&t=273723&p=1506785#p1506785
Just installed the latest driver provided by Canon and registered the printer with lpadmin in a terminal.
Works fine now
Last edited by Moem on Tue Aug 07, 2018 9:54 am, edited 1 time in total.
Reason: Fixed a link

Post Reply

Return to “Printers & Scanners”