Page 1 of 1

Printing problem in Linux Mint 19

Posted: Sat Aug 25, 2018 9:44 am
by ktziotis
Hello.

I am facing the following printing problem after installing Linux Mint 19 Cinnamon 64-bit.

After Mint 19 installation I added with Software Manager Printer-driver-escpr.

Then I added normally my printer (EPSON Stylus Office BX305FW Plus) through Menu -> Administration -> Printers -> Add. I have done the same procedure many times since I started using Linux Mint from version 17. Printer is defined as a Network Printer and is Wi-Fi connected. During printer setup I printed the test page and everything seemed to be working fine.

After printer's set-up I opened its properties and I changed the Saturation through Job Options -> Image Options -> Saturation. After that when I tried to print the job failed. Actually the system seemed to be hung-up. The printer was not responding, but the job appeared to be running under the View Print Queue. When I tried to close the View Print Queue window the system did not respond. I tried also to close the Printers-localhost window, but this action also failed. Finally I had to restart my computer.

After reboot I tried once again all the above and I got the same results. I restarted the computer and after reboot I deleted the printer. Then I added the printer from scratch. During printer set-up I printed again with success the test page. I printed several documents from different applications and no problem appeared.

Then after a few days I changed another property through Menu -> Administration -> Printers -> EPSON Stylus Office BX305FW Plus -> Properties. When I applied the changes I had again the same printing failure.

I made other efforts to fix the problem. I also tried to set-up the printer by using the CUPS Web Browser Interface (http://localhost:631). No success. I got the same result after each try to apply any property's change through Menu -> Administration -> Printers -> EPSON Stylus Office BX305FW Plus -> Properties.

I also thought that it might be a hardware's malfunction, but I have the same problem in all Mint 19 installations in three different computers, one desktop and two laptops.

I appreciate any help of yours.

Many thanks.

Re: Printing problem in Linux Mint 19

Posted: Sat Aug 25, 2018 10:13 am
by deepakdeshp

Re: Printing problem in Linux Mint 19

Posted: Sat Aug 25, 2018 10:44 am
by ktziotis
Printer is Ok. I can print from Windows 10 and I also can print from Linux Mint 18.3 Cinnamon 64-bit.

As I wrote, I can print from Linux Mint 19 Cinnamon 64-bit, but only if I do not apply any change to the properties of the printer...

EPSON Stylus Office BX305FW Plus

Posted: Sat Aug 25, 2018 2:52 pm
by pdc_2
so if I was starting from the beginning, I would start at the linux portal for Epson http://download.ebz.epson.net/dsc/searc ... ch/?OSC=LX and enter 305 and end up as in the attached thumbnail; the full-feature was issued in 2012 .. but ..

I see the latest driver issued was 3 weeks ago: 1st August 2018 so that sounds promising (maybe though it is more generic than the full-feature ..)

to download the generic; issued 3 weeks ago; one goes here http://download.ebz.epson.net/dsc/du/02 ... 4ae09fe5a5 and if one opts for 64bit debian, one goes for epson-inkjet-printer-escpr_1.6.23-1lsb3.2_amd64.deb

clicking to download; and selecting OPEN should mean gdebi installer will leap in and offer to open; that should mean install; so that is good;

to register a printer one needs to do at least 2 things: 1) install the drivers and 2) register the printer with lpadmin

installing the drivers usually triggers the Mint system to do 2) as well; so just "opening" the downloaded deb package; with gdebi installer; should trigger 2)

If your existing icon(s) in the PRINTERS folder do not work; maybe delete them before doing the above .. as they don't seem to work: does any of this help?

Re: Printing problem in Linux Mint 19

Posted: Sun Aug 26, 2018 12:08 pm
by ktziotis
Thanks for the suggestion, but I already tried it. I don't think that the problem has to do with the driver, because the printer works fine unless you try to change any of its properties. I suspect that applying the changes of the properties it confuses the system, so probably some permission rules might be involved. I also think that it might be some CUPS bug. Linux Mint 19 Cinnamon comes with CUPS 2.2.7 instead of CUPS 2.1.3 of Linux Mint 18.3 Cinnamon.

Re: Printing problem in Linux Mint 19

Posted: Mon Sep 10, 2018 7:55 am
by pdcurtis
I have had similar problems with printing using an Epson SX510w due to a regession in the Gutenprint version 5.2.13 driver.

This was a major issue in my case was that the printed images were completely unacceptable and could not be adjusted in printer settings. I tried adjusting in various programs such as LibraOffice and the image viewer as well as in Printers itself with little effect. Comparison with a different machine showed that a different version of gutenprint print driver was in use in Mint 18.3 where the results were perfectly acceptable without any adjustment. I found that going back to the version 5.2.11 used in Mint 18.3 gave me a perfect working printer as in Mint 18.3.

So what I did, (which may not be the best way but is largely GUI based) was to:

Delete the existing printer in System Settings -> Printers
Use the Synaptic Package Manager and search for gutenprint which should show there are two packages installed.
Uninstall libgutenprint2 and printer-driver-gutenprint (both were version 5.2.13) then close the Synaptic Package Manager
Now we need replacement versions 5.2.11 which I found in Ubuntu Xenial (equivalent to Mint 18) so go to
https://packages.ubuntu.com/xenial/amd6 ... 2/download
and https://packages.ubuntu.com/xenial/amd6 ... t/download
and download them both from an appropriate local link on the pages.
First right click on the libgutenprint2_5.2.11-1_amd64.deb package you have downloaded and open with the gdebi and install ignoring the messages that there is a newer version in the repositories
Repeat for the printer-driver-gutenprint_5.2.11-1_amd64.deb package
Reinstall the Printer
Test

If it is all working you have to make sure they are not updated by the Update Manager and so open the Update Manager and Refresh after which printer-driver-gutenberg which will show as being updated. Do not update but use a right click on the package -> ignore updates for this package.

Hope this helps others

Re: Printing problem in Linux Mint 19

Posted: Mon Sep 10, 2018 9:49 am
by ktziotis
Many thanks to pdcurtis for the suggestion. I tried your method step by step, but unfortunately I got the same results. Printer works fine unless I change any of its properties. If I apply any change to its properties then all next print jobs are showing the message "Printing completed", but nothing is actually printed by the printer. So it doesn't seem that gutenprint version affects this issue. Anyway many thanks for the effort.

Re: Printing problem in Linux Mint 19

Posted: Mon Sep 10, 2018 10:56 am
by CJC
Thanks PDCurtis. WIll give this a try in the next few days. I reported in detail the issues with Tara(LM19) and the printer sub-system from the very first few days of the beta program and followed it up with more detail info from further testing and as requested to no avail. Sadly despite providing all the requested info nothing was fix. Unfortunately, LM19 has been a bad regression that broke the printer options handling function as reported by many people.