nightmare with epson XP-445 scanner

Forum rules
Before you post please read this
Post Reply
User avatar
squid-f
Level 1
Level 1
Posts: 16
Joined: Fri Nov 07, 2014 8:19 pm
Location: Lyon, FR

nightmare with epson XP-445 scanner

Post by squid-f » Mon Aug 27, 2018 7:35 am

Hi all

I am currently in a true nightmare with the scanner of my epson XP-445.

I started to use the ubuntu tutorial on epson installation.
I created the file /lib/udev/rules.d/40-libsane.rules with the ids provided by lsusb
Then, I modified /etc/sane.d/epson.conf and /etc/sane.d/epson2.conf with, as well, the ids provided by lsusb

Epson Iscan software was not working even after install epson iscan package but Simple Scan and gscan2pdf were working.
At least it has worked until a point (I don't remember which one) and I have a random detection (not to say a seldom detection) of the scanner. Printer has always been working.

lsusb always finds the scanner.
scanimage -L finds it every time on sudo mode
sane-find-scanner doesn't find it when scanimage -L finds it only on sudo

I am bit desperate now. In fact, even if I remove /lib/udev/rules.d/40-libsane.rules, it doesn't change anything. Detection is always random and seldom.
What I did recently is to create /etc/sane.d/epkowa.conf in a same way epson2.conf is set. I then added epkowa on /etc/sane.d/dll.conf. It seems to have an effect as, when the scanner is detected, it is identified under XP-445 and not PID1114 as it used to be with only epson2.conf modified.
I tried as well to uncomment epson on dll.conf and to comment out epson2 but it does solve the issue.

So, any support, even ideas of new track to follow, would be very helpful.

I am on LM19 cinnamon with the latest Kernel proposed on Mint Update.

Thanks !

User avatar
squid-f
Level 1
Level 1
Posts: 16
Joined: Fri Nov 07, 2014 8:19 pm
Location: Lyon, FR

Re: nightmare with epson XP-445 scanner

Post by squid-f » Mon Aug 27, 2018 1:21 pm

Hi again

I found the post : viewtopic.php?f=51&t=272874 interesting.

In fact, I might have mixed up things but now, sudo sane-find-scanner returns :

Code: Select all

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
found USB scanner (vendor=0x04b8, product=0x1114) at libusb:003:006
could not fetch string descriptor: Pipe error
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
saneimage -L doesn't find any scanner, with or without sudo

As I have the Pipe error by running sane-find-scanner I thought the post I refer to above could be a solution.
However, the folder /usr/lib/sane doesn't exist on my installation. I installed iscan package from epson site but it doesn't change anything.

I am then stuck at the first step of the solution provided which is : sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/i386-linux-gnu/sane

Any tip is welcome. I am lost...

Thanks


User avatar
squid-f
Level 1
Level 1
Posts: 16
Joined: Fri Nov 07, 2014 8:19 pm
Location: Lyon, FR

Re: nightmare with epson XP-445 scanner

Post by squid-f » Mon Aug 27, 2018 4:38 pm

Hi administrollaattori

Yes, I have all of that. I have been back and forth between the LM stock escpr and the one provided by Epson. No scanner behavior change. The new drivers allow to have access to the ink level though.

Any other idea ?

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: nightmare with epson XP-445 scanner

Post by pdc_2 » Mon Aug 27, 2018 7:28 pm

I thought I had bookmarked the page; but I can't find it now .. !!

but a bug report on Ubuntu last year recommended

Code: Select all

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane
eg in this post: https://askubuntu.com/questions/1034528 ... 22_1034528

User avatar
squid-f
Level 1
Level 1
Posts: 16
Joined: Fri Nov 07, 2014 8:19 pm
Location: Lyon, FR

Re: nightmare with epson XP-445 scanner

Post by squid-f » Tue Aug 28, 2018 1:30 am

Thanks pdc_2 for your support.

Yes, I saw this post on the bug and I tried to use the same solution.

However, the folder /usr/lib/sane doesn't exist on my installation.

I am then stuck at the first step of the solution provided which is : sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/i386-linux-gnu/sane

Post Reply

Return to “Printers & Scanners”