Unable to Print Documents

Forum rules
Before you post please read this
Post Reply
icek
Level 1
Level 1
Posts: 1
Joined: Thu Sep 20, 2018 8:27 am

Unable to Print Documents

Post by icek » Thu Sep 20, 2018 8:42 am

I have just switched to linux mint and have been having a problem trying to print a word document. I have an epson L382 printer as well as a Hp Laserjet P2014. i am able to connect to the printers automatically but when I try to print it using the Epson printer, the printer prints out blank pages. On the HP nothing happens although its showing a notification on the panel that its printing.
i have tried running the printing troubleshooter which showed that no system journal entries were found and suggested i run the following command on terminal
su -c 'journalctl -u cups.service --since="None" --until="2018-09-20 15:10:11"' > troubleshoot-logs.txt

when i do so it shows su: Authentication failure. How can I fix this issue?

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Epson L382 needs Epson linux drivers

Post by pdc_2 » Thu Sep 20, 2018 1:11 pm

Hi icek welcome to the Mint forums

best you install a linux driver for the L382

if you go here http://download.ebz.epson.net/dsc/du/02 ... 382b28ef04 and click to ACCEPT, then on the next screen, if you have 64bit Mint,

select epson-inkjet-printer-201601w_1.0.0-1lsb3.2_amd64.deb and click to download ... try to choose the OPEN option; as that means gdebi installer should install it and trigger a registration: this package is the driver and then you need to register the printer with lpadmin on your system: the admin for linux printing (lp) inside your install of Mint; this second bit should be triggered by installing the driver;

(best go to the PRINTERS folder; before doing the above; and delete any existing entries for the L382; as, if they do not work now, best remove them ..)

Post Reply

Return to “Printers & Scanners”