Page 1 of 1

[Solved?] Linux Mint 19 and Canon MF244dw

Posted: Sun Sep 23, 2018 3:27 pm
by horizon81
I have a Canon MF244dw. I have used it on previous versions of Linux Mint without any major problems (aside from the scanner, which I got working). I recently upgraded to Mint 19 and the printer no longer functions. So far I've tried:
Installing the Canon x64 drivers individually
Installing through
Installing x32 dependencies and trying the x32 files

So far nothing has worked. While the system detects the printer just fine over a network and I can connect to it, it won't print correctly. The test page is either gibberish or does not print at all. The self test page lists the following:

Code: Select all

   userdict dup(\004)cvn{}put (\004\004)cvn{}put
%%%If you can read this, you are using the wrong driver for your printer.%%%	
Any help welcome. I would really like to get this thing working as soon as possible, thanks.

Re: Linux Mint 19 and Canon MF244dw

Posted: Sun Sep 23, 2018 4:13 pm
by JerryF
From the Canon drivers download, there is a file linux-UFRII-drv-v360-usen.tar.gz

I assume that's the one you used to install the driver. After extracting/unzipping that, there is subfolder called Documents. Within that folder, there's a readme file called README-ufr2-3.6xUS.html

Did you go through that before installing the driver?

Re: Linux Mint 19 and Canon MF244dw

Posted: Sun Sep 23, 2018 6:25 pm
by horizon81
I went through the file before and after. I didn't see anything particularly noteworthy, and I did try installing the extra libraries mentioned in any case. Still didn't work. I used the printer on a x32 installation of Mint prior, but aside from that I cannot figure out why it won't work. I am usually able to solve things just by searching around, but I cannot seem to find any indication on how to resolve this issue.

Maybe there's a dependency I'm missing somewhere? But even in that case, I have installed everything with no issues and added the printer. It just won't print properly despite everything I've tried.

Re: Linux Mint 19 and Canon MF244dw

Posted: Sun Sep 23, 2018 6:33 pm
by JerryF
Shot in the dark: do you have Firewall enabled? If so, try disabling it temporarily.

Re: Linux Mint 19 and Canon MF244dw

Posted: Sun Sep 23, 2018 6:50 pm
by pdc_2
so Canon issued that 3.6 driver less than a month ago; we have had folks report various printing issues with Mint 19; where before their machines were fine on Mint 18;

sounds like you are very familiar with what to do and you have tried the options; (I see mention of 32bit: is that the system you run?)

I think Canon offer both 32bit and 64bit variants; in debian and rpm packages; as well as source code; and they warrant that the 64bit are good too;

Ubuntu have a wiki where you activate the log that records issues; can I suggest you do that and see if anything emerges in the trawl net?

go here

They mention a Troubleshooting Wizard; you find it from the Help menu in the PRINTERS folder ... or press the F1 key when the PRINTERS folder is opened ..

.. does it tell you anything? If not, ... _error_log

.. first, they tell you how to use the GUI to log issues: see picture

then using the terminal

Code: Select all

cupsctl LogLevel=debug
. and I think that just does what the above does ..


Code: Select all

cupsctl LogDebugHistory=999999
so it records lots ..

then they tell you how to record the log as an attachment to a bug report; you can file that with Mint;

Canon did test quite a few variants of their printers that use the UFR driver; with Ubuntu 18.04 and it seemed ok;

Re: Linux Mint 19 and Canon MF244dw

Posted: Sun Sep 23, 2018 8:24 pm
by horizon81
Just the regular firewall that comes with Mint. Don't think I changed anything on that end.
I'll have to check all that out tomorrow when I'm working on that station, thank you. The driver version might be the issue, and I might also try finding an earlier driver. Honestly, I didn't think it would be this much trouble to install the printer and I've already spent hours on it. As for the system, it's x64. I built a new desktop. The previous one that had the printer running was a x32.

Re: Linux Mint 19 and Canon MF244dw

Posted: Mon Sep 24, 2018 12:05 am
by pdc_2
thanks; so you just have one icon in the PRINTERS folder for the 244?

using the install script; should mean it recognises it needs debian packages; that the system is 64bit; and installs the appropriate;

and registers the printer

Canon in the users guide suggest

Code: Select all

from the terminal; to open an interface;

that allows you to register the printer on your system;

(on the lines of
sudo /usr/sbin/lpadmin -p MF244 -P /usr/share/ppdl/whatever.ppd -v <DEVICE URI>
.... the Canon utility uses the above format to do it for you ........

(I just wonder if you delete any icons in the printers folder; then run the above cnsetuputil ..... it may not make any difference but perhaps a try?

Re: Linux Mint 19 and Canon MF244dw

Posted: Mon Sep 24, 2018 6:49 pm
by horizon81
Okay, so here we go:

I've tried installing/reinstalling/registering the printer many times. It appears just fine and is registered each time, so I don't think that's the problem.
I have installed earlier versions of the various packages (re-rolling the system back each time, thanks Timeshift!) down to 2.30. Still no-go.

I did run a few of the debugging tools, and my network settings appear to check out. cups printing fails to print a test page for reasons that I am uncertain of. I also know that the printer itself works just fine because I was able to print to it from my cellphone.

I've attached the various logs. I'll dive through them a bit later, and please let me know if there is something else that comes to mind. Thanks for your continued assistance, and I don't think I'm going to figure this one out on my own :?

Re: Linux Mint 19 and Canon MF244dw

Posted: Mon Sep 24, 2018 7:22 pm
by pdc_2
I think you need to file this as a bug report to Mint; that should be accepted;

you could also refer it to Ubuntu as a bug report; as Mint comes from Ubuntu; but they may feel a specific tweak of Mint is the problem ............

Re: Linux Mint 19 and Canon MF244dw

Posted: Mon Sep 24, 2018 10:16 pm
by horizon81
Gotcha, will file it soon.

Re: Linux Mint 19 and Canon MF244dw

Posted: Wed Sep 26, 2018 5:17 pm
by horizon81

I had an old laptop that I had installed the same printer on previously. I did a bit of research on what was installed on it, and it appears that it largely functioned the same as my current installation. While the test page and self test did not print correctly, documents, images, and so on printed fine. I re-installed the 3.60 drivers, ran, and then registered the printer on Mint 19.

End result is that I can print things fine, but test and self test pages still give problems. Since the latter is not a huge deal, I am not going to bother trying to resolve it. As a bonus, the scanner was detected right away with XSane (which wasn't the case the last time I tried getting it to work).

I am calling this one resolved for now. Maybe the test and self test pages will work in Mint 20 :lol:

Re: [Solved?] Linux Mint 19 and Canon MF244dw

Posted: Wed Sep 26, 2018 9:53 pm
by pdc_2
so this seems curious; 2 separate installs of Mint 19; on the first one, the 244 did not work; on the second install, it did;

and both were the most recent 3.6 UFR driver; were both 64bit installs, of the same DE? .. ie mate or cinnamon?

Re: [Solved?] Linux Mint 19 and Canon MF244dw

Posted: Thu Sep 27, 2018 6:38 am
by horizon81
The other install was on Lubuntu 18.04. It had a driverless cups printer installed; not sure if I ever tried testing any other drivers.

I also still have a hard drive with an earlier version of Mint that had the printer installed, but I never got a chance to test it out. I might update this topic if I ever do. So Lubuntu 18.04 and Mint 19 do not print test and self test pages, but an earlier version of Mint did print the test and self test pages (Mint 17 maybe?).

Re: [Solved?] Linux Mint 19 and Canon MF244dw

Posted: Fri Jan 18, 2019 1:02 am
by emmfranklin
I had canon ir3230 working absolutely fine in linux 17.
when i upgraded to linux 19 the printer stopped working.

two days of trial and error and nothing worked.

finally i did these steps and i don't know at which point the problem got solved.

i am writing this method for canon ir3230.
you may modify it for your own printer

i am not an expert linux . so i wont be able to give details . ill do my best.

my steps are copy pasted from various forums

remove cups and reinstall cups.

i tried removing cups and then tried reinstalling cups . i seem to have broken few packages so i did this.

update linux
this is the command
sudo aptitude update && sudo aptitude install gtkorphan

Continue by running:

sudo aptitude update && sudo aptitude upgrade
This is used to double-check that you have all the updates.

To clear out the broken packages use the command:

sudo aptitude -f


go to synaptic edit click fix broken packages

now install cups

how to install cups

restart cups
sudo /etc/init.d/cups restart
restart ccpd in case you have it.

remove/delete canon ir3230 entry from printer dialog box
remove canon printer driver utility

reinstall canon printer driver utility from the command only
use this command
cd linux-UFRII-drv-v350-uken

sudo ./

reinstall your specific printer from utility

restart pc
no print

open printer dialog box
right click ir3230
click properties
click change from make and model
select option of provide ppd file
and give this file

you will get this file

select canon image runner 3225 in the drop down
reinstall from ppd file

now test page printed
it works