Page 1 of 1

[SOLVED] Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 10:42 am
by bjornmu
I previously had problems with the scanner part of the printer/scanner in Mint 17: I could only scan the whole page in 300 dpi. I was hoping this would get better with Mint 19.

Now I finally got another desktop and have installed Mint 19. But now it's even worse. :-( I did install the driver and scangearmp2 from Canon. scangearmp2 does find the scanner but as before I only get a very basic interface which lets me scan the whole page in 300 dpi.

Bue XSane cannot find it. It says no devices found. sane-find-scanner says:

found USB scanner (vendor=0x04a9 [Canon], product=0x1825 [TS5100 series]) at libusb:001:013
could not fetch string descriptor: Pipe error
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

scanimage -L says it cannot find it.

What am I missing? I did remember this that I had to do on the other box:

echo "canon_pixma" >> /etc/sane.d/dll.conf

Re: Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 1:45 pm
by deepakdeshp
https://sites.google.com/site/easylinuxtipsproject/17
There is a section on Cannon in the site.

Re: Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 1:59 pm
by bjornmu
Thanks but that only explained how to install Canon's very basic scanner app, and I did get that to work. What I'm missing is being able to run from xsane and hopefully get some more options besides scanning the whole page in 300 dpi. The scanner is supposed to support up to 1200x2400.

Update: I found a tip of turning on debug so I set SANE_DEBUG_DLL=128 before running scanimage -L. It loads all the backends include the pixma one, then is simply says:

[dll] sane_get_devices: found 0 devices

So I think this is related to the device not being found on USB. On my Mint 17 box I do not get the error "could not fetch string descriptor: pipe error".

Re: Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 2:04 pm
by phd21
Hi bjornmu,

I just read your post and the good replies to it. Here are my thoughts on this as well.

You might have been better off using Linux Mint ver.18.3 rather than going from Linux Mint ver.17.x to ver.19.

Simple scan in mint 19 - Linux Mint Forums
viewtopic.php?f=47&t=274108&hilit=sane


Hope this helps ...

Re: Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 2:30 pm
by bjornmu
How should I have known that an older O/S might be better? I want to have a Mint version that will be supported for a number of years ahead.

Edit: interesting observation: man sane-pixma on Mint 17 says PIXMA TS5000 is supported, but on Mint 19 it is instead on the list that "have not yet been reported to work (or not).". The man page is dated *yesterday* while the man page on Mint 19 is from May 2017. So it may look like Mint 19 has an older version of the backend library.

Re: Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 2:44 pm
by phd21
Hi bjornmu,

You could ask first. Linux Mint 18.3 has long-term support (LTS) until 2021 as stated on the Linux Mint download webpages release announcement. Linux Mint 19 has LTS until 2023 and it is still a new major release.

As with most major operating systems when new major releases come out it can take a little time to "mature" and resolve any issues that come up. Linux Mint 19 seems stable to me, but if you check the forums you can see there are still issues with somethings. A fair amount of software available in previous versions were simply not available for Linux Mint 19.x based on Ubuntu 18.04 Bionic yet, although you could still install the Linux Mint 18.x software based on Ubuntu 16.04 Xenial, and then other updated software that was only available outside of the Mint repositories was now available through the Software Manager or Synaptic Package Manager (SPM) which is great.

In the Link I provided, there are updates available for scanning related software that may resolve your issues in Linux Mint 19.x. I have to assume that you have already checked for and installed any current Canon Pixma TS5150 Linux drivers (assuming there are any and it looks like there is). Restart your computer after installing these.

Use Linux debian links whenever you can versus source files in the links below for easy to install "deb" files, may have to extract archive file first to get to the deb files.

Canon PIXMA TS5150 Driver Series Download
http://www.canonprintersdrivers.co/cano ... 50-driver/

PIXMA TS5150 - Support - Download drivers, software and manuals - Canon UK
https://www.canon.co.uk/support/consume ... 20(64-bit)

Hope this helps ...

Re: Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 3:06 pm
by bjornmu
Ok it just seems a bit odd that my Mint 17 (based on Ubuntu 14.04) has a more updated sane library. I have noticed that the sane-backends get updated quite often. Yes I installed the drivers from Canon but these are not of any help for using xsane. I also tried to download Vuescan which was mentioned, and gscan2pdf. They could not find the scanner either. Only Canon's proprietary program could and it also produced a scan, so that proves the scanner and the USB connection works.

I may have to wait for an update to the sane-pixma backend. I don't have an urgent need for advanced use of the scanner just yet. But according to the man page, it should still recognize and activate the scanner even if it may or may not work. It does say TS5000 and not TS5100 so maybe my scanner is not actually on the list yet.

Re: Sane cannot find my Canon Pixma TS5150

Posted: Sun Sep 30, 2018 8:48 pm
by pdc_2
Hi there Bjorn up there in Trondheim; sorry to hear of your issues; it must be very frustrating; very irritating;

Mint comes from Ubuntu; Ubuntu is noted for fast paced development; they had several major changes of things in the last couple of years; lots of changes; they wanted to have a unitary OS that would go on all from desktops to mobile phones; that didn't pan out it seems; so even the LTS (long-term support) release of 18.04 does seem to need some settling in ... so Mint 19 needs that too .... new adopters find issues; they get fixed hopefully; and those sluggish laggards who hang back for quite a while; probably get a smoother ride when they do finally adopt;

so for anyone else reading this thread, SANE is the open-source engine to attempt to drive as many scanners as possible;

and ScanGearMP is what Canon provide for their scanners;

for SANE: (open-source) ... they issue a standard version; and a development version; more updated; it seems essentially stable; all it does is add the latest tweaks as I understand it;

so one could try installing that; it is called the Rolf Bensch PPA https://launchpad.net/~rolfbensch/+arch ... u/sane-git

instructions on the page; please ask for more detailed instructions if you would need them.

various commands are suggested to troubleshoot scanner issues: you probably know them well

Code: Select all

sane-find-scanner

Code: Select all

scanimage -L
and then repeat them with sudo in front of each command; if you want to post back here what you get; like you, we can google and try to see if any threads of light are out there;

as I understand it, with scanners the data goes in and out between computer and scanner; (whereas with a printer, it is usually uni-directional): so potentially security issues with that in an OS: there are some threads where one changes the permissions of the scanner; so that maybe data flows more easily from scanner to computer (chmod)

Re: Sane cannot find my Canon Pixma TS5150

Posted: Mon Oct 01, 2018 11:55 am
by bjornmu
A-ha, now I see that I had added this repo on the Mint 17 box to get the latest sane. That explains why I got so frequent updates and why it had a newer version.

Now I added this on the Mint 19 and got the same version of sane-pixma. BUT xsane still cannot find the scanner! Something more fundamental is broken it seems. I have tried two different USB 2.0 ports on the box just in case.

I tried adding a 'usb' line to /etc/sane.d/pixma.conf but than made no difference. Plus I did not have that on Mint 17 and it still worked.

[SOLVED] Sane cannot find my Canon Pixma TS5150

Posted: Tue Oct 09, 2018 2:59 pm
by bjornmu
Success! :D Although a bit of frustration at first. :?

I got an update to the "bleeding edge" sane-backends and noticed the sane-pixma man page was updated with info that Pixma TS5100 was on the list of scanner series that were now recognized, though not guaranteed to be fully supported.

So I turned it on, tried xsane and it did find the scanner! But then it just gave me a pop-up saying "Failed to open device pixma:04A91825: Device busy". scanimage -L reports it finds the scanner but plain scanimage gives the same device busy error even as root. I have googled but could not find any mention of a solution or even an explanation for that particular problem.

I was just about to post in frustration here when it occurred to me that it *could* be related to USB 2.0 vs. 3.0 and I wasn't sure what the USBs on back of my desktop are. But on top it has two clearly labelled 2.0 so I tried. Lo and behold, now it worked! I even don't have the limitations as before, I can select a part of the preview and scan at higher res. It does not give me the mixed resolution of 1200x2400 which is the maximum but that's OK. I moved the USB to the back again and it still works. So never mind the initial problem, now I can scan my stamps! :lol: