HP 5530 printer not found by hplip

Forum rules
Before you post please read this
Post Reply
icemeister
Level 1
Level 1
Posts: 17
Joined: Fri Sep 07, 2018 3:44 pm

HP 5530 printer not found by hplip

Post by icemeister » Mon Oct 22, 2018 9:11 pm

it looks like missing dependences are missing. software manager says they are in stalled. I have tried to install hplip by software manager and by terminal with no success. following is the error i am getting. This is a fresh install i am setting up.

error: No PPD found for model envy_5530 using old algorithm.
error: No appropriate print PPD file found for model envy_5530_series
DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo apt-get install --assume-yes libcups2'
Please wait, this may take several minutes...
error: A required dependency 'cups (CUPS - Common Unix Printing System)' is still missing.
Thanks for any help

srq2625
Level 4
Level 4
Posts: 360
Joined: Tue Jan 08, 2013 11:35 am
Location: State: Constant Confusion, Country: D'oh

Re: HP 5530 printer not found by hplip

Post by srq2625 » Tue Oct 23, 2018 6:35 am

My printer is still new enough that I have to download the driver source and compile it because the version I need is not in the repos. Part of the process of doing the compile is installing all required dependencies. The following command installs all the "cups related" dependencies:

Code: Select all

apt update
apt install cups libcups2 libcups2-dev cups-bsd cups-client libcupsimage2 libcupsimage2-dev cups-filters
Maybe the above will solve your cup-related dependency issue.

icemeister
Level 1
Level 1
Posts: 17
Joined: Fri Sep 07, 2018 3:44 pm

Re: HP 5530 printer not found by hplip

Post by icemeister » Tue Oct 23, 2018 9:46 pm

Thank you for the code. I did install and it made no difference. I am not seeing the printer at all. When i plug in and do a set up all works but as soon as i unplug all disappears. Neither the HPLIP or Printers can find the printer. I looked in software manager and the HP- cups and HP-ppd is installed. I feel i made an error somewhere that is causing this to happen. May be network settings? i will look but as a newbie i am not sure what i am looking at. any help would be great.
Thanks

ajgringo619
Level 4
Level 4
Posts: 473
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: HP 5530 printer not found by hplip

Post by ajgringo619 » Tue Oct 23, 2018 11:16 pm

Is the printer using WiFi? What about DHCP? I found that using static IP addresses worked better with my Envy 4520.
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-39-generic, GeForce GTX 960 w/Nvidia 410.73]
Image

icemeister
Level 1
Level 1
Posts: 17
Joined: Fri Sep 07, 2018 3:44 pm

Re: HP 5530 printer not found by hplip

Post by icemeister » Tue Oct 23, 2018 11:53 pm

yes the printer is on wifi. one of the hplip settings was to connect to printer run set up and then disconnect. I have just updated the router firmware and will give it a go and see if i can reset it up.
thanks for the suggestion i will be back

ajgringo619
Level 4
Level 4
Posts: 473
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: HP 5530 printer not found by hplip

Post by ajgringo619 » Wed Oct 24, 2018 12:13 am

Here's how I have setup my printer using hp-toolbox; this has worked on every Linux system I've tried it on:
Attachments
Screenshot_2018-10-23_21-11-09.png
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-39-generic, GeForce GTX 960 w/Nvidia 410.73]
Image

icemeister
Level 1
Level 1
Posts: 17
Joined: Fri Sep 07, 2018 3:44 pm

Re: HP 5530 printer not found by hplip

Post by icemeister » Wed Oct 24, 2018 2:07 am

Yes i have tried this and it can not find the printer. I have set the printer a static ip and i can see the printer in the router. I pinged the router in terminal and not able to find device. I am now looking at setting a rule in firewall to see if that works. Just so you know this is a huge learning for me as i have never done anything like this before.

Thanks for your input

icemeister
Level 1
Level 1
Posts: 17
Joined: Fri Sep 07, 2018 3:44 pm

Re: HP 5530 printer not found by hplip

Post by icemeister » Wed Oct 24, 2018 2:56 am

OK tried to set a rule and it didnt work. turned firewall off still not working. tried a bunch of hp help cmds with no luck. here is my guess whatever program in mint is not seeing the router as the printer is listed in router. I can not figure out how to open ports that hp says should be open for hplip to use. 9100 and 161 i think. ran a cmd that says 999 ports closed and only tor port open. I really am at a lose as to what to try next or go back to the first timeshift and lose a week of setting this up.
thanks

Post Reply

Return to “Printers & Scanners”