Crazy problem with Brother hl1112 printer driver on mint 19 Xfce [SOLVED]

Forum rules
Before you post please read this
Post Reply
davidlondonuk
Level 1
Level 1
Posts: 4
Joined: Sun Mar 18, 2012 2:14 pm

Crazy problem with Brother hl1112 printer driver on mint 19 Xfce [SOLVED]

Post by davidlondonuk » Tue Oct 23, 2018 10:44 am

Hi,

I am trying to install the printer driver for a Brother HL-1112 printer using the linux-brprinter-installer-2.2.1-1 on Linux Mint 19 Xfce (64 bit).

When I ran the installer it wanted to install a deluge of i386 32 bit packages, roughly about a 100 completely unnecessary packages - which looked like a good way of messing up the Mint 19 64 bit system. Using another Ubuntu based Xfce distro on the same Dell PC the only dependencies were: libc6-i386, lib32gcc1, lib32stdc++6.

Is there another way to get this printer working without filling the system up with a lot of useless and probably conflicting i386 32 bit packages?

Thanks for any help.

SOLVED

I have no idea what the latest Brother driver installer is trying to do but I managed to get the printer working with the following steps:

Code: Select all

sudo apt install libc6-i386 lib32gcc1 lib32stdc++6
sudo dpkg -i --force-all hl1110lpr-3.0.1-1.i386.deb
sudo dpkg -i --force-all hl1110cupswrapper-3.0.1-1.i386.deb
The deb packages are on the Brother website.

Post Reply

Return to “Printers & Scanners”